Skip to main content
Topic solved
This topic has been marked as solved and requires no further attention.
Topic: [SOLVED] Missing services spice-vdagentd and qemu-ga (Read 62 times) previous topic - next topic
0 Members and 1 Guest are viewing this topic.

[SOLVED] Missing services spice-vdagentd and qemu-ga

The problem as the title says, is that when trying to start the qemu-ga and spice-vdagentd services, openRC tells me that these services do not exist, even though these packages are installed, I check the / etc / init directory. There are no scripts for qemu-ga nor those for spice-vdagentd. Meanwhile in the / usr / bin directory if the qemu-ga and spice-vdagentd daemons appear, do you know if I can create a script and bind these with the corresponding daemons?
PS: I tried to create a script for qemu-ga, but when starting the service, it gets crashed. So I have the qemu-ga script like this


# cat /etc/init.d/qemu-guest-agent
#! / sbin / openrc-run

name = "QEMU Guest Agent"
pidfile = "/ run / qemu-ga.pid"
command = "/ usr / bin / qemu-ga"
command_args = "- m $ {GA_METHOD: -virtio-serial} -p qemu-ga -p / dev / vport2p1 -l /var/log/qemu-ga.log -d"

I currently have no script for spice-vdagentd

I appreciate in advance any help you can offer[/i]

 

Re: Missing services spice-vdagentd and qemu-ga

Reply #2
@artoo Are you fine with me adding these?

Re: Missing services spice-vdagentd and qemu-ga

Reply #3
These packages have been added and will be available once the mirrors sync