Skip to main content
Topic solved
This topic has been marked as solved and requires no further attention.
Topic: [SOLVED] No window open with Wlan active (Read 564 times) previous topic - next topic
0 Members and 1 Guest are viewing this topic.

[SOLVED] No window open with Wlan active

Hi!

I have a strange problem with my installation.

When I use Wlan I can't open any program anymore. If I try to open a program in the terminal I get the following output:
Code: [Select]
No Protocol specified
Unable to init server: Connection failed: Connection setup rejected
Error: connato open display: :0

What is this and how can I solve this problem?

I use OpenRC if this is important. I tried it with KDE and XFCE but both have the same behaviour (both with a fresh installation).


Re: No window open with Wlan active

Reply #2
Yes, and it worked for four days (after a fresh installation with a weekly ISO, all others won't work). I don't know what this failure caused.


Re: No window open with Wlan active

Reply #4
I changed the hostname to another one and now it works. I haven't used localhost or any other system relevant hostname so I still don't understand why my hostname didn't worked. In any other Distro I used the same and had no problems.

Anyway, thanks for your help and the link! Now I know what caused this failure.

Re: No window open with Wlan active

Reply #5
I changed the hostname to another one and now it works. I haven't used localhost or any other system relevant hostname so I still don't understand why my hostname didn't worked. In any other Distro I used the same and had no problems.
I do not know the answer to your problem, and I will let the specialists answer you.
But I had read that the hostname could be a problem :
https://forum.artixlinux.org/index.php/topic,2700.msg17826.html#msg17826

Quote
Anyway, thanks for your help and the link! Now I know what caused this failure.
With pleasure 8-)



Re: No window open with Wlan active

Reply #7
@strajder

What do you want me to say with your links? I know what a hostname is and how it should be named.

So, then tell me what was wrong with my hostname "grid"?

With "grid" as hostname and wlan activated no programs can be opened. I changed it to "thegrid" and now it works.

And I have to say that this behaviour is only in Artix, on all other Distris I can use "grid" as hostname without a problem.

Re: No window open with Wlan active

Reply #8
Just tried setting my hostname to "grid" without any errors. Proof:

https://i.imgur.com/ofB1TlP.png

Notes:

1. I'm using 66.

2. When setting the hostname with hostname grid as root, X programs will from that point on refuse to start in the currently running X session, which is expected (this isn't related to the name "grid" itself). I had to do 66-env [email protected] as root and set the hostname there, followed by 66-enable -F -t boot [email protected] and reboot to be able to properly set the hostname to "grid" and test the rename.

Without more details about your problem, it's hard to say. For example, you only mentioned what was the actual hostname which was failing now. Maybe someone could help you more if you described the steps you did when setting the hostname to "grid" more thoroughly and gave the links to relevant configuration files (using paste.artixlinux.org for larger files).

Re: No window open with Wlan active

Reply #9
Which steps? As I mentioned I did a fresh install and set the hostname with the installer, nothing else.

And I can't describe more because there's nothing more to say except what I said.

Re: No window open with Wlan active

Reply #10
I got the same problem, with the wlan that, casually, locked or not the execution of every program if the notebook is connected. You disconnect it from the wlan and all start regularly, despite the connection to the lan, obviously.
It happen to me with 2 different notebook of Tuxedo (the GEN1 model). It work correctly when I'm in office, don't work with the lan of Customer A, work with Customer B, but not always and so on.
Sometime simply disconnecting and connecting to the lan, via WIFI, is sufficient to have all work correctly. Its an error that is a lot less frequent, at least for me, from 2 months, more or less.

The hostname in not localhost.

I thought about a problem with connman, I'm using networkmanager, but I'm not sure. Anyway I removed connman from the program started automatically.


Re: No window open with Wlan active

Reply #11
Which steps? As I mentioned I did a fresh install and set the hostname with the installer, nothing else.
That is a description as well. But you didn't include the "nothing else" part in the OP. Every bit of information is important, because it helps narrow down the problem.

Your init is important, because in addition to narrowing down the problem, the exact commands in the solution will differ if it involves dealing with services.

So far we have determined that the problem doesn't depend on the particular hostname that is given to the computer - "grid" is not special in any way.

This is just a speculation, but I'd say that the problem could be in not activating the dhcpcd service. In OpenRC:
Code: [Select]
$ su
# rc-service dhcpcd start

The hostname service in OpenRC just reads /etc/hostname and runs the command hostname with whatever it read from that file as the argument (check with less /etc/init.d/hostname).

Without logs, we can't be sure what's wrong with your system.

I happen to have a laptop with a built-in wifi adapter, but unfortunately I cannot reinstall Artix on it just for the sake of testing this. Wifi works perfectly on it under Artix base with 66 init, and there are no problems with starting X programs.

Re: No window open with Wlan active

Reply #12
Check /var/log/rc.log (perhaps paste it to pastebin or similar after redacting it with sed or similar if there was any sensitive info in it) and if the hostname setting worked you might see something like this:
Setting hostname to grid from /etc/hostname ...
 [ ok ]
not:
Failed to set the hostname
Testing this on 2 Artix OpenRC  laptops, one with the internal wifi card and the other with a PCMCIA card (also on the PCI bus) I had no problems using grid or nf220 which I think was the name that gave me problems on another laptop. But these 2 had a base install and lack a regular network manager app, whereas the one I had problems with was a fairly default Mate (iirc) iso install.

Re: No window open with Wlan active

Reply #13
Your init is important, because in addition to narrowing down the problem, the exact commands in the solution will differ if it involves dealing with services.

In the first post I wrote that I use OpenRC and tried with XFCE and KDE (now I'm on KDE), both fresh installs.

I will give the logs if this issue happens again.

I think it's the wrong driver for this Wlan card because sometimes the connection get lost and it takes sometime to connect again. I will have a look which hardware the laptop has.

Re: [SOLVED] No window open with Wlan active

Reply #14
I was so annoyed by the problem that I first installed another distribution.
Actually, I am still interested in the error, so I just installed Artix again.
Even before I did the first update (I used the same weekly Iso from 30.08. like the last time, and the exact settings), Wlan was activated, nothing worked again.
I have therefore made two screenshots where you can see the error message in the terminal.
Can it be that this is a bug of KDE with the combination of Wayland? Or isn't the KDE ISO well configured?