Skip to main content
Topic: Errors on boot & auto-mount polkit (Read 905 times) previous topic - next topic
0 Members and 1 Guest are viewing this topic.

Errors on boot & auto-mount polkit

Hey guys, so I tried to see if F2FS would work & it didn't(reported those problems in another thread)

I had to re-install on BTRFS, but I ran into some odd problems.

This is the error on boot:
Code: [Select]
Error initializing authority: Error calling StartServiceByName for org.freedesktop.PolicyKit1: GDBus.Error:org.freedesktop.DBus.Error.Spawn.ChildExited: Launch helper exited with unknown return code 1

and this is the error when plugging in USBs/SD-cards

Code: [Select]
Not authorized to perform operation (polkit authority not available and caller is not uid 0)

Re: Errors on boot & auto-mount polkit

Reply #1
guys when I run loginctl show-session $XDG_SESSION_ID 

it shows me

Remote=no
Active=yes

but I have ABSOLUTELY NO IDEA HOW TO CHANGE THIS!!!!!!!!!!!!!!!!!!!!!!!! I'm starting to get really frustrated with this, I KNOW HOW TO GET THE OUTPUT OF THIS, BUT I DON'T KNOW HOW TO CHANGE IT!!!!! WHERE IS THIS CONFIG FILE?~!?!?!?!?!!?
I've looked at so many forums threads, wiki's, etc, and I STILL CAN'T FIGURE OUT SOMETHING THAT SHOULD BE SOOOOOOOOOOOO BASIC........


There has to be something wrong with polkit or elogind.... my logout window(lxsession-logout)  also doesn't show shutdown, reboot, sleep/hibernate, etc.

Re: Errors on boot & auto-mount polkit

Reply #2
I too had this it was due to lightdm being used at install time the solution was to use sddm instead.
Note lightdm works fine after installation.