Skip to main content
Topic solved
This topic has been marked as solved and requires no further attention.
Topic: [LVM on LUKS] GRUB error - no such cryptodisk found (Read 1633 times) previous topic - next topic
0 Members and 1 Guest are viewing this topic.

[LVM on LUKS] GRUB error - no such cryptodisk found

Heyy
I got a LVM on LUKS with full disk encryption, and since the 3/4 last boots i got the exact same error as described here https://bbs.archlinux.org/viewtopic.php?id=247568 with the exact same outputs, with no clue how to resolve it
It started just after I updated cryptsetup (and regenerated my grub.cfg), did nothing else between the last boot that worked and the first that crashed
(As described in the arch topic i am able to boot by the rescue mode)
Here's my grub.cfg http://ix.io/46l5
And here my /etc/default/grub http://ix.io/46l7

Thx

Re: [LVM on LUKS] GRUB error - no such cryptodisk found

Reply #1
EDIT : tried a couple things, it appears that since the last update of cryptsetup, you need to put "cryptodisk" into the GRUB_PRELOAD_MODULES line (which was not the case before) and then it works fine

Re: [LVM on LUKS] GRUB error - no such cryptodisk found

Reply #2
I read your post and I was a little bit worried, I got a problem with encrypted disk with Manjaro and wasn't simple to solve, so I went to read the /etc/default/grub file and I discovered that, after a pacman.conf.pacnew upgrade, was added the

# Uncomment to enable booting from LUKS encrypted devices
GRUB_ENABLE_CRYPTODISK=y

I crosed my fingers, updated all, and everything work correctly without adding any parameters to the  GRUB_PRELOAD_MODULES instruction.

Maybe that this is the problem that you got?