Skip to main content
Topic solved
This topic has been marked as solved and requires no further attention.
Topic: New primary mirror (Read 4534 times) previous topic - next topic
0 Members and 1 Guest are viewing this topic.

New primary mirror

We are moving away from Sourceforge hosting, main reason being the restriction of colon characters (':') in filenames, which breaks the package database with epoch-versioned packages. Our new primary mirror is active and serving. The rest of the mirrors will sync soon.

To use the new repo, you must enable [system-testing] above [system]. After updating artix-mirrorlist from [system-testing], users will need to rename /etc/pacman.d/mirrorlist.pacnew to /etc/pacman.d/mirrorlist and re-sync.

Code: [Select]
pacman -Sy system-testing/artix-mirrorlist

After that, you can comment-out [system-testing] and wait until the updates make it to [system], or be guinea pigs bold and brave testers and report any issues.

Re: New primary mirror

Reply #1
Havn't got the new artix-mirrorlist yet perhaps it is still propagating?

Re: New primary mirror

Reply #2
is this right?
Code: [Select]
 # Artix mirrors
  Server = http://mirror1.artixlinux.org/artix-linux/repos/$repo/os/$arch
should it not be
Code: [Select]
Server = https://mirror1.artixlinux.org/repos/$repo/os/$arch
?

currently on the first format i get:
error: failed retrieving file 'world.db' from mirror1.artixlinux.org : The requested URL returned error: 404

fixing it gives no 404 error.  also both show the following:
Code: [Select]
  dbus-openrc : Orphan 
  elogind : Orphan
  eudev : Orphan
  libelogind : Orphan
  libeudev : Orphan
even though these packages all exist in [system]
http://mirror1.artixlinux.org/repos/system/os/x86_64/

Re: New primary mirror

Reply #3
is this right?
Code: [Select]
 # Artix mirrors
  Server = http://mirror1.artixlinux.org/artix-linux/repos/$repo/os/$arch
should it not be
Code: [Select]
Server = https://mirror1.artixlinux.org/repos/$repo/os/$arch
?

currently on the first format i get:
error: failed retrieving file 'world.db' from mirror1.artixlinux.org : The requested URL returned error: 404

fixing it gives no 404 error.  also both show the following:

Well the second format is correct, but the 404 error continued for me due to the "https://" instead of the "http://". This is because the server hasn't been set up with encryption yet. :/

The forum got https:// in week or two, so maybe that or less until the hosting server does?

Code: [Select]
Server = http://mirror1.artixlinux.org/repos/$repo/os/$arch

To use the new repo, you must enable [system-testing] above [systemd]. After updating artix-mirrorlist from [system-testing], users will need to rename /etc/pacman.d/mirrorlist.pacnew to /etc/pacman.d/mirrorlist and re-sync.

Uhm, nous, should [systemd] be [system]? Perhaps all that heat from the automated build server is getting to you. Maybe crack a window? :p

EDIT: Good to know, @thefallenrat. Thank you @artoo  for the timely fix!


Re: New primary mirror

Reply #5
I shall ban myself for a week for writing 'systemd'.


[EDIT]
And that was an extra week to boot.

Re: New primary mirror

Reply #6
Still havn't got the new artix-mirrorlist I assume it is the 12/09/2017 one, I can only see the 18/08/2017 one have I done something wrong?

Well it sort of worked now after I added
Server = http://mirror1.artixlinux.org/repos/$repo/os/$arch   to pacman.conf below system-testing though still a few errors where packages are newer than system-testing branch

Re: New primary mirror

Reply #7
We provide quality packages with nothing to hide! Joking aside, package mirrors don't really need https, the content is public.

Re: New primary mirror

Reply #8
So are we switching to the testing branch, updating to get the new mirror and then switching back to stable?  Or will we have to stick to testing for the time being?

(Can already tell I am going to be the slow one on this ship :D)


Re: New primary mirror

Reply #10
Instructions as I see them clear, because all of the above seemed very confusing.

1  edit /etc/pacman.conf and uncomment the [system-testing] and the line below it.
Not the world and galaxy testing, they are not ready yet.
2  edit /etc/pacman.d/mirrorlist and add 
Code: [Select]
Server = http://mirror1.artixlinux.org/repos/$repo/os/$arch
https is not working as of 20170912 - 12 UTC  but it may work in the near future?  For now use http
3  pacman -Syyu


Re: New primary mirror

Reply #11
Is the temporary repo change really necessary? I just upgraded the artix-mirrorlist with pacman -U and moved the new mirrorlist in the proper place...
Code: [Select]
# pacman -U http://mirror1.artixlinux.org/repos/system-testing/os/x86_64/artix-mirrorlist-20170912-1-any.pkg.tar.xz
# mv /etc/pacman.d/mirrorlist.pacnew /etc/pacman.d/mirrorlist

Re: New primary mirror

Reply #12
It took me a little while but I was able to get the new repo. It gave a 443 error at first but the updates went through

Re: New primary mirror

Reply #13
All fine here good work guys

Re: New primary mirror

Reply #14
The good thing about Artix for  pan-Americans and beyond-west is that by the time they wake up, if a bug comes through an update it is all solved.  Unless you are insomniacs like me, you will never have to face a bug.  And if you don't see any further updates by early afternoon chances are you are not going to see them till the next morning.

That makes testing extra-stable for you ;)