Skip to main content
Topic: Issue with updates (Read 82 times) previous topic - next topic
0 Members and 1 Guest are viewing this topic.

Issue with updates

Hey people,

My first post he so please go gentle  ;)

So I seem to have a few packages that I am having issues updating.
I migrated my Qemu-kvm box to Artix quite some time back (2015) and am looking to remove some of the older cruft still left over. All normal updates have been fine as I am quite particular on regular updates (like you do on RR systems)  but I would like some assistance in resolving the following:

Code: [Select]
[email protected] ~  trizen -Sua 
:: Package polkit-consolekit is unmaintained!
:: Package js17 was not found in AUR -- skipping
:: Package libtxc_dxtn was not found in AUR -- skipping
:: Package netctl was not found in AUR -- skipping
:: Package xorg-xwrapper was not found in AUR -- skipping

I know I can ditch netctl as net config is back where it should be RC+ conf.d file(s) but the remainder have me a bit stumped!

Could someone offer some advice on the best way to deal with these please?
Optiplex 790, Intel Core i3-2100 CPU @ 3.10GHz 16Mb Corsair Vengeance 1333Mhz - GeForce 970 - XFCE

If everything in life was easy, we would learn nothing!
 Linux User: 401820   Last FM

Re: Issue with updates

Reply #1
Hello,
I know only that you can remve "polkit-consolekit" because Artix is by default using elogind.
netctl looks like some relic from systemd.

Other packages are from AUR ? and where probably removed... check what needs them and remove them if not needed.

Honestly only you know what you need.
Happy falling

Re: Issue with updates

Reply #2
Hello,
I know only that you can remve "polkit-consolekit" because Artix is by default using elogind.
netctl looks like some relic from systemd.

Other packages are from AUR ? and where probably removed... check what needs them and remove them if not needed.

Honestly only you know what you need.

Hi SGOrava,

Thanks for the response.

j17 is a dep of polki-consolekit so I guess they can go.
libtxc_dxtn appears to be an orphan
xorg-wrapper was installed during migration:

Code: [Select]
[email protected]  ~  cat /var/log/pacman.log | grep xorg-wrapper
[2015-11-04 16:35] [PACMAN] Running 'pacman -S --needed awesomewm polkit-consolekit mdm-nosystemd displaymanager-openrc xorg-wrapper upower-pm-utils consolekit-openrc'

So I'm kinda lost with regards to that as I see it is not mentioned anywhere in the new migration guide.

EDIT:
polkit-consolekit is a dep of xfce so I'm stuck with them lol
Optiplex 790, Intel Core i3-2100 CPU @ 3.10GHz 16Mb Corsair Vengeance 1333Mhz - GeForce 970 - XFCE

If everything in life was easy, we would learn nothing!
 Linux User: 401820   Last FM

Re: Issue with updates

Reply #3
Hi SGOrava,

Thanks for the response.

j17 is a dep of polki-consolekit so I guess they can go.
libtxc_dxtn appears to be an orphan
xorg-wrapper was installed during migration:

Code: [Select]
[email protected]  ~  cat /var/log/pacman.log | grep xorg-wrapper
[2015-11-04 16:35] [PACMAN] Running 'pacman -S --needed awesomewm polkit-consolekit mdm-nosystemd displaymanager-openrc xorg-wrapper upower-pm-utils consolekit-openrc'

So I'm kinda lost with regards to that as I see it is not mentioned anywhere in the new migration guide.

EDIT:
polkit-consolekit is a dep of xfce so I'm stuck with them lol

No you are not stuck with them xfce I am sure does not require consolekit, which is systemd  and has been removed from openrc for at least a year as mentioned above replaced by elogind. If you want to remove it the command is
Code: [Select]
yaourt -Rdd polkit-consolekit

 

Re: Issue with updates

Reply #4
No you are not stuck with them xfce I am sure does not require consolekit, which is systemd  and has been removed from openrc for at least a year as mentioned above replaced by elogind. If you want to remove it the command is
Code: [Select]
yaourt -Rdd polkit-consolekit

Hi Robin0800,

I use Trizen not yaourt ;)
Also managed to resolve the issue by installing the correct packages over the outdated ones I had:
Code: [Select]
world/polkit
world/js
world/upower

Now I just have to figure out if xorg-wrapper is surplus, if elogind provides rootless xorg sessions then it is or am I misunderstanding things ?
Optiplex 790, Intel Core i3-2100 CPU @ 3.10GHz 16Mb Corsair Vengeance 1333Mhz - GeForce 970 - XFCE

If everything in life was easy, we would learn nothing!
 Linux User: 401820   Last FM