Skip to main content
Topic: Folder shortcuts [Solved] (Read 116 times) previous topic - next topic
0 Members and 2 Guests are viewing this topic.

Folder shortcuts [Solved]

Hey guys, I am trying to make a folder shortcut so that /home/user/Mounted/XferZone/Videos ends up being /home/user/Videos
How do I do this??? I am using LXDE, I can't seem to make a folder shortcut by right-clicking on anything like all these stupid internet guides tell me to do  -_-

I want to make a few folders in my /home/user/ go to my secondary harddrive, could fstab be used to do this? What would that look like? Would I be able to make an fstab entry that looks like:

UUID=1234 /home/user/Mounted/XferZone
instead of this, like:
/home/user/Mounted/XferZone/Videos /home/kz/Videos
?? What else would I put in there?

Or, could I perhaps make the drive mount to more than one file location??
like...
UUID=1234 /home/user/Mounted/XferZone /home/user/Videos /home/user/Pictures /home/user/Music /home/user/Podcasts
???

How do I do this so I can just cd ~/Videos to get to my Videos? I tried making a symbolic link but that doesn't work either apparently...  :(

I don't wanna make a .desktop shortcut because then I can't cd ~/Videos .... or do I have that wrong? IDK


I know that this doesn't work:
/home/kz/mounted/XferZone/Videos /home/kz/Videos bind defaults 0 0

Nor does this, which apparently works for others but not for me... -.-
/home/kz/mounted/XferZone/Videos/ /home/kz/Videos none bind 0 0

I've also tried none defaults,bind and bind defaults,bind

This works, however this isn't in the fstab & I need something to make this work in the fstab :(
sudo mount --bind /home/kz/Mounted/XferZone/Videos/ /home/kz/Videos

I guess I can just add the mount --bind commands to /etc/rc.local, but I would REALLY prefer them to be in the fstab...
I created the entries in /etc/rc.local but that doesn't work either, I have to manually run the command to make this work :( I don't get what I am doing wrong here, I have looked at multiple other forums posts that apparently works for everyone but me...


Ugh... why isn't my /etc/rc.local working???? :(

I can't seem to make anything work....

Re: Folder shortcuts

Reply #1
Not sure why the symlink didn't work for you, but it's what you want.

Code: [Select]
ln -s /home/user/Mounted/XferZone/Videos /home/user/

That should do it.

Re: Folder shortcuts

Reply #2
Not sure why the symlink didn't work for you, but it's what you want.

Code: [Select]
ln -s /home/user/Mounted/XferZone/Videos /home/user/

That should do it.

But that doesn't work, I can't open it up... How do I make my /etc/rc.local work so I can just mount --bind them???

Re: Folder shortcuts

Reply #3
/etc/rc.local isn't starting up with the system, I have to run sudo sh /etc/rc.local to make it work.

Why isn't /etc/rc.local executing when I boot-up my computer????? All I need to do is fix /etc/rc.local so it works on boot-up

ugh, doing this creates a bunch of mounted devices in my file manager... Wish I could stop it from doing that...

Apparently the ln -s symlinks are working now, that's really strange because before it came up as a triangle with a ! exclamation mark & I couldn't cd into it either.

Re: Folder shortcuts

Reply #4
But that doesn't work, I can't open it up... How do I make my /etc/rc.local work so I can just mount --bind them???

What do you mean "can't open it up?" Descriptions and error output is nice to have. I'm not sure why you would have any problems with that unless your permissions are all just messed up.

As for /etc/rc.local, I thought you just enable local with rc-update.

Code: [Select]
# rc-update enable local default

I can't verify for you though since I'm on runit at the moment.