Skip to main content
Topic solved
This topic has been marked as solved and requires no further attention.
Topic: Install nightmare with nvidia-340xxx (Read 741 times) previous topic - next topic
0 Members and 1 Guest are viewing this topic.

Install nightmare with nvidia-340xxx

I've done a successful install with the lxqt iso from January.  However, installing nvidia-340xx has been a complete nightmare.  Every reboot briefly shows the console 1 login prompt, then (I had sddm installed and enabled) the screen goes black (I'm assuming it is a switch to VT7 in an attempt to start X which fails) then back to console 1 and back and forth.  I've tried with linux and linux-lts from both the main repository and with gremlins.  I've tried with the main nvidia drivers, and with dkms.

The latest dkms attempts have failed because I have gcc 7.3 installed, but the kernels were compiled with gcc 7.2.

Am I just doomed to failure with nvidia-340xx, or am I missing something in how I'm approaching this?  Is there something I should be adding to the grub linux line?  I've checked multiple wikis and forum posts, but I'm just not finding anything quite directly useful.

Thanks for any pointers.  (I also figure as soon as I post this, I'll recognize what I'm doing wrong :-( . . . .  )

Re: Install nightmare with nvidia-340xxx

Reply #1
Your screen is flickering becuase it is failing to start the X server, can you show us wich is the error in your Xserver logs please?

Re: Install nightmare with nvidia-340xxx

Reply #2
Are you sure you are using a legacy nvidia card?
Lets put it this way my artix install is about 8 months old started as LXQT then cinnamon, now Mate, just removed the old DEs and installed new nothing more

I started with the LTS kernel then installed nvidia "sudo pacman -S nvidia-lts" nothing more.

 Changed to the ck-kernel added nvidia "sudo pacman -S  nvidia-ck" nothing more.

Now I run the main line Arch kernel  added nvidia "sudo pacman -S nvidia" nothing more.

Do you see the pattern it all works nothing added or removed apart from the old kernels and nvidia drivers.
So if you have a problem install  inxi  from AUR then type   inxi -F    in a terminal and post it here so we can see what you are running and on what.

I'm sorry Artix users can not mind read or try to help with nill information from users.

Re: Install nightmare with nvidia-340xxx

Reply #3
This is mine on onothe DE as a example it really help to trouble shoot


System:
  Host: kelvin Kernel: 4.15.15-1-ARCH x86_64 bits: 64 Desktop: Gnome 3.28.0
  Distro: Arch Linux
Machine:
  Type: Desktop Mobo: Gigabyte model: 970A-UD3P v: x.x serial: N/A
  BIOS: American Megatrends v: F1 date: 08/06/2013
CPU:
  Topology: 6-Core model: AMD FX-6100 type: MCP L2 cache: 2048 KiB
  Speed: 2903 MHz min/max: 1400/3300 MHz Core speeds (MHz): 1: 1475 2: 2294
  3: 1695 4: 3461 5: 3837 6: 3698
Graphics:
  Card-1: NVIDIA GF108 [GeForce GT 440] driver: nvidia v: 390.48
  Display Server: N/A driver: nvidia tty: 80x24
  Message: Advanced graphics data unavailable in console. Try -G --display
Audio:
  Card-1: AMD SBx00 Azalia driver: snd_hda_intel
  Card-2: NVIDIA GF108 High Definition Audio driver: snd_hda_intel
  Sound Server: ALSA v: k4.15.15-1-ARCH
Network:
  Card-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
  driver: r8169
  IF: enp3s0 state: up speed: 100 Mbps duplex: full mac: fc:aa:14:0c:49:9e
Drives:
  HDD Total Size: 7.28 TiB used: 62.47 GiB (0.8%)
  ID-1: /dev/sda model: WDC_WD20EARS-00M size: 1.82 TiB
  ID-2: /dev/sdb model: WDC_WD10EZEX-00B size: 931.51 GiB
  ID-3: /dev/sdc model: WDC_WD20EZRX-00D size: 1.82 TiB
  ID-4: /dev/sdd model: WDC_WD20EZRX-00D size: 1.82 TiB
  ID-5: /dev/sde model: WDC_WD10EZEX-08W size: 931.51 GiB
  ID-6: /dev/sdf type: USB model: USB_DISK_2.0 size: 3.73 GiB
Partition:
  ID-1: / size: 23.91 GiB used: 11.39 GiB (47.7%) fs: ext4 dev: /dev/sdb2
  ID-2: /boot size: 96.8 MiB used: 60.1 MiB (62.1%) fs: ext2 dev: /dev/sdb1
  ID-3: /home size: 96.29 GiB used: 50.89 GiB (52.8%) fs: ext4
  dev: /dev/sdb3
Sensors:
  System Temperatures: cpu: 34.0 C mobo: 24.0 C gpu: nvidia temp: 48 C
  Fan Speeds (RPM): cpu: 748 fan-1: 2319 fan-3: 0 fan-4: 0 fan-5: 0
  gpu: nvidia fan: 36%
Info:
  Processes: 203 Uptime: 3m Memory: 7.76 GiB used: 614.7 MiB (7.7%)
  Init: systemd Shell: bash inxi: 2.9.12
Code: [Select]

						

Re: Install nightmare with nvidia-340xxx

Reply #4
@damnwidget - I agree the flicker is due to X failing.  Unfortunately, I don't have an X log with the failure available, and I'm desperately trying to get the system stable and running virtualbox to run Windows so I can install a program to do my taxes, so I won't be able to try again with the nvidia driver for a week or so.  I'll post the log as soon as i can get to it.

@mandog - lscpi shows "VGA compatible controller: NVIDIA Corporation C77 [GeForce 8200M G] (rev a2)"  which the nvidia site say uses the 340 driver.  I don't expect any mind reading.  I specifically asked if anyone knew of any problems with the nvidia-340xx drivers and recent kernels, and I'd also love to see any general notes about nvidia drivers on Artix.  Also, I started this post multiple times, with different info included each time, so apologies that the version I finally did post had less information than some others.  Output of "inxi -F" below.  I still need to work through "inxi --recommends."

Code: [Select]
Resuming in non X mode: xrandr not found. For package install advice run: inxi --recommends
System:    Host: ffortso5 Kernel: 4.14.34-1-lts x86_64 bits: 64 Desktop: LXQt Distro: Artix Linux
Machine:   Device: laptop System: Hewlett-Packard product: Compaq Presario CQ60 Notebook PC v: F.54 serial: N/A
           Mobo: Wistron model: 303C v: 08.60 serial: N/A BIOS: Hewlett-Packard v: F.54 date: 08/18/2009
Battery    BAT0: charge: 33.4 Wh 100.0% condition: 33.4/47.5 Wh (70%)
CPU:       Dual core AMD Athlon QL-62 (-MCP-) cache: 1024 KB
           clock speeds: max: 2000 MHz 1: 2000 MHz 2: 1000 MHz
Graphics:  Card: NVIDIA C77 [GeForce 8200M G]
           Display Server: N/A drivers: nouveau (unloaded: modesetting,fbdev,vesa) tty size: 134x46
Audio:     Card NVIDIA MCP72XE/MCP72P/MCP78U/MCP78S High Definition Audio driver: snd_hda_intel
           Sound: Advanced Linux Sound Architecture v: k4.14.34-1-lts
Network:   Card-1: NVIDIA MCP77 Ethernet driver: forcedeth
           IF: enp0s10 state: down mac: 00:1f:16:69:64:c2
           Card-2: Qualcomm Atheros AR928X Wireless Network Adapter (PCI-Express) driver: ath9k
           IF: wlp7s0 state: up mac: 00:23:4e:33:cf:7a
Drives:    HDD Total Size: 1000.2GB (0.4% used)
           ID-1: /dev/sda model: WDC_WD10JPVX size: 1000.2GB
Partition: ID-1: / size: 196G used: 4.1G (3%) fs: ext4 dev: /dev/sda1
Sensors:   System Temperatures: cpu: 58.6C mobo: 52.0C gpu: 66.0
           Fan Speeds (in rpm): cpu: N/A
Info:      Processes: 122 Uptime: 15:22 Memory: 307.6/3695.9MB Init: N/A rc: OpenRC runlevel: default
           Client: Shell (bash) inxi: 2.3.56

The system is working fine now, but I would prefer to get the nvidia drivers installed.

Re: Install nightmare with nvidia-340xxx

Reply #5
Lets get this right you are using the nvidia-lts cpu driver to go with the LTS kernel because its a simple
Sudo pacman -S  nvidia-340xx-lts and the headers will be brought reboot.

This is what is wrong    N/A drivers: nouveau (unloaded: modesetting,fbdev,vesa)

Should look more like this with your card and legacy driver
Graphics:
  Card-1: NVIDIA GF108 [GeForce GT 440] driver: nvidia v: 390.48
  Display Server: N/A driver: nvidia tty: 80x24 

Re: Install nightmare with nvidia-340xxx

Reply #6
@mandog I'm sorry you do not seem to follow.  Right now, I am using nouveau because it works.  I did install the nvidia-340xx-lts and that's when I got the flashing of X trying and failing, then trying again.  When I have time (after I do my taxes) I will try again and either figure out what I did wrong, or post the X log showing the failure. 

I think It all seemed more complicated because I tried the plain linux kernel with nvidia-340xxx, then the lts vesrsions of both.  I also tried plain and lts from gremlins, but the available nvidia drivers wouldn't go with the newer kernels, and I couldn't compile the dkms versions because the kernels were compiled wtih gcc 7.2, but gremlins has 7.3.  I suspect trying to describe all my attempts just muddied the explanations.

Open question:  Do I need to make any changes to the grub boot line for nvidia?  I have vague memories from old systems of needing to add "nomodesetting" (or something similar) but did NOT do that this time.  It would be nice if it's that simple.

Re: Install nightmare with nvidia-340xxx

Reply #7
No you don't Why don't you try the mainline Arch kernel with the legacy nvidia works fine

Re: Install nightmare with nvidia-340xxx

Reply #8
I think you're just doomed to fail since nvidia doesn't play nicely with mismatching kernel versions. I don't know how exactly the nvidia module works, so maybe it's somehow possible to get a nvidia-dkms compiled with gcc 7.3. Regardless, it wouldn't be something that you could just install conveniently from a repository. You'll probably just have to wait for the driver to update or get off the gremlins kernel.

Re: Install nightmare with nvidia-340xxx

Reply #9
@mandog At this point, we just have to wait until I have time to try it again.  All I can say now is that I did try it, and it didn't work.  I can't swear I didn't do something wrong in the process, but I've been using linux for years (including LFS years ago, my main box is Gentoo, and I have two other Artix installations.)  My current personal issue is that I'm not going to do anything not essential until I finish getting Windows 7 installed in Virtualbox (doing updates now) and getting TurboTax installed, and filing my taxes.  When that's done, I'll try installing the drivers again.

@Dudemanguy I don't know what you mean by mismatched kernel versions.  I did try various kernels, but in each case, I was trying to use the correct driver for that particular kernel.  For 4.16 for example, compiling nvidia-dkms with gcc 7,.3 would be useless, since that kernel was compiled with 7.2.  I'm really not trying to go bleeding edge, just something that works.

I think there's really nothing more to do here for another week or so.  Once I try again, it will either work, or I'll have more solid logs to post.

Re: Install nightmare with nvidia-340xxx

Reply #10
Oh I mean that the nvidia proprietary drivers are specifically designed to go with a certain kernel version and will fail if they don't match. The nvidia drivers are served in Arch's repos while the grelims kernel, of course, comes from Artix. I wouldn't anticipate Artix's unstable kernel to match with whatever version Arch's nvidia drivers are supposed to work with. You're probably out of luck there.

As for the dkms part, my apologies I got the versions backwards. The dkms module is supposed to work with any kernel version (so you definitely want to be using the dkms package, not the normal one) since it compiles itself in during installation. Since the kernels were compiled with 7.2, you probably could try downgrading gcc to 7.2 and then try installing dkms again. I would anticipate that would work, but if not, then you would just have to wait for the kernels to be rebuilt with 7.3.

Re: Install nightmare with nvidia-340xxx

Reply #11
This is a common problem with nvidia-dkms; put 'IGNORE_CC_MISMATCH=1' somewhere in your environment and it won't bother you again. You do a quick test by issuing
Code: [Select]
IGNORE_CC_MISMATCH=1 dkms install nvidia/340.106
And don't forget to mark the thread as solved :-)

Re: Install nightmare with nvidia-340xxx

Reply #12
Sorry for the delay, but I had all sorts of other computer problems which kept me busy.  I also ran into some issues with the openrc upgrade, but that is all sorted out now.

To simplify things, I got rid of linux (4.16) and concentrated on linux-lts.  (Eventually I'll try for the newer kernel again, but not too soon...)  Adding nvidia-340xx-lts seemed to boot ok, but the screen was frozen - no response to mouse or keyboard.  I finally managed to get to a text console before it froze up, and as Dudemanguy implied - that kernel module (per modinfo) was actually for a slightly different kernel version - 4.14.36 instead of 4.14.37, I think.  Switching to the dkms version finally worked, so I'm now running lxqt with the nvidia 340 driver.  However, I ended up having to manually to mkinitcpio and update-grub.  (I suppose it would help to be sure which repository each version of the relevant packages came from, but

Bottom line - especially with the nvidia drivers (I don't know if the legacy ones are the same or different from mainline in this area) you do have to be absolutely sure that the driver matches the exact kernel version you are trying to use it with.  As long as there is some mixing of Artix and Arch sources for packages, this is likely to be a potential issue.

However - I'm now trying to move from lxqt to kde/plasma, but that's a new nightmare for a new thread.  Lets just say, it seems to make even less sense than this one did...

Re: Install nightmare with nvidia-340xxx

Reply #13
Going back to the Arch mainline Kernel and Arch Nvidia they always match i know I use Arch but  you can't mix match  from different repros.
Kde should be a simply sudo pacman  -syyu then sudo pacman -s kde  then choose what you want to install i would go for a minimal install pacman is very simple to use and will ask you if you want to install optional deps don't use package managers they install blind.

Re: Install nightmare with nvidia-340xxx

Reply #14
@mandog - just curious, but do you mean upper or lower case s/S?  In terms of matching kernel and module - I know it shouldn't be this hard, but I maybe I just didn't notice which repro things were coming from, so using the dkms guarantees the module will match the kernel.j  All the kde stuff installs just fine, but on actually starting it, something is getting hung up.  Even just starting sddm with nvidia-340xx was hanging.  I'm beginning to suspect there is something about this specific laptop, since I have Artix/nvidia/kde running just fine on a desktop in the next room.  At this point, I'm probably going to hold off until a soon to be done install on a brand new laptop.  If that goes OK, I'll try this one again - maybe just starting with a brand new install from scratch, since I've been mucking around with this one for too long.  I don't want to get into kde details in this trhread.