Skip to main content
Recent Posts
1
Installation / Migration / Configuration / Re: new iso from sourceforge only boots in efi mode
Last post by ####### -
I had this yesterday, and just now when I tried to answer here again. My clock is right btw.
An Error Has Occurred
Session verification failed. Please try logging out and back in again, and then try again.
Palemoon - do this -
Tools - Preferences - Privacy - History - remove individual cookies - (type artix in search box) - remove all shown
Then it works. It's a cookie problem, perhaps they only last a day then go mouldy and stale. They must be near their sell by date at the moment.  :D

Great tip about the dangers of efi, I hadn't heard that before.
2
Installation / Migration / Configuration / Re: new iso from sourceforge only boots in efi mode
Last post by nous -
but when i try to login to these forums from withing artix i cant log in, even when logged out of my arch labs session
this is bizarre.  if i have to reboot into archlabs to use your forums, what's the point?
Well, that is indeed bizarre and shouldn't happen. What browser are you using? Have you tried another? Is your system clock correctly setup in Artix? I occasionally receive "session expired" errors when trying to log in, but usually 1 retry is enough to succeed. For the record, I just logged in from the latest runit ISO with falkon, installed in vmware.
5
Installation / Migration / Configuration / new iso from sourceforge only boots in efi mode
Last post by Lizzi.A.S -
when i try to bot the usb in other than efi mode it hangs and doesnt boot.  one time it got hung up on clearing the /tmp space?

truly crazy behavior

aint no way i'm gonna install an efi on my pc.  not today, not ever.  there is nothing about a partition that a windows virus or malware can write to that will ever make my pc more secure
6
Announcements / Re: Artix needs your help
Last post by Lizzi.A.S -
This article is old by 6 months.  Is this still an issue?

i have an ryzen5 2400g apu with 16gb ram and i am about to install artix on the ssd.  Would you like some access to the hardware for package building?
7
Software development / Re: Updating /etc/pacman.d/mirrorlist-arch
Last post by ####### -
The mirrorlists are separate packages, just the mirrorlist, it's not part of the pacman package.
Code: [Select]
$ pacman -Qo /etc/pacman.d/mirrorlist
/etc/pacman.d/mirrorlist is owned by artix-mirrorlist 20180822-1
$ pacman -Qo /etc/pacman.d/mirrorlist-arch
/etc/pacman.d/mirrorlist-arch is owned by archlinux-mirrorlist 20170709-1
$ pacman -Ql artix-mirrorlist
artix-mirrorlist /etc/
artix-mirrorlist /etc/pacman.d/
artix-mirrorlist /etc/pacman.d/mirrorlist
$ pacman -Ql archlinux-mirrorlist
archlinux-mirrorlist /etc/
archlinux-mirrorlist /etc/pacman.d/
archlinux-mirrorlist /etc/pacman.d/mirrorlist-arch

But the Arch one has not been updated for over a year. In truth though, the only reason I noticed this was because I was tidying up rm'ing some pacnew and backup files in /etc. In the Manjaro OpenRC conversion I had these old mirrorlist-manjaro (in the very early Artix days the Manjaro repos were used for a while as well) and mirrorlist-arch files that had not been updated for ages, and they didn't belong to any package, so I deleted them. Then pacman stopped working with an error that it couldn't find mirrorlist-arch! It was important after all...  :o  So I had to make a new updated one and checked out the ownership in the other Artix installation.
8
Software development / Re: Updating /etc/pacman.d/mirrorlist-arch
Last post by fungalnet -
Manjaro only has its own repository and mirrors, no arch.  It is arch based but I don't think it originally comes with arch repositories, you have to add them on your own if you like.  Artix uses arch repositories (at least extra and community) so the mirrorlis-arch belongs to pacman.
Once in a while I get a bad hit of an arch-mirror and comment it out.  To avoid confusion I rename mirrorlist as mirrorlist-artix in pacman.conf and pacman.d/  but then when a new mirrorlist comes in I have to rename it manually.  When you list them you can tell them apart by size, arch being huge and artix being small.
When I moved from manja-operc to artix I was getting a little confused about things because I had no previous arch experience.  I only had  debian experience.  After a while when I played around with manjaro again trying to shift it to runit or s6 I understood how confusing things manjaro was doing and arch made much more sense.  I know others may say the reverse, but how you switch manjaro to testing from stable is really complex for no reason.  I guess if you focus in clicking things on a gui you do things differently.


9
Software development / Updating /etc/pacman.d/mirrorlist-arch
Last post by ####### -
I noticed I was getting some mirrorlist.pacnew files (Artix repos) occasionally, but the mirrorlist-arch file (Arch repos) was left the same.
On a Manjaro OpenRC conversion, /etc/pacman.d/mirrorlist-arch was not owned by any package. On an Artix base install:
Code: [Select]
$ pacman -Qo /etc/pacman.d/mirrorlist-arch
/etc/pacman.d/mirrorlist-arch is owned by archlinux-mirrorlist 20170709-1
But that mirrorlist over a year old and some http mirrors have now changed to https and so on.
You can easily make your own fully updated speed ranked mirrorlist (for the Arch mirrors) to your own specs with the Arch Linux Pacman Mirrorlist Generator:
https://www.archlinux.org/mirrorlist/

I thought that was a useful tip to share, perhaps helping to reduce update download times.
10
System / Re: Artix update
Last post by fungalnet -
If you replace those pkgs with the artix equivalent the warnings will go away.  For them to be repackaged by artix they have systemd-crap-dependencies/relations in them.
But it can happen with aur pkgs as well, for example I have an inxi pkg that is more advanced than even arch and I get this warning that it is newer.    But I wouldn't choose any pkg from Arch over one of Artix, despite of version.