Skip to main content
Topic: XMobar segfaults when a window passes over it (Read 162 times) previous topic - next topic
0 Members and 1 Guest are viewing this topic.

XMobar segfaults when a window passes over it

If I move a window over xmobar is segfaults (sometimes):
https://youtu.be/fz7nfFZdFHQ
However I did not experience this behavior (with the exact same config) on other distros.

Any ideas?

Re: XMobar segfaults when a window passes over it

Reply #1
Looks like a dbus and systemd issue to me. XMobar is served in Arch's community repo. Even though neither dbus or systemd is listed as a dependency, it probably will make use of dbus if you have it installed and Arch packages are built with a dbus that looks for systemd. Try building it yourself and see if you get the same segfault.

Re: XMobar segfaults when a window passes over it

Reply #2
Building xmobar-git results in this:
Code: [Select]
Configuring xmobar-0.26...
setup: Encountered missing dependencies:
alsa-core ==0.5.*,
alsa-mixer >0.2.0.2,
dbus >=0.10 && <1.0,
timezone-olson ==0.1.*,
timezone-series ==0.1.*

==> ERROR: A failure occurred in build().
    Aborting...

Re: XMobar segfaults when a window passes over it

Reply #3
Those appear to be missing haskell dependencies to me. I'm not sure why they aren't included in that PKGBUILD, but you'll need to install them to build it. I haven't worked much with haskell, but it does have its own package manager, cabal. You can use that to install those dependencies. It's also worth nothing that Arch/AUR has packages for haskell-alsa-core, haskell-alsa-mixer, and haskell-dbus0.10. if you prefer to install those that way.

Re: XMobar segfaults when a window passes over it

Reply #4
deleted

Re: XMobar segfaults when a window passes over it

Reply #5
Those packages allowed it to build, but after install with pacman -U and running it, the issue is still persistent.
I've checked runit, and dbus is indeed running.

Is there a way to make it stop calling dbus?

Re: XMobar segfaults when a window passes over it

Reply #6
Try building it without the "with_dbus" flag in the PKGBUILD.

Re: XMobar segfaults when a window passes over it

Reply #7
Can you tell whether in the cases it does happen is your memory use real high, or does it happen when memory use is low too.  Do you have swap?
Also, as I recently found out, with some browsers when you see dbus running as a process it may not be "THE dbus" but one used internally by the browser.  When your desktop first starts up is dbus running? 

Re: XMobar segfaults when a window passes over it

Reply #8
Compiling without dbus removes the dbus error, but it still segfaults:
Code: [Select]
Fields missing from config defaulted: additionalFonts,wmClass,wmName,textOffse
Segmentation fault

Memory usage can be low or high, and I do have a SWAP partition.
Dbus is in run level default.

 

Re: XMobar segfaults when a window passes over it

Reply #9
Yeah sorry, no idea on that one. You should probably ask the developer.