Skip to main content
Topic: dkms bugaboo (Read 50 times) previous topic - next topic
0 Members and 1 Guest are viewing this topic.

dkms bugaboo

On the upgrades I keep getting this message, which is related to a module I had to download from intel to get work

Code: [Select]
==> dkms install e1000e/3.3.6 -k 4.14.48-1-lts
==> dkms install e1000e/3.3.6 -k 4.16.12-1-ARTIX
Error! Bad return status for module build on kernel: 4.16.12-1-ARTIX (x86_64)
Consult /var/lib/dkms/e1000e/3.3.6/build/make.log for more information.
( 6/24) Updating linux-lts initcpios...

can someone point me to docs on how to fix this?

Re: dkms bugaboo

Reply #1
You might have old version of mentioned module.
I found in aur version 3.4.1  and on some intel site version 3.4.0

So check if you can update it, if you cant than post the build log from dkms
Happy falling

Re: dkms bugaboo

Reply #2
I can download it and compile it but getting it to play nice with the packaging system is another problem.

Re: dkms bugaboo

Reply #3
I can download it and compile it but getting it to play nice with the packaging system is another problem.

I think for this there is AUR. Are you saying that the package in AUR is broken ?
If so modify it to suit your needs.
Also you should check for new "driver" / module version when you update kernel.
Happy falling

Re: dkms bugaboo

Reply #4

Quote
I think for this there is AUR. Are you saying that the package in AUR is broken ?

What I am saying is that the one from the intel site was made specifically for me :)  That is why it needs to be compiled as a separate module and loaded with depmod and modprobe

This is automated with dkms if I can get the package manager to work with it.