Skip to main content
Topic solved
This topic has been marked as solved and requires no further attention.
Topic: [SOLVED] Seatd 0.6.2-1.6 from galaxy conflicts with Elogind from galaxy (Read 178 times) previous topic - next topic
0 Members and 1 Guest are viewing this topic.

[SOLVED] Seatd 0.6.2-1.6 from galaxy conflicts with Elogind from galaxy

The seatd package provided by galaxy conflicts with elogind. This is a problem if one wants to use Xorg based projects and wlroots  based projects, because wlroots requires seatd, and Xorg requires elogind to work properly (i.e. not running as root). So, in my case, in order to be able to use Xorg, I need to downgrade to seatd-0.6.2-1.3, but this version does not work with wlroots 0.14.1-2, so I can only use either wlroots or xorg.

I'm not sure what the solution would be here, besides just holding seatd at that specific version until something breaks, or compiling wlroots myself and seeing if I can get it to work without seatd.

Re: Seatd 0.6.2-1.6 from galaxy conflicts with Elogind from galaxy

Reply #1
Update System
Code: [Select]
sudo pacman -Syu
It should be fixed
Create problems which don't have solution

Re: Seatd 0.6.2-1.6 from galaxy conflicts with Elogind from galaxy

Reply #2
seatd 0.6.2-1.6 is the latest one, which does conflict with elogind. (i.e. no, it isn’t fixed yet)

Code: [Select]
pacman -Si seatd
Repository      : galaxy
Name            : seatd
Version         : 0.6.2-1.6
Description     : A minimal seat management daemon, and a universal seat management library
Architecture    : x86_64
URL             : https://sr.ht/~kennylevinsen/seatd/
Licenses        : MIT
Groups          : None
Provides        : logind  elogind
Depends On      : libelogind
Optional Deps   : None
Conflicts With  : logind  elogind
...

Re: Seatd 0.6.2-1.6 from galaxy conflicts with Elogind from galaxy

Reply #3
The conflict is necessary atm, since elogind and seatd are functionally similar components.
However, there are multiple issue why seatd connot fully replace elogind.
We added it to repos, but its far from perfect, wlroots currently the only one having a hard depend on seatd.
Since seatd uses the elogind backend anyway, there is no real point to use it unless you are wlroots user.

Seatd could only replace elogind in combination with ck2, which raises a power management issues.
It relies on old pm-utils and iirc upower had support removed many moons ago.

Re: Seatd 0.6.2-1.6 from galaxy conflicts with Elogind from galaxy

Reply #4
Actually wlroots only depends on libseat.so which is now a split package. Unfortunately to update smoothly you would have to first use pacman -S libseat with the --overwrite argument to replace the conflicting files. Then after that, you should be able to remove seatd and then update the rest.

 

Re: Seatd 0.6.2-1.6 from galaxy conflicts with Elogind from galaxy

Reply #5
Actually wlroots only depends on libseat.so which is now a split package. Unfortunately to update smoothly you would have to first use pacman -S libseat with the --overwrite argument to replace the conflicting files. Then after that, you should be able to remove seatd and then update the rest.

That worked, thanks.