Skip to main content
Topic: How Is Artix Running For you? (Read 1381 times) previous topic - next topic
phoenix_king_rus and 1 Guest are viewing this topic.

Re: How Is Artix Running For you?

Reply #15
The issues I've been having are minor and they are edge cases: pulseaudio running within firejail seems to be acting differently from the systemd setup (not really working except in one jail at a time), some extra/ packages are newer (as already mentioned on other threads). There's also the 'small' issue of systemd launching network sockets for services as its own user, that gladly doesn't happen on openrc, but I had to change some firewall rules (again, minor).

For me, as long as firefox/some terminal emulator/awesome or i3/virtualbox and a few other pieces of software that aren't systemd related in any way (yes, I know , everything got infected lately), I'm a happy camper.

I ran gentoo for a few years, it didn't agree with my backup strategy (long compile times on recovery), went back and forth between the major distros, ditched .deb for arch because of better community support for older packages through AUR, and now I'm on Artix because I get AUR + openrc (or anything non-systemd) and I don't have to compile for hours.

For me it's clear that Artix is still a work in progress, but I've been using it for months and since I know my way around things, I didn't have any major issues with it and I'm expecting it to get better.

I'm kind of surprised there aren't more people using devuan/artix to be honest, but migrations can be painful, I suppose.

It's also not hard to just switch back to arch, once you understand how it interprets mirrors/sigs, but I didn't find the need to.

Re: How Is Artix Running For you?

Reply #16
I've posted my issues on the IRC channel, but I'll try to summarize them here.  But first my environment.

I'm running Artix installed from scratch from the artix-lxqt-20171015-x86_64 ISO, and is not an upgrade or conversion.  It is installed in a VirtualBox VM with 1.5 GB memory, 2 vCPUs, 128M video memory, KVM paravirtualization, ALSA Audio on the host and ICH AC97 controller.  DE has been either lxqt or xfce4.  The host is CentOS 6.9 running the 2.6.32 kernel.  The mainboard is an ASUS M5A78L-M/USB3 (AMD Thuban x6).  We have HSI that gets about 150mbps down, and I am hardwired, not wireless, to the Comcast modem.

Until installation of the 4.14.14 kernel, the system was a bit unstable, with the system going into a freeze for minutes at a time, sometimes freezing completely.  Sound was flakey, sometimes going out at seemingly random times; killing other programs with sound like pysol (even though I disabled sound on pysol), or restarting the browser, or both, most times revived sound... for a while.  Eventually I had to reboot the VM.  I think that was with the 4.9.75 kernel, idr now.  BTW, changing from lxqt to xfce4 did not cause noticeable improvement or degradation; performance was about the same.

After the update to the 4.14.14 kernel, the system is much more stable, and I have not noticed the long freezes and hang-ups.   So far, anyway.   But I do notice that there is still a sluggishness of the video.  When I go to click on items, about 3/4 of the time, I have to click a second time even though the control seemed to have registered with the first click.  Sometimes moving the mouse to one place does not seem to register with a program here and there even though the mouse pointer is in the spot I wanted, and then suddenly it will jump to another place, usually a few pixels away (maybe 100 px or so, I'm estimating).    In some web pages, I will get some artifact hanging on the cursor which I have to click to get rid of.  Keystrokes are often delayed, but worse, moving the mouse after entering characters sometimes causes unwanted highlighting, and worst yet, occasionally deletes work I did not want removed.  Thank goodness for ctrl-Z!

One other issue I might mention is concerning syslog-ng.  While trying to sort out these issues under the 4.9.75(?) kernel, I found that the system log messages during one freeze were missing.  Since the update of the kernel 4.14.14, I have not yet experienced a freeze, so I will not know until it happens (if it happens, that is) if missing log messages are still symptomatic.

For comparison purposes ONLY:  I do not observe or experience this type of behavior in  my other VMs, including anti-X and devuan 1.0.   These VMs run in (nearly) identical configurations.   I've tried enabling/disabling 3D, KVM, NX, etc to no avail.

4.14.14 certainly does seem better, but only the sluggishness of the UI is annoying.  I continue to use it, hoping more improvements come down the pike soon.  I would like to see more support for multiple kernels as this is handy when trying to sort out issues like the ones I am discussing.   I am hunting for  replacement for my CentOS hosting of VirtualBox, but so far this arrangement is not promising.  I understand that running in VM versus bare metal would certainly have at least some impact, but given that I do not see all these responsiveness symptoms in my other VMs, I am rather sceptical that this difference is significant.  I get very good UI responsiveness in the other VMs as well as the host.

I am more than happy to share more info with devs (aside from user IDs and passwords, my SSN, street address, phone number, etc), although I think I have been very thorough already.

Re: How Is Artix Running For you?

Reply #17
I switched my DE from xfce to lxqt, and now I am getting good responsiveness and performance (finally!).  But I will be sensitive to any recitivism and report it here.   For now, though, it looks hopeful again.

Re: How Is Artix Running For you?

Reply #18
Lets hope it stays working well for you like it does for me I use JWM by the way.

Re: How Is Artix Running For you?

Reply #19
If I am not mistaken, lxqt uses openbox wm.

Re: How Is Artix Running For you?

Reply #20
no issues for me here
running kde plasma on a xeon 5470 @3.85 / 10gb ram
a couple of hiccups with early kernel packages/modules and an issue with the nvidia proprietary driver but nothing that wasnt solveable
OC'ing the cpu does cause problems with long builds (firefox/ffmpeg) because of heat but i just do -j2 for those
my experience since going from lfs -> arch -> arch openrc -> artix has been pretty smooth

Re: How Is Artix Running For you?

Reply #21
Swimmingly :D
A few package version niggles related to stuff from Arch repos (running a full Plasma desktop here), but nothing insurmountable.

I was contemplating Gentoo for a while there, after finding Devuans ascii/testing somewhat unready for prime-time, but I'm glad I gave Artix a go first. It's nice.

Re: How Is Artix Running For you?

Reply #22
Been using Artix on my HP laptop since new. Been working great and I really like LXqt. My laptop is mostly used for my business and so it having been very reliable is great. Only issues is I can't get mtp working with my S8 - have had troubles with mtp with all sorts of phones and Linux OS's. Never got it working on Gentoo either. Pacman sometimes gives me errors, but they usuall 'wash out' with time - latest is a whole bunch of conflicts with xorgproto?
https://forum.artixlinux.org/index.php/topic,403.msg0.html

Being systemd free just feels great  8)  8)  8)

Re: How Is Artix Running For you?

Reply #23
I wonder if your MTP problems are LXQT related as LXDE does not have that problem being gtk its a matter of just installing gvfs-mtp and adding this to startup  dbus-launch pcmanfm --desktop -d  but i don't have experiance with LXQT  I just know in  LXDE gtk the file manager does not give full functions without dbus starting the file manager.

Re: How Is Artix Running For you?

Reply #24
: community                                                                     4.1 MiB  5.89M/s 00:01 [############################################################] 100%
:: Starting full system upgrade...
:: Replace compositeproto with world/xorgproto? [Y/n]

 

Re: How Is Artix Running For you?

Reply #25
:: Replace compositeproto with world/xorgproto? [Y/n]

https://forum.artixlinux.org/index.php/topic,403.0.html
https://forum.artixlinux.org/index.php/topic,335.0.html 

world-testing/xorgproto replacing all other ***proto [SOLVED?]
New xorgproto unable to update
Clementine libprotobuf


Re: How Is Artix Running For you?

Reply #26
My experiences :
I started using Arch+ fluxbox at year 2014, when systemd was already implanted, so OpenRC or any other init is new for me; before Arch I was using *buntu, Mint and similar, and didn't care about init system. As systemd becomes more and more complex, and developer gets less and less idea of what he is doing (because of that complexity), plus some recent annoyances with systemd, I started to search for nosystemd distros.

At first I was thinking about Devuan Ascii, but after reading this I quit that idea, and choose Artix, and here I am. After all, it iz Arch without systemd, and It is my main OS for years.

Default Artix (calamares, artix-lxqt-20180108-x86_64.iso) installation finished with "linux kernel 4.15.14"; (working excellent, btw)
I read that default Artix kernel is "linux-lts", AND that nVidia proprietary drivers (for Artix) are 'best cooked' as nvidia-lts, so i installed "linux-lts 4.14.32-1" and removed linux "kernel 4.15.14-1", then installed nvidia-lts.
Wow!
I must admit that I did not expect such a top-notch lxqt masterpiece!

Now, I must share some strange experience.
There was no devices (except smartphone), meaning other disks/partitions (ext4,ntfs,luks) from my machine not showed unmounted at pcmanfm-qt left side (places), so I decided to play with fstab;
First I picked big ext4 data partition (sdc3 - not configured during installation proces) and added it to fstab:
Code: [Select]
UUID=b06736bd-2425-3234-9124-932b2368f6fa /mountplace1      ext4    defaults,noauto,noatime 0 2
Now, as soon as I pressed "save" in text_editor ---> poooof!:
ALL disks/partitions, not just that sda3 from fstab, but ALL other partitions (not in fstab) showed up in pcmanfm-qt left side, unmounted, of course.
So I commented out
Code: [Select]
# UUID=b06736bd-2425-3234-9124-932b2368f6fa /mountplace1      ext4    defaults,noauto,noatime 0 2
and rebooted to see if that (desired) behavior of pcmanfm-qt will remain preserved, and it did!

Now I just have to learn more "How to(s)" OpenRC ...

Re: How Is Artix Running For you?

Reply #27
Don't listen to those sysdfree folks, they get all wired up and blow more steam than it is worth.  ;)

I am glad you are here though.  Do you have gvfs installed?  Do you have your user as a member of wheel?

Welcome

Re: How Is Artix Running For you?

Reply #28
Do you have gvfs installed?  Do you have your user as a member of wheel?
Default installation automatically put me into audio, lp, network, optical, power, scanner, users and wheel groups.

Habit from Arch (+fluxbox+pcmanfm) --> always install gvfs-smb, gvfs-mtp, gvfs-mtp, gvfs-nfs, gvfs-gphoto2 to have access (from pcmanfm) to smartphone and NAS samba shares;
everything seems triggered to function properly when I pressed "save" on that modified (now reversed) fstab file.
Never mind, now is working as it should,  I shared that in case any future user browse forum for similar solution/problem.

Also, for any user that care about tmpfs:
Arch (systemd) uses tmpfs for /tmp by the default systemd setup and does not require an entry in fstab unless a specific configuration is needed.
I noticed that is not the case in Artix (Yes, I know this is not systemd-based OS, and I said I don't know nothing about any other init system -- everything I know is from Arch+systemd, so I use it as reference point) so I just added line in fstab, to have it back:
Code: [Select]
tmpfs   /tmp    tmpfs   rw,nodev,nosuid,noatime         0 0
Installation is on SSD, so it is useful configuration (for me)
To check 'where is Your /tmp mounted' issue:
Code: [Select]
$ df /tmp
Filesystem     1K-blocks  Used Available Use% Mounted on
tmpfs            4085452     0   4085452   0% /tmp
Of course, You can also browse through the output of mount command

After some trial period, I'll decide if Artix will become my main OS, now I am dual booting with Arch.
So far - so good.

Re: How Is Artix Running For you?

Reply #29
Its my main as well, migrated from Manjaro openrc.

I also get mandog's lts lag, but instead of getting desperate, i simply hold upgrading kernel/xorg until nvidia is up to date (pacman complains anyway). The package usually gets updated a few days later. I'm using: linux-lts, nvidia-lts and r8168-lts, all three must be updated at the same time or else i might lose network or video...

Before using manjaro openrc, my experience centered mostly around debian derivatives, and before that slackware and some rpm distros (and bsds). Because arch and derivatives dropped 32 bit, i also use voidlinux in some computers, which came handy for learning the ways of runit, which someday i plan to put to use in Artix as well (prefer to wait for bugs or issues to be ironed out).

Voidlinux is great, but the vast amount of software in arch/aur repositories tips the balance if i can help it. But us in "forsaken" countries can't be picky and certainly can't discard 32 bit quite yet. I'll keep an eye to archbang...

On my main desktop I'm using xfce. You can still keep a "redmond"ish appearance if you want, just make sure to have matching themes for gtk and qt. QT is a bit stubborn and needs fiddling with qt5ct from time to time when you change themes or something affecting themes gets updated.

I have skipped systemd entirely, but read and saw some horror stories from former coworkers etc. I also happen to not use pulseaudio, and don't see any need for avahi, imo. When someone has bad coding and design practices, those things tend to propagate to all his projects, so why risk it? I had enough with pulseaudio issues way before he decided to take over the world with systemd. So i made a pure alsa config which works perfectly fine, dmix and dsnoop mixes anything and i don't use or want bluetooth audio.

So yes I have it running fine here, but I wouldn't recommend this distro to newbies, no hand holding easy to break stuff when you do foolish things. Its nice to have updated and vast amount of packages one command away, and only you decide when to update, and no bloat if you don't want it. For a server I would still throw devuan or a bsd, but this is great for the desktop.

I used a bit of pamac with manjaro, but got in the habit of just using pacman for system packages and trizen for aur packages. If pacman complains a package needs a certain lib version not available, just don't upgrade, wait a few days and resync. Also its always good to read announcement/forums/social before doing upgrades, just in case. Rolling distros carry more responsibility, and often packages update things you need to carefully check such as config files, etc.

Another advantage of always waiting a little bit is, if major things break, you get the warning (and possibly the solution) in advance. I only upgrade from time to time, sometimes i just need a single package updated, no need to deal with a massive system upgrade all the time, especially when everything is working just fine. Many aur packages also exist in binary form, no need to compile all the time either (or deal with gcc version annoyances).