Skip to main content
Topic solved
This topic has been marked as solved and requires no further attention.
Topic: cpupower governor doesn't stay on desired setting [Solved] (Read 183 times) previous topic - next topic
0 Members and 1 Guest are viewing this topic.

cpupower governor doesn't stay on desired setting [Solved]

Hey guys, I'm trying to make my CPU governor remain on "performance" but it keeps switching back to ondemand or schedutil after every reboot, if I have cpupower enabled it'll keep switching back to ondemand, if I disable it it'll keep switching back to schedutil, no matter how many times I change the settings to performance, they end up back on one of these two settings, ondemand if cpupower is on, schedutil if cpupower is off.

How can I make it remain on performance? This is driving me nuts.

I issue this command but it doesn't make a difference once I reboot... I can't see the startup screen for long but it looks like cpupower is setting itself to ondemand on startup... I want it on performance!  I'm using the linux-ck kernel.

Code: [Select]
sudo cpupower frequency-set -g performance

For some reason when I do
Code: [Select]
sudo rc-service cpupower start

it will do this:
Code: [Select]
 * Running cpupower -c all frequency-set --governor ondemand ...                                                              [ ok ]

I don't want it to do that! I want it to go to performance!

Well, I thought I wouldn't be able to figure this out by myself but apparently I have... at least I think I have.

sudo nano /etc/conf.d/cpupower

Code: [Select]
START_OPTS="--governor performance"

This has solved it.
:^)

Re: cpupower governor doesn't stay on desired setting [Solved]

Reply #1
that's what i have as well

Re: cpupower governor doesn't stay on desired setting [Solved]

Reply #2
that's what i have as well

I've put it to ondemand now because I think it works better that way. Nice display picture btw!
:^)