Artix Linux Forum

Artix Linux => Applications & Software => Topic started by: kenny_w on 26 July 2018, 18:12:06

Title: Compiling dolphin-emu 4 for PC with older openGL
Post by: kenny_w on 26 July 2018, 18:12:06
Hey guys, I'd like to compile dolphin-emu version 4.0 for a PC with an older version of OpenGL because the latest dolphin-emu gives me an error about it. When trying to compile dolphin-emu, this is what I'm getting:


Code: [Select]
Wayland support disabled
X11 support disabled
CMake Error at CMakeLists.txt:433 (message):

No suitable display platform found

Requires wayland or X11 to run

-- Configuring incomplete, errors occured!

I have libx11 and all that stuff, what package could I possibly be missing? Is there a cmake -D command thing I am missing? Does anyone remember compiling dolphin-emu when it was version 4?
Title: Re: Compiling dolphin-emu 4 for PC with older openGL
Post by: Dudemanguy on 26 July 2018, 18:17:19
What version of opengl is this? Is there a reason why you can't update to a newer one?
Title: Re: Compiling dolphin-emu 4 for PC with older openGL
Post by: kenny_w on 27 July 2018, 05:08:54
Yea theres a reason it can't use the newer one, its a laptop with a card that doesn't support the newest OpenGL. It plays all emulators except dolphin-emu. I just want to know how to get the older versions of dolphin to build...
Title: Re: Compiling dolphin-emu 4 for PC with older openGL
Post by: Dudemanguy on 27 July 2018, 15:03:23
Yeah but are you sure the opengl version just isn't flat out too old for dolphin emu?  What card is it?
Title: Re: Compiling dolphin-emu 4 for PC with older openGL
Post by: kenny_w on 31 July 2018, 21:00:19
Yeah but are you sure the opengl version just isn't flat out too old for dolphin emu?  What card is it?

The computer is from 2011, its not new enough for Dolphin 5.0, its a laptop. I would just like to know how to build the older versions!
No offense but I made this thread to try to figure out how to make the older versions of dolphin-emu to compile, not to determine what version of OpenGL my laptop is using.... I just need to know how people built the older version back when it was the norm. I looked at some older PKGBUILDs but they were of no help.
Title: Re: Compiling dolphin-emu 4 for PC with older openGL
Post by: Dudemanguy on 31 July 2018, 22:21:44
The computer is from 2011, its not new enough for Dolphin 5.0, its a laptop. I would just like to know how to build the older versions!
No offense but I made this thread to try to figure out how to make the older versions of dolphin-emu to compile, not to determine what version of OpenGL my laptop is using.... I just need to know how people built the older version back when it was the norm. I looked at some older PKGBUILDs but they were of no help.

The point is that I'm not even sure what you're trying to do is possible. You've said you're on a laptop from 2011. I don't know what it is, but it is very possible we are talking about a really old intel gpu with a really old version of opengl. Maybe you could hypothetically roll back to some really old version of dolphin, but at the moment I have no way of knowing. People need information if you want them to help you.
Title: Re: Compiling dolphin-emu 4 for PC with older openGL
Post by: kenny_w on 14 September 2018, 02:38:10
Nobody knows how to make this compile?
its an intel i915, its a hp elitebook 8440p so its like 2011, its got an intel i5 and it works great for PCSXR, PCSX2, mupen64plus, snes9x, ppsspp, etc. I just want to get it to compile, I don't know how to make it compile right because it spits out that error in cmake.... :/
there are some low-end gamecube games I think should play on it, but I'll never know if I can't get it to compile... Guess I'll try the dolphin-emu forums.