Skip to main content
Topic: Bluetooth PS3 controllers not connecting (Read 2092 times) previous topic - next topic
0 Members and 1 Guest are viewing this topic.

Re: Bluetooth PS3 controllers not connecting

Reply #15
It builds and completes the tests with gcc7 built from the AUR and the following changes, some of the other changes from gripped to remove unused bits could be added:
Code: [Select]
--- origPKGBUILD        2019-06-08 15:08:09.232347589 +0100
+++ PKGBUILD    2019-06-08 15:04:51.642326443 +0100
@@ -30,6 +30,7 @@

 build() {
   cd ${srcdir}/${_gitname}
+  export CC=/usr/bin/gcc-7
   ./configure \
           --prefix=/usr \
           --mandir=/usr/share/man \
@@ -37,6 +38,7 @@
           --localstatedir=/var \
           --libexecdir=/usr/lib \
           --enable-sixaxis \
+          --enable-systemd=no \
@@ -70,5 +72,5 @@
   install -Dm644 ${srcdir}/bluetooth.modprobe ${pkgdir}/usr/lib/modprobe.d/bluetooth-usb.conf

   # fix obex file transfer -
-  ln -fs /usr/lib/systemd/user/obex.service ${pkgdir}/usr/lib/systemd/user/dbus-org.bluez.obex.service
+#  ln -fs /usr/lib/systemd/user/obex.service ${pkgdir}/usr/lib/systemd/user/dbus-org.bluez.obex.service

Testsuite summary for bluez 5.45
# TOTAL: 25
# PASS:  25
# SKIP:  0
# XFAIL: 0
# FAIL:  0
# XPASS: 0
# ERROR: 0

I wanted to build it with the tests if possible, although any build would be an improvement over none. I hadn't noticed the check funtion  ;D . I can't test it either, I have 2 bluetooth chips but no bluetooth devices.
If the tests complete there is a good chance the built package should work properly given the details on the bug report, also see the recent comment here:
Rebuilding all the bluez things with an older gcc version should hopefully fix the bluetooth problems.
Also you need an older gcc to build Pale Moon and gcc54 stopped getting updates last year and it was about time I got a newer version, but I'd been avoiding it as there are no alternative gcc  binary packages any more. I mounted another partition with more space and changed the build dir in pakku.conf, thankfully that built with no errors as it took 2 or 3 hours on my hw.

Re: Bluetooth PS3 controllers not connecting

Reply #16
######### Could you please make this into an AUR package? Big necessity if its stopping PS3 controllers from working. I suck at this stuff, you'd be a real life-saver for me and tons of others, I have no idea what I'm doing half the time and just wing it, usually that doesn't go so well lol... from what I understand I need a special version of GCC that doesn't exist in binary form and I have no idea where to begin with doing that! Maybe I will re-read things a couple times, sorry I'm slow.

Re: Bluetooth PS3 controllers not connecting

Reply #17
Here is how to install pakku from the AUR if you don't already have an AUR helper, you can git clone yay.git instead of pakku.git if you wanted yay. I have both installed atm, although this is perhaps slightly silly it isn't really problematic, and actually used yay to install pakku. yaourtix-git is in the binary repos so can be installed with pacman too. Once you have an aur helper it should make more sense, the gcc7 package can be built as standard from the AUR. I think an "Artix" UR would be required to get a PKGBUILD with systemd disabled accepted.  ;D pakku and yaourtix can use another AUR package called customizepkg to automate modified packages, I haven't got that far myself yet, but that's why I've been trying out pakku, as some other PKGBUILD's I've seen need adapting a bit to use with openrc.

I cut out a lot of the automated build output, it only took minutes to do all this, unlike the big gcc7 package:
Code: [Select]
$ mkdir pakku-test
$ cd pakku-test/
$ git clone
$ ls
$ cd pakku
$ ls
$ makepkg -sirc
==> Making package: pakku 0.13-2 (Tue 11 Jun 2019 02:21:59 BST)
[sudo] password for <me!>:
==> Checking runtime dependencies...
==> Checking buildtime dependencies...
==> Installing missing dependencies...
Packages (1) nim-0.18.0-1
Total Download Size:   17.68 MiB
Total Installed Size:  36.96 MiB
:: Proceed with installation? [Y/n] y
:: Retrieving packages...
(1/1) installing nim                                                                                       [----------------------------------------------------------------] 100
==> Retrieving sources...
  -> Downloading pakku-0.13.tar.xz...
==> Finished making: pakku 0.13-2 (Tue 11 Jun 2019 02:23:09 BST)
==> Installing package pakku with pacman -U...
warning: pakku-0.13-2 is up to date -- reinstalling
Packages (1) pakku-0.13-2
Total Installed Size:  0.70 MiB
Net Upgrade Size:      0.00 MiB
:: Proceed with installation? [Y/n] y
(1/1) reinstalling pakku                                                                                   [----------------------------------------------------------------] 100
==> Cleaning up...
==> Removing installed dependencies...
Packages (1) nim-0.18.0-1
Total Removed Size:  36.96 MiB
:: Do you want to remove these packages? [Y/n] y
(1/1) removing nim                                                                                         [----------------------------------------------------------------] 100%

Re: Bluetooth PS3 controllers not connecting

Reply #18
hmmm..... do you think you could make me a PKGBUILD I can use then? I don't know how to do this thing with GCC to use an older version and whatnot.

Re: Bluetooth PS3 controllers not connecting

Reply #19
 I'd guess gcc-git in the AUR could have a fix in it by now, and the next gcc release whenever that is will probably contain that. Installing that would replace /usr/bin/gcc so the export line would not be needed. The gcc mailing list search function didn't work for me though so I'm not sure!
We are really lucky to have gcc9 though, most distros are on older versions and gcc8 is so 2018  ;D
Here's the complete PKGBUILD I used:
Code: [Select]
# $Id$
# Maintainer: Tom Gundersen <[email protected]>
# Contributor: Andrea Scarpino <[email protected]>
# Contributor: Geoffroy Carrier <[email protected]>
# Contributor : ianux <[email protected]>

pkgdesc="Daemons for the bluetooth protocol stack. Patched to support PS3 controllers, including Gasia/Shanwan clones"
arch=('i686' 'x86_64')
provides=('bluez' 'bluez-plugins')
makedepends=('dbus' 'libical' 'systemd')
depends=('libical' 'dbus' 'glib2')
conflicts=('bluez' 'bluez-plugins' 'obexd-client' 'obexd-server')

#pkgver() {
#  cd ${srcdir}/${_gitname}
#  echo "$(git rev-list --count HEAD).g$(git rev-parse --short HEAD)"

build() {
  cd ${srcdir}/${_gitname}
  export CC=/usr/bin/gcc-7
  ./configure \
          --prefix=/usr \
          --mandir=/usr/share/man \
          --sysconfdir=/etc \
          --localstatedir=/var \
          --libexecdir=/usr/lib \
          --enable-sixaxis \
          --enable-systemd=no \

check() {
  cd ${srcdir}/${_gitname}
  make check

package() {
  cd ${srcdir}/${_gitname}
  make DESTDIR=${pkgdir} \
       install-libexecPROGRAMS \
       install-dbussessionbusDATA \
       install-systemdsystemunitDATA \
       install-systemduserunitDATA \
       install-dbussystembusDATA \
       install-dbusDATA \
       install-pluginLTLIBRARIES \

  # ship upstream main config file
  install -dm755 ${pkgdir}/etc/bluetooth
  install -Dm644 ${srcdir}/${_gitname}/src/main.conf ${pkgdir}/etc/bluetooth/main.conf

  # add basic documention
  install -dm755 ${pkgdir}/usr/share/doc/${pkgbase}/dbus-apis
  cp -a doc/*.txt ${pkgdir}/usr/share/doc/${pkgbase}/dbus-apis/
  # fix module loading errors
  install -dm755 ${pkgdir}/usr/lib/modprobe.d
  install -Dm644 ${srcdir}/bluetooth.modprobe ${pkgdir}/usr/lib/modprobe.d/bluetooth-usb.conf
  # fix obex file transfer -
#  ln -fs /usr/lib/systemd/user/obex.service ${pkgdir}/usr/lib/systemd/user/dbus-org.bluez.obex.service

Re: Bluetooth PS3 controllers not connecting

Reply #20
So... I should install GCC-7 and then bluez-ps3? Just trying to clarify, I don't have a great handle on this stuff yet.

Re: Bluetooth PS3 controllers not connecting

Reply #21
I got it to compile and install.... doesn't work... now I'm really lost. I just want my PS3 controllers to work so I can play games... I guess I have to revert to Debian or something...

Re: Bluetooth PS3 controllers not connecting

Reply #22
I saw this thread here:
It suggests bluez-ps3 is an older patched version and the newer versions of things should work anyway. Perhaps rebuilding some other bluez things might help? There is also a link on that thread to an Arch wiki page:
Regarding using and setting up bluetooth devices you know more than me, perhaps someone else can make some suggestions.

Re: Bluetooth PS3 controllers not connecting

Reply #23
I got it to compile and install.... doesn't work... now I'm really lost. I just want my PS3 controllers to work so I can play games... I guess I have to revert to Debian or something...

It is all about individual priorities, values and principles.  The closest I would get to debian would be antix, and that with a heavy heart and running sid (as I always did).

I saw this thread here:..... perhaps someone else can make some suggestions.

Good luck ever finding someone who cares this much in the debian universe, I never did.  Someone who would read something and instantly think of "it" being able to help someone who has a problem and spearing 5' to transfer a piece of information to the right party.


Re: Bluetooth PS3 controllers not connecting

Reply #25
well I'd love to know how to get this stuff to work, but sadly I have no clue.... Where do I even begin? I've rebuilt the packages, how do I rebuild them with the latest git source? That sounds like its far too complicated for me to do on my own... I can barely make PKGBUILDs for game emulators... that's about as far as my knowledge goes.

Re: Bluetooth PS3 controllers not connecting

Reply #26
It would appear my controllers work on Devuan running kernel 4.9, but not when I switch to 5.1 Liquorix... so its something in the kernel?
I've tried the linux-lts kernel but that doesn't seem to work either, I'm looking up a 4.9 or 4.14 kernel in the AUR, in the hopes that it may make it work... I could be all wrong about this, but from what I can see.... this is what I've gotta do... I gotta try..

I tried QTSIXA, an old program I used to use years ago before I knew of bluez-plugins, I had no luck with that, so I assume this must be something within the kernel. If anyone can point me to a PKGBUILD of a 4.14 or 4.9 kernel, I'd REALLY appreciate it.(I think I found one, but not sure if it'll work or not...)
the device is "uncategorized" in blueman on later kernels, but registers correctly as a peripheral (or keyboard for the non-legit ps3 controllers) on kernel 4.9 devuan.

Re: Bluetooth PS3 controllers not connecting

Reply #27
After all that was said about Manjaro kernels I don't see the harm of trying one or two

linux44-4.4.180-1-x86_64.pkg.tar.xz                17-May-2019 22:55            61858852
linux44-4.4.180-1-x86_64.pkg.tar.xz.sig            17-May-2019 22:55                 329
linux44-headers-4.4.180-1-x86_64.pkg.tar.xz        17-May-2019 22:55             7184356
linux44-headers-4.4.180-1-x86_64.pkg.tar.xz.sig    17-May-2019 22:55                 329
linux49-4.9.180-1-x86_64.pkg.tar.xz                31-May-2019 20:07            64436296
linux49-4.9.180-1-x86_64.pkg.tar.xz.sig            31-May-2019 20:07                 329
linux49-headers-4.9.180-1-x86_64.pkg.tar.xz        31-May-2019 20:08             7854336
linux49-headers-4.9.180-1-x86_64.pkg.tar.xz.sig    31-May-2019 20:08                 329
linux414-4.14.124-1-x86_64.pkg.tar.xz              09-Jun-2019 21:57            64234656
linux414-4.14.124-1-x86_64.pkg.tar.xz.sig          09-Jun-2019 21:57                 329
linux414-headers-4.14.124-1-x86_64.pkg.tar.xz      09-Jun-2019 21:57             8565252
linux414-headers-4.14.124-1-x86_64.pkg.tar.xz.sig  09-Jun-2019 21:57                 329

for example:
Code: [Select]
$ cd /tmp
$ wget
$ sudo pacman -U /tmp/linux49-4.9.180-1-x86_64.pkg.tar.xz
$ sudo grub-mkconfig -o /boot/grub/grub.cfg (or whatever bootloading you do)

Then boot linux49

Re: Bluetooth PS3 controllers not connecting

Reply #29
Schpankme that's awfully strange because I was using kernels 4.19 4.20 and such with the controllers.... I dunno what to make of that. and thank you fungal, but my GPU isn't supported by 4.9 :( I have an nvidia GTX 1070 Ti
Is there a way I can build this thing into the latest kernel? I like the XANMOD AUR kernel - that's the only one I typically would use.