Skip to main content
Topic: [SOLVED] Problems with perl update from 5.28.2-1 to 5.30.0-2 (Read 546 times) previous topic - next topic
0 Members and 1 Guest are viewing this topic.

[SOLVED] Problems with perl update from 5.28.2-1 to 5.30.0-2

As part of a recent "pacman -Syu" it seems perl got upgraded  from 5.28 to 5.30 - ending with "WARNING: '/usr/lib/perl5/5.28' contains data from at least 47 packages which will NOT be used by the installed perl interpreter."  The following line give a pacman command to get the list of those modules.  My problem is that I can't seem to resolve the problems.  Those packages in the regular repositories (I've forgotten the easy way to tell where each actually came from, although I think most are from extra) apparently have been built against perl 5.28, so just reinstalling doesn't change anything.  Those from AUR either reinstalled OK, or (perl-perl-prereqscanner and perl-dist-zilla) fail to install, seemingly due to not finding some of the other modules not yet available in 5.30.  
What's the proper way to request that these be rebuilt (or find they already have been, and I just need to wait for the mirrors to catch up)?

EDIT:  I suppose I should know enough just to wait a few days.  I got the new perl from gremlins, but the perl-xxxx modules are in other repositories which take a bit longer to catch up with such things.  All modules from extra got updated today, and after that, the rest from AUR were able to be rebuilt with no more errors.