Skip to main content
Topic: Update problems. [solved] (Read 438 times) previous topic - next topic
0 Members and 1 Guest are viewing this topic.

Re: Update problems

Reply #15
Code: [Select]
[/kaos:[root]:/home/keos# LANG=C pacman -Syu
:: Synchronizing package databases...
 system is up to date
 world is up to date
 galaxy is up to date
 lib32 is up to date
 extra is up to date
 community is up to date
 multilib is up to date
:: Starting full system upgrade...
 there is nothing to do
kaos:[root]:/home/keos#

code]

Why i can't use pacman -Syyu now in arch?
Mate
Desktop: xfce

Graphics: AMD Radeon HD 7640G integrated graphics
GPU: AMD/ATI Trinity [Radeon HD 7640G]

Re: Update problems

Reply #16
pacman -Syu updates your databases if the repositories haven’t been checked recently, and upgrades any new package versions.

pacman -Syyu forces updates of your databases for all repositories (even if it was just updated recently) and upgrades any new package versions.

pacman -Syuu upgrades packages and also downgrades packages (if you happen to have a newer version than in the repository). Normally this should not be used. Only if you’re trying to fix a specific issue due to a new package being removed from the repository.

This is what we know from reading documentation around:

    -y checks the repositories hashes on the available mirrors, comparing them to the local system. If there is a difference, downloads and updates the package list from the available mirrors.
    -yy doesn’t check anything. Just downloads and updates the package list for all repositories from the available mirrors.

On the surface, there doesn’t seem to be much point to this. Why not just, you know, always use -yy? And in fact, you can. It’s perfectly alright.

    -y checks the repositories hashes on the available mirrors, comparing them to the local system. If there is a difference, downloads and updates the package list from the available mirrors. Use it when you haven’t made any changes to your repository or mirror list.
    -yy doesn’t check anything. Just downloads and updates the package list for all repositories from the available mirrors. Use it when you changed your repository or mirror lists.

source: https://forum.manjaro.org/t/syu-vs-syuu-vs-syyu/26486/6

Re: Update problems. [solved]

Reply #17
Well, i don't understand much ... in Manjaro i'm able to do this, it looks to me that maybe different distros has different philosophies ;)


 Thanks!
Mate
Desktop: xfce

Graphics: AMD Radeon HD 7640G integrated graphics
GPU: AMD/ATI Trinity [Radeon HD 7640G]

Re: Update problems. [solved]

Reply #18
Well, i don't understand much ... in Manjaro i'm able to do this, it looks to me that maybe different distros has different philosophies ;)


 Thanks!
Did you try a simple sudo pacman  -Syyu by any chance with no additional garbage 1st

Re: Update problems. [solved]

Reply #19
Code: [Select]
kaos:[root]:/home/keos# LANG=C pacman -Syyu
:: Synchronizing package databases...
 system                   218.8 KiB   396K/s 00:01 [----------------------] 100%
 world                    775.7 KiB  2.21M/s 00:00 [----------------------] 100%
 galaxy                   602.3 KiB  5.16M/s 00:00 [----------------------] 100%
 lib32                     15.2 KiB  0.00B/s 00:00 [----------------------] 100%
 extra                     12.7 KiB  0.00B/s 00:00 [----------------------] 100%
error: could not open file /var/lib/pacman/sync/?mac=0C%3A8D%3ADB%3A6E%3AAB%3A0D&real_ip=10.200.12.152&client_ip=10.84.187.218&client_mac=2C:D0:5A:35:D6:92&vap=0&a=972a67c48192728a34979d9a35164c1295401b71&b=799963&auth_version=5&key=347bfa16bd7d5296de497f9787ae0eea74be4673&acl_ver=P4628682V2&continue_url=http%3A%2F%2Fmirror.rackspace.com%2Farchlinux%2Fextra%2Fos%2Fx86_64%2Fextra.db.sig.part: File name too long
 community                 12.7 KiB  0.00B/s 00:00 [----------------------] 100%
error: could not open file /var/lib/pacman/sync/?mac=0C%3A8D%3ADB%3A6E%3AAB%3A0D&real_ip=10.200.12.152&client_ip=10.84.187.218&client_mac=2C:D0:5A:35:D6:92&vap=0&a=972a67c48192728a34979d9a35164c1295401b71&b=799963&auth_version=5&key=347bfa16bd7d5296de497f9787ae0eea74be4673&acl_ver=P4628682V2&continue_url=http%3A%2F%2Fmirror.rackspace.com%2Farchlinux%2Fcommunity%2Fos%2Fx86_64%2Fcommunity.db.sig.part: File name too long
 multilib                  12.7 KiB  0.00B/s 00:00 [----------------------] 100%
error: could not open file /var/lib/pacman/sync/?mac=0C%3A8D%3ADB%3A6E%3AAB%3A0D&real_ip=10.200.12.152&client_ip=10.84.187.218&client_mac=2C:D0:5A:35:D6:92&vap=0&a=972a67c48192728a34979d9a35164c1295401b71&b=799964&auth_version=5&key=a1aae277324acc1a4b9ff29fc1e943712aeaca4e&acl_ver=P4628682V2&continue_url=http%3A%2F%2Fmirror.rackspace.com%2Farchlinux%2Fmultilib%2Fos%2Fx86_64%2Fmultilib.db.sig.part: File name too long
:: Starting full system upgrade...
error: could not open file /var/lib/pacman/sync/extra.db: Unrecognized archive format
error: could not open file /var/lib/pacman/sync/community.db: Unrecognized archive format
error: could not open file /var/lib/pacman/sync/multilib.db: Unrecognized archive format
 there is nothing to do
kaos:[root]:/home/keos#

kaos:[keos]:~% sudo pacman  -Syyu
[sudo] password for keos:
:: Sincronizando las bases de datos de los paquetes...
 system                   218.8 KiB   260K/s 00:01 [----------------------] 100%
 world                    775.7 KiB  2.01M/s 00:00 [----------------------] 100%
 galaxy                   602.3 KiB  4.42M/s 00:00 [----------------------] 100%
 lib32                     15.2 KiB  4.95M/s 00:00 [----------------------] 100%
 extra                     12.7 KiB  0.00B/s 00:00 [----------------------] 100%
error: no se pudo abrir el archivo /var/lib/pacman/sync/?mac=0C%3A8D%3ADB%3A6E%3AAB%3A0D&real_ip=10.200.12.152&client_ip=10.84.187.218&client_mac=2C:D0:5A:35:D6:92&vap=0&a=972a67c48192728a34979d9a35164c1295401b71&b=800040&auth_version=5&key=ac0d978f284d3371d5c1380e211f30b5836e46bb&acl_ver=P4628682V2&continue_url=http%3A%2F%2Fmirror.rackspace.com%2Farchlinux%2Fextra%2Fos%2Fx86_64%2Fextra.db.sig.part: Nombre de fichero demasiado largo
 community                 12.7 KiB  0.00B/s 00:00 [----------------------] 100%
error: no se pudo abrir el archivo /var/lib/pacman/sync/?mac=0C%3A8D%3ADB%3A6E%3AAB%3A0D&real_ip=10.200.12.152&client_ip=10.84.187.218&client_mac=2C:D0:5A:35:D6:92&vap=0&a=972a67c48192728a34979d9a35164c1295401b71&b=800040&auth_version=5&key=ac0d978f284d3371d5c1380e211f30b5836e46bb&acl_ver=P4628682V2&continue_url=http%3A%2F%2Fmirror.rackspace.com%2Farchlinux%2Fcommunity%2Fos%2Fx86_64%2Fcommunity.db.sig.part: Nombre de fichero demasiado largo
 multilib                  12.7 KiB  0.00B/s 00:00 [----------------------] 100%
error: no se pudo abrir el archivo /var/lib/pacman/sync/?mac=0C%3A8D%3ADB%3A6E%3AAB%3A0D&real_ip=10.200.12.152&client_ip=10.84.187.218&client_mac=2C:D0:5A:35:D6:92&vap=0&a=972a67c48192728a34979d9a35164c1295401b71&b=800040&auth_version=5&key=ac0d978f284d3371d5c1380e211f30b5836e46bb&acl_ver=P4628682V2&continue_url=http%3A%2F%2Fmirror.rackspace.com%2Farchlinux%2Fmultilib%2Fos%2Fx86_64%2Fmultilib.db.sig.part: Nombre de fichero demasiado largo
:: Iniciando actualización completa del sistema...
error: no se pudo abrir el archivo /var/lib/pacman/sync/extra.db: Unrecognized archive format
error: no se pudo abrir el archivo /var/lib/pacman/sync/community.db: Unrecognized archive format
error: no se pudo abrir el archivo /var/lib/pacman/sync/multilib.db: Unrecognized archive format
...el sistema ya está actualizado.
kaos:[keos]:~%

Mate
Desktop: xfce

Graphics: AMD Radeon HD 7640G integrated graphics
GPU: AMD/ATI Trinity [Radeon HD 7640G]

Re: Update problems. [solved]

Reply #20
The problem is back again, there is something wrong with this installation, i'm having many problems too with applications...

Code: [Select]
kaos:[root]:/home/keos# LANG=C pacman -Syu 
:: Synchronizing package databases...
error: failed to update system (unable to lock database)
error: failed to update world (unable to lock database)
error: failed to update galaxy (unable to lock database)
error: failed to update lib32 (unable to lock database)
error: failed to update extra (unable to lock database)
error: failed to update community (unable to lock database)
error: failed to update multilib (unable to lock database)
error: failed to synchronize all databases
kaos:[root]:/home/keos# LANG=C pacman -Syyu
:: Synchronizing package databases...
error: failed to update system (unable to lock database)
error: failed to update world (unable to lock database)
error: failed to update galaxy (unable to lock database)
error: failed to update lib32 (unable to lock database)
error: failed to update extra (unable to lock database)
error: failed to update community (unable to lock database)
error: failed to update multilib (unable to lock database)
error: failed to synchronize all databases
kaos:[root]:/home/keos# pacman -Syu
:: Sincronizando las bases de datos de los paquetes...
error: no se pudo actualizar system (no se pudo bloquear la base de datos)
error: no se pudo actualizar world (no se pudo bloquear la base de datos)
error: no se pudo actualizar galaxy (no se pudo bloquear la base de datos)
error: no se pudo actualizar lib32 (no se pudo bloquear la base de datos)
error: no se pudo actualizar extra (no se pudo bloquear la base de datos)
error: no se pudo actualizar community (no se pudo bloquear la base de datos)
error: no se pudo actualizar multilib (no se pudo bloquear la base de datos)
error: no se pudo sincronizar ninguna base de datos
kaos:[root]:/home/keos# pacman -Syyu
:: Sincronizando las bases de datos de los paquetes...
error: no se pudo actualizar system (no se pudo bloquear la base de datos)
error: no se pudo actualizar world (no se pudo bloquear la base de datos)
error: no se pudo actualizar galaxy (no se pudo bloquear la base de datos)
error: no se pudo actualizar lib32 (no se pudo bloquear la base de datos)
error: no se pudo actualizar extra (no se pudo bloquear la base de datos)
error: no se pudo actualizar community (no se pudo bloquear la base de datos)
error: no se pudo actualizar multilib (no se pudo bloquear la base de datos)
error: no se pudo sincronizar ninguna base de datos
kaos:[root]:/home/keos#

After turn off the PC for some time and start the system again i was able to do the update, probably an unstable system, let's wait and see ...

Mate
Desktop: xfce

Graphics: AMD Radeon HD 7640G integrated graphics
GPU: AMD/ATI Trinity [Radeon HD 7640G]

Re: Update problems. [solved]

Reply #21
No if using pamac, octopi, that happens turn of the update notifier or better still remover as it plays havac with octopi, pamac, and pacman

Please stop the Manjaro does this and that it does the same they both draw from Arch. using Arch packages  Pamac octopi are manjaro packages