Skip to main content
Topic: system does not enter graphic environment crashes (Read 196 times) previous topic - next topic
0 Members and 1 Guest are viewing this topic.

system does not enter graphic environment crashes

hello after an update the system does not start the graphics I get stuck on starting service local.
give me warning netmount will start when networkmanager has started.
what can I see to fix, as system uses openrc.
thanks in advance

Re: system does not enter graphic environment crashes

Reply #1
Does your network card use an out-of-kernel module, some sort of -dkms? If so, it needs to be updated for your current kernel and NM is satisfied. Alternatively, boot into single-user mode and disable NM (rc-update del networkmanager) and reboot, hopefully into desktop. You can then try to start NM manually or fix the module problem.

Re: system does not enter graphic environment crashes

Reply #2
Code: [Select]
rc-update del networkmanager
for starters  - how does one boot into single user mode?

Gentoo's sysvinit setup
Gentoo's sysvinit setup, as specified in its standard /etc/inittab file, is as follows:

The default runlevel is 3. This is specified in an initdefault entry.
init executes an openrc sysinit command during the boot sequence and waits for it to finish. This is specified in a sysinit entry, and makes OpenRC start services in its sysinit runlevel.
init then executes an openrc boot command and waits for it to finish. This is specified in a bootwait entry, and makes OpenRC start services in its boot runlevel.
Entering runlevel 1 makes init execute an openrc single command and wait for it to finish, then spawn an agetty process for terminal /dev/tty1. The openrc invocation makes OpenRC stop all its managed services except those in its sysinit runlevel.
Entering runlevel 2 makes init execute an openrc nonetwork command and wait for it to finish, then spawn agetty processes for terminals /dev/tty1 to /dev/tty6. The openrc invocation makes OpenRC start services in its nonetwork runlevel.
Entering runlevel 3 makes init execute an openrc default command and wait for it to finish, then spawn agetty processes for terminals /dev/tty1 to /dev/tty6. The openrc invocation makes OpenRC start services in its default runlevel.
Runlevels 4 and 5 are identical to runlevel 3.
Entering runlevel 0 makes init re-execute itself, then execute an openrc shutdown command and wait for it to finish, then power the machine off with a halt -dhnp command. The openrc invocation makes OpenRC start services in its shutdown runlevel.
Entering runlevel 6 makes init re-execute itself, then execute an openrc reboot command and wait for it to finish, then reboot the machine with a reboot -dkn command. The openrc invocation makes OpenRC start services in its shutdown runlevel, and set variable RC_REBOOT to "YES" in the environment of executed service scripts. This allows services to use RC_REBOOT to determine whether a reboot operation was requested or not.
Entering single user mode makes init execute an openrc single command and wait for it to finish, then spawn an emergency shell by invoking the sulogin program.
Using a telinit a command makes init execute the /etc/X11/startDM.sh script. This is specified in a once entry, and used by OpenRC service script /etc/init.d/xdm from package x11-base/xorg-server to launch a display manager. Script /etc/X11/startDM.sh is provided by package x11-apps/xinit.
Pressing the Ctrl+Alt+Del key combination makes init reboot the machine with a shutdown -r now command. This is specified in a ctrlaltdel entry.
agetty process are specified in respawn entries, so that when a user's interactive shell exits, it is possible to log in again on the terminal the shell used. The Gentoo ebuild might also add architecture-specific entries to /etc/inittab, to make init spawn additional agetty processes for special character device nodes.

https://wiki.artixlinux.org/Main/OpenRC#Runlevels

Re: system does not enter graphic environment crashes

Reply #3

I have disabled the agetty services so I do not arrive and enter the virtual terminal and disable network manager.
I tried to chroot live but it won't let me in

Re: system does not enter graphic environment crashes

Reply #4
I have disabled the agetty services so I do not arrive and enter the virtual terminal and disable network manager.
I tried to chroot live but it won't let me in



This is a real head scratcher and easier to fix in person than over a forum, but I will say two points:  First there is a usually a  hardware issue of either a broken driver for the GPU or possibly broken hardware itself ...  turning off the ttys is not that useful.  You need a terminal to talk to the thing even in single user mode. 

What GPU are you using?



Re: system does not enter graphic environment crashes

Reply #7
you mean :)

https://wiki.artixlinux.org/Main/OpenRC#Runlevels
https://wiki.artixlinux.org/Main/OpenRC#Selecting_a_specific_runlevel_at_boot

maybe?

Code: [Select]
Selecting a specific runlevel at boot
OpenRC reads the kernel command-line used at boot time, and will start the runlevel specified by the softlevel parameter if provided, instead of default. For instance, you can choose whether to boot into the default, nonetwork or single-user runlevels with the following example grub.conf configuration:

 /boot/grub/grub.conf
 title=Regular start-up
 kernel (hd0,0)/boot/vmlinuz-linux root=/dev/sda3
 title=Start without networking
 kernel (hd0,0)/boot/vmlinuz-linux root=/dev/sda3 softlevel=nonetwork
 title=Single-user mode
 kernel (hd0,0)/boot/vmlinuz-linux root=/dev/sda3 softlevel=single
Usage