Skip to main content
Topic: thunar automount devices (Read 1843 times) previous topic - next topic
0 Members and 1 Guest are viewing this topic.

Re: thunar automount devices

Reply #15
Well it does the trick though it seems like not completely...
I will try to write short post not long one this time... What i am trying to perform is Call of Duty 1 installation. Even with gvfs i instert CoD1 CD and it's fine i can boot installation and install then thjere is 40% and it asks me for 2CD. When i press unmouint in thunar it says Volume is busy. Same thing was happening with mount /dev/cdrom /*folder* i am not able to unmount cd 1 because the installation is running, but i remember on artix lxqt i was able to install multiple cds just fine when i ejected cdrom and changed the cd it was automatically updating in the file manager well i had to click on CoD2 and then mounted file displayed stuff from cd2 so i was able to perform installation, but i can't now. Same thing happened when i tried to install it on manjaro openbox...

Right now i have ejected cd from the cd rom and there is CoD2 in Devices but when i click on it the directory is still /run/media/f/CoD1/ it should be CoD2... :D.
I know that this isn't related to linux or Artix because it's windows game, i had similar frustrating stuff with configuring nvidia optimus in the past when i had no idea how to setup bumblebee etc. now it's some windows games urgh!!!

Re: thunar automount devices

Reply #16
Right now I have ejected cd from the cd rom and there is CoD2 in Devices but when I click on it the directory is still /run/media/f/CoD1/ it should be CoD2... :D.

You sure? It might include the contents of the 2nd disk in that folder (I assume it's not since  you didn't continue the installation)

Right now you have a problem with dealing with these 2-part disks and not automounting devices anymore. Here are many ways to solve this. Choose whichever you prefer, but I can't promise anything.

  • Try running the setup from outside of disk directory (Do wine /media/dvd/setup.exe instead of cd /media/dvd; wine setup.exe). This will prevent disk locks and you will be able to eject the disc
  • When the disk can't be ejected. Use fuser to find the process that use the directory and kill it
    Code: [Select]
    # cd
    # fuser /cdrom
    # kill -9 514  # or whatever process number(s) show
    # eject cd
  • Extract the contents of both disk in separate folder, merge them (including hidden files), then run the setup

If I can hit that bullseye, the rest of the dominoes will fall like a house of cards. Checkmate!

Re: [solved]thunar automount devices

Reply #17

Thank you for help. Well i think it's probably something wrong with the call of duty, because for some reason i have installed diablo 2 fine, when i insterted cd 2 and cd 3 it read it okay... Same when i insert sd card to the laptop it reads everything ok too...

So i have no idea what's going on, i did something like copied all stuff from cd 1 and 2 to one folder and installed cod1 but there was some buffer error during start... Then last time i have insterted CD 2 and it read it ok there was installator report couldn't find some file or something...

I have no idea what's the matter, but fuck it... Ill play it maybe different time, i have got lots of games to complete anyways...
However i have configured the automount thing and polkits... Cheers!!

Re: thunar automount devices

Reply #18
Are you playing with wine or playonlinux or do you have native Linux games ?

Just curious.. .. sounds  as if you want to use windows games and I don't understand how that works..

Re: thunar automount devices

Reply #19
I have had problem with installing Call of Duty 1 on either Manjaro openbox edition and Artix... Well i deleted manjaro cuz i thought maybe installing artix base will resolve this but no luck.

What has been happening is that when installing some games i had to mount the cd-rom with command lines.
So basically
Code: [Select]
mkdir /cdrom 
mount /dev/cdrom /cdrom
So cd1 was fine but then when CoD1 installer asked me for 2nd i couldn't unmount the first cd cuz it stated the device is busy.
Even when i opened the cd-rom and inserted 2nd disc, for the computer the first disk was still mounted and there was nothing on from the CD2, i suppose the wine installer reads just one cd-rom but 2nd cd couldn't be mounted on the same one that cd1 was on...

But it's just happens with call of duty, cuz when i install Diablo 2 that has 3 discs, it was reading all of them automatically, or was even able to unmount the partition then mount the 2nd cd on the same directory /cdrom...
I remember that i managed to install CoD1 on Artix .lxqt iso from 2018 maybe or 2019 but now im using artix runit i have installed from base .iso :D.
Yeah it's wine game, i have tried PlayonLinux but same thing has happened ;P

So i have also tried i copied all stuff from CoD CD1 and CD2 to one folder then run the installation, and i managed to install this game but there was some buffer error so couldn't say if this is just error or something hasn't been copied properly to the installation directory...
It's fine it's just one game, but it's probably something related to windows from this time i suppose...