Skip to main content
Topic: thunar automount devices (Read 504 times) previous topic - next topic
0 Members and 1 Guest are viewing this topic.

thunar automount devices

Hey

I have no idea what subject should be here. I have installed artix base for first time yesterday (yay  :D ) runit one with xfce. I have used lxqt .iso for some time and there was very huge convenience that i liked very much which was automount devices in filemanager. Well i have got about 25 windows pc games and part of them require multiple CD's for installation... The problem is that when i use
Code: [Select]
mkdir /cdrom 
mount /dev/cdrom

it only makes sense for 1 cd, but when installer asks me for 2cd then when i try to umount /cdrom it says target is busy. If i eject and insert cd2 it won't recognize the second disk therefore i am stuck (but for some reason i managed to install diablo 2 that has 3 cds i have no idea why, but call of duty 1 no luck).

So i went on #artix yesterday and asked for solution, a nice person suggested to install GVFS and it was ok at first but after reboot the devices appear on thunar list but... it won't even ask me for password. If i open thunar with root permissions the devices don't appear on the list.
Well i think it is supposed to ask me for password first before opening a device, but it doesn't. I read on internet that i should install polkit-gnome well i have got it installed... I am so used to systemd that does things for me automatically and now i am on runit i have no idea how to manage everything!!?? PLS help how can i install games windows way without mounting anything manually????? Thanks
artix runit xfce4
I am vegeterian ^.^

May all beings have happiness and the causes of happiness;
May all beings be free from suffering and the causes of suffering;

Re: thunar automount devices

Reply #1
I don't use a login manager (lightdm or so) and start thunar in ~/.xinitrc like so (first line):

Code: [Select]
dbus-launch thunar --daemon &
# start other programs etc..
exec fvwm

It was the same problem here. "dbus-launch"  seemed to be the solution.
Otherwise maybe try installing lightdm.. ..and/or  thunar-volman

Re: thunar automount devices

Reply #2
Hey
Thanks :-)

I have got lightdm installed. The way i boot into system though is that i get prompted to tty, i type root and password then from terminal i type # lightdm and then i get log in box... I haven't ./xinitrc on the system. I have got thunar-volman installed but when i try to run it from terminal i get this error:
Code: [Select]
thunar-volman: Must specify the sysfs path of new devices with --device-added.
artix runit xfce4
I am vegeterian ^.^

May all beings have happiness and the causes of happiness;
May all beings be free from suffering and the causes of suffering;

Re: thunar automount devices

Reply #3
Hi.

If you want to use lightdm as login manager you can "enable" it.  Install lightdm-runit (if you use runit) and then:

 
Code: [Select]
sudo ln -s /etc/runit/sv/lightdm  /run/runit/service
 
I believe (not sure) when you then boot and lightdm starts, you can choose xfce and login, and lightdm will start thunar in the background. I think I have read something like that.

Re: thunar automount devices

Reply #4
ln: failed to create symbolic link '/run/runit/service/lightdm': File exists

thanks for your help :-)
artix runit xfce4
I am vegeterian ^.^

May all beings have happiness and the causes of happiness;
May all beings be free from suffering and the causes of suffering;

Re: thunar automount devices

Reply #5
Code: [Select]
sudo sv status /run/runit/service/*

should list your services. when lightdm is running it should come up at boot.. (?)

aah I remember. you have to edit xdm config..
Code: [Select]
 nano /etc/conf.d/xdm        <- edit and set DISPLAYMANAGER="lightdm"

(or maybe stop the xdm service, if running. not sure)

Re: thunar automount devices

Reply #6
it says that /conf.d doesn't exist

fuck i have installed artix base and i am completely idiot in terms of linux so i dont know stuff but i manatged to install artix base runit just fine and xfce... sorry :(
artix runit xfce4
I am vegeterian ^.^

May all beings have happiness and the causes of happiness;
May all beings be free from suffering and the causes of suffering;

Re: thunar automount devices

Reply #7
I would look here:

Code: [Select]
sudo sv status /run/runit/service/*

if lightdm or xdm are running. or maybe another display login manager.
maybe you need to enable xdm ( "sudo ln -s ...." as above) not sure

see here: https://wiki.artixlinux.org/Main/Installation#Display_Login_Manager (but for openrc there)

Re: thunar automount devices

Reply #8
aah I remember. you have to edit xdm config..
Code: [Select]
 nano /etc/conf.d/xdm        <- edit and set DISPLAYMANAGER="lightdm"

(or maybe stop the xdm service, if running. not sure)

That's OpenRC-exclusive.

I would look here:

Code: [Select]
sudo sv status /run/runit/service/*

if lightdm or xdm are running. or maybe another display login manager.
maybe you need to enable xdm ( "sudo ln -s ...." as above) not sure

see here: https://wiki.artixlinux.org/Main/Installation#Display_Login_Manager (but for openrc there)

No, xdm should not be enabled if lightdm is already enabled. It's two service colliding.
the runit guy on artix

Re: thunar automount devices

Reply #9
Sorry but i have no clue what display manager has in common with mounting devices, i think i need somehow to manage how to get asked for authentication cuz i have got partitions showed in thunar but when i click well nothing happens

If i type dbus thunar i get this error
Quote
D-Bus library appears to be incorrectly set up: see the manual page for dbus-uuidgen to correct this issue. (Failed to open "/var/lib/dbus/machine-id": No such file or directory; UUID file '/etc/machine-id' should contain a hex string of length 32, not length 0, with no other text)

Well it's not like it's urge but you know in artix lxqt iso the automount is configured properly though... basically what i mean to achieve is when i insert some cd with game it will show up in thunar and i can click on it and then start installation and then if i get asked to insert 2cd i insert it and thunar detects this as well so i can continue installation :-(
artix runit xfce4
I am vegeterian ^.^

May all beings have happiness and the causes of happiness;
May all beings be free from suffering and the causes of suffering;

Re: thunar automount devices

Reply #10
Ok sorry for double post i think there might be problem with user rights... When i log in with root and start xfce i can access stuff like mtp smartphone fine or other partitions... But after base installation i created user f and well it seems like he's got limited permissions :-). Maybe i will find a solution online but if somebody can tell me how to enable right permissions for user i have created it will be appreciated, thanks ;)
artix runit xfce4
I am vegeterian ^.^

May all beings have happiness and the causes of happiness;
May all beings be free from suffering and the causes of suffering;

Re: thunar automount devices

Reply #11
Have a look in thunar in "Settings-->advanced" (I only see it in german here) for removable media settings..
It was showing me a hint there, why it wouldn't work.

Re: thunar automount devices

Reply #12
Have you got sudo pacman -Sy gvfs installed

Re: thunar automount devices

Reply #13
Yeah
world/gvfs 1.40.2-1 (gnome) [installed]

I tried thunar advanced preferences but no luck. I think it's probably user permissions issue ut i dont know how to solve it :D
artix runit xfce4
I am vegeterian ^.^

May all beings have happiness and the causes of happiness;
May all beings be free from suffering and the causes of suffering;

 

Re: thunar automount devices

Reply #14
Well i think it is supposed to ask me for password first before opening a device, but it doesn't. I read on internet that i should install polkit-gnome well i have got it installed... I am so used to systemd that does things for me automatically and now i am on runit i have no idea how to manage everything!!?? PLS help how can i install games windows way without mounting anything manually????? Thanks

What? Why would you want a password authorization to access a CD partition? The purpose of automount is to be able to access partition and removable media WITHOUT a password.

You are correct to install polkit-gnome because your file manager (thunar) requires a polkit authentication agent. But you need make sure your DE (which is XFCE) autostarted polkit-gnome on login

Head over your XFCE's settings > Session and Startup > Application Autostart > Add a command /usr/lib/polkit-gnome/polkit-gnome-authentication-agent-1 > re-login, then it should work

Report back if something wrong

See also:

https://wiki.archlinux.org/index.php/File_manager_functionality
https://wiki.archlinux.org/index.php/Polkit
https://wiki.archlinux.org/index.php/Udisks
 
If I can hit that bullseye, the rest of the dominoes will fall like a house of cards. Checkmate!