Skip to main content
Topic solved
This topic has been marked as solved and requires no further attention.
Topic: Nvidia modules wrong kernel (Read 97 times) previous topic - next topic
0 Members and 1 Guest are viewing this topic.

Nvidia modules wrong kernel

Upgraded last night and rebooted. No X

in Xorg log
Quote
[    15.556] (EE) NVIDIA: Failed to initialize the NVIDIA kernel module. Please see the

I downgraded linux and nvidia to the previously installed versions (both had just been upgraded). Rebooted and I have X again.
Looked in the upgraded Nvidia (nvidia-435.21-15-x86_64.pkg.tar.xz) package and modules are in 5.3.8-artix1-1 whereas the upgraded linux package (linux-5.3.8.1-2-x86_64.pkg.tar.xz) has its modules in  5.3.8-artix1-2
Should these not be the same ? Regardless the modules were not being found.


(Another thing I noticed is linux-5.3.8.1-2-x86_64.pkg.tar.xz has no /boot/vmlinuz-linux , which seems odd ? But I haven't looked further into. Must be somewhere else ?)

Re: Nvidia modules wrong kernel

Reply #1
Ok nvidia package has been updated again (435.21-15.1)  and now contains the correct modules :)

Re: Nvidia modules wrong kernel

Reply #2
Yup, you were caught in the middle of a mirror sync. Perhaps you should use the -dkms versions of the packages or not auto-update the kernel and nvidia packages.
Once I hit a stable (i.e. trouble-free hibernate-resume cycles) kernel, I don't update it for a loooong time. Still on 4.20.14-ck...

Re: Nvidia modules wrong kernel

Reply #3
Yup, you were caught in the middle of a mirror sync. Perhaps you should use the -dkms versions of the packages or not auto-update the kernel and nvidia packages.
Once I hit a stable (i.e. trouble-free hibernate-resume cycles) kernel, I don't update it for a loooong time. Still on 4.20.14-ck...


That's good advice. I hadn't considered the dkms package and now I think about it I don't know why  :D