Skip to main content
Topic solved
This topic has been marked as solved and requires no further attention.
Topic: Bumblebee failure after update (Read 54 times) previous topic - next topic
0 Members and 1 Guest are viewing this topic.

Bumblebee failure after update

Hi everybody, I'm not really sure if it is the same issue as here.

I'm currently using the lts kernel (version 4.19.81-2-lts) and the nvidia-390xx-lts driver (I have a GT540M card). After an update bumblebee gives the usual errors that it can't access secondary GPU or failed to load nouveau module. Usually I wait for a driver update because this is not the first time that the kernel and the driver aren't in sync.

But time passes and the problem persist so I tried everything I could find to solve it until I noticed that in the /usr/lib/modules are two dirs. One for the 4.19.81-2 kernel and one for the 4.19.81-1 kernel and find that there are no nvidia modules for my kernel but there are for the old one.

Is there any workaround for this?

I tried to rollback to the previous version of the kernel and headers but OMG for a reason that it is not the subject of this topic I had to clear the cache and I can't install the previous version.

Is there anyway to download the 4.19.81-1 version of the kernel and headers? I'm new to Artix and I don't know if there is some repo to download older versions of some packages.

Thanks in advance for your answers and forgive me if I made some mistakes because english isn't my native language

Re: Bumblebee failure after update

Reply #1
Well it happens, for such cases use dkms packages.
Simple pros and cons: Always for your actual kernel but the update takes longer.

Code: [Select]
pacman -S nvidia-390xx-dkms
Man is as good as his tools.

Re: Bumblebee failure after update

Reply #2
I unnistalled the lts version and installed the dkms version and now it's working again. I never used the dkms version because I allways thought that it was for custom kernels.

Thank you very much for your answer.