Skip to main content
Topic: Thunderbird looking for older ICU (Read 117 times) previous topic - next topic
0 Members and 1 Guest are viewing this topic.

Thunderbird looking for older ICU

Hi,
Had a problem with Thunderbird 68.2.2 refusing to load, removing and reinstalling it didn't help:

XPCOMGlueLoad error for file /usr/lib/thunderbird/libxul.so:
libicui18n.so.64: cannot open shared object file: No such file or directory
Couldn't load XPCOM.

Installed version of icu is 65.1-2. I reverted to 64.2-1 and that works fine. Backing up the files libicui18n.so.64, libicuuc.so.64 and libicudata.so.64 and putting them into /usr/lib after going back to 65.1-2 also seems fine.

On a different computer that I just did a fresh Artix installation on today Thunderbird 68.2.2 works with just icu 65.1-2. Any idea why TB is looking for these older versions?

Thanks!