Skip to main content
Topic solved
This topic has been marked as solved and requires no further attention.
Topic: [SOLVED] Elogind conflict (Read 99 times) previous topic - next topic
0 Members and 2 Guests are viewing this topic.

[SOLVED] Elogind conflict

As I was moving from Arch to Artix, and was about to install the init system, the following problem pops up:
Code: [Select]
error: unresolvable package conflicts detected
error: failed to prepare transaction (conflicting dependencies)
:: eudev-openrc and eudev-runit are in conflict

I chose runit as my init system as you can see above, but for some reason it conflicts with this OpenRC package even though I hadn't installed OpenRC.

 

Re: Elogind conflict

Reply #1
For runit you must install eudev (and maybe elogind) services explicitly: installator tries to install automatically openrc scripts without checking what init did you choose