Skip to main content
Topic: broken update with pyqt5-common and python-pyqt (Read 2964 times) previous topic - next topic
0 Members and 2 Guests are viewing this topic.

broken update with pyqt5-common and python-pyqt

Hello all! I tried to update my machine today and I came across a problem with pyqt5 that I'm not sure how to resolve. I'm running KDE Plasma. There is also an error related to xorgproto. Is anyone else seeing this error?

Code: [Select]
[[email protected] ~]$ sudo pacman -Syyu
[sudo] password for rocky:
:: Synchronizing package databases...
 system                                                                     222.9 KiB  6.59 MiB/s 00:00 [#############################################################] 100%
 world                                                                      938.9 KiB  27.8 MiB/s 00:00 [#############################################################] 100%
 galaxy                                                                     833.4 KiB  30.1 MiB/s 00:00 [#############################################################] 100%
 lib32                                                                       14.5 KiB  3.54 MiB/s 00:00 [#############################################################] 100%
 extra                                                                     1642.4 KiB  18.4 MiB/s 00:00 [#############################################################] 100%
 community                                                                    4.8 MiB  31.7 MiB/s 00:00 [#############################################################] 100%
 multilib                                                                   163.7 KiB  22.8 MiB/s 00:00 [#############################################################] 100%
:: Starting full system upgrade...
:: Replace wine_gecko with community/wine-gecko? [Y/n]
resolving dependencies...
looking for conflicting packages...
:: python-pyqt5 and pyqt5-common are in conflict. Remove pyqt5-common? [y/N]
error: unresolvable package conflicts detected
error: failed to prepare transaction (conflicting dependencies)
:: python-pyqt5 and pyqt5-common are in conflict
[[email protected] ~]$ sudo pacman -R python-pyqt5
checking dependencies...
error: failed to prepare transaction (could not satisfy dependencies)
:: removing python-pyqt5 breaks dependency 'python-pyqt5' required by kajongg
[[email protected] ~]$ sudo pacman -R python-pyqt5 kajongg
checking dependencies...
error: failed to prepare transaction (could not satisfy dependencies)
:: removing kajongg breaks dependency 'kajongg' required by kdegames-meta
[[email protected] ~]$ sudo pacman -R python-pyqt5 kajongg kdegames-meta
checking dependencies...
error: failed to prepare transaction (could not satisfy dependencies)
:: removing kdegames-meta breaks dependency 'kdegames-meta' required by kde-applications-meta
[[email protected] ~]$ sudo pacman -R pyqt5-common
checking dependencies...
error: failed to prepare transaction (could not satisfy dependencies)
:: removing pyqt5-common breaks dependency 'pyqt5-common' required by python-pyqt5
[[email protected] ~]$

Thanks

Re: broken update with pyqt5-common and python-pyqt

Reply #1
Hello,
I also got pyqt5-common error during my update. The problem is that this package was removed.
To solve the update I first removed  "pyqt5-common" from my system with
Code: [Select]
pacman -Rdd pyqt5-common
and than update ran fine.

In face of xorgproto errors check our main site
https://artixlinux.org/news.php#Xorg_cleanup_requires_manual_intervention
Man is as good as his tools.

 

Re: broken update with pyqt5-common and python-pyqt

Reply #2
Hello,
I also got pyqt5-common error during my update. The problem is that this package was removed.
To solve the update I first removed  "pyqt5-common" from my system with
Code: [Select]
pacman -Rdd pyqt5-common
and than update ran fine.

In face of xorgproto errors check our main site
https://artixlinux.org/news.php#Xorg_cleanup_requires_manual_intervention

Thanks, that did it! Is there a mailing list for these sorts of manual interventions for Artix like there is for Arch?

Re: broken update with pyqt5-common and python-pyqt

Reply #3
Thanks, that did it! Is there a mailing list for these sorts of manual interventions for Artix like there is for Arch?
There is not, only website and forum.
In general the manual interventions from Arch are also good for Artix (when not counting systemd problems).
This issue I believe should be also in Arch, I don`t know why they did not make announcement.

I think of making RSS feed for news so it would be easier to follow.
Man is as good as his tools.


Re: broken update with pyqt5-common and python-pyqt

Reply #5
Just tested the feed. You did a fine job there!

Thank you, but it is far from perfect.
There is no image/logo for feed and it is also barely valid.
But works for me, if you feel it needs changes (well it is rss feed not atom feed) feel free to change it.

PS: You miss the latest news in your image.
Man is as good as his tools.