Skip to main content
Topic solved
This topic has been marked as solved and requires no further attention.
Topic: [SOLVED] Unable to mount an F2FS partition (Read 306 times) previous topic - next topic
0 Members and 1 Guest are viewing this topic.

[SOLVED] Unable to mount an F2FS partition

I made myself a brand new shiny F2FS partition, so naturally I have f2fs-tools installed. However I'm unable to mount it:
Code: [Select]
sudo mount /dev/sda4 /mnt/new-partition
mount: /mnt/new-partition: unknown filesystem type 'f2fs'.

lsmod doesn't list any f2fs modules. modprobe f2fs complains that it can't find the module, although I can see a file named f2fs.ko.xz sitting in /lib/modules/5.4.6-artix1-1/kernel/fs/f2fs/ . All the different guides in the internets say that mount should just work and no manual module loading should be necessary. What am I missing?

Re: Unable to mount an F2FS partition

Reply #1
Fixed after a reboot. Apparently in the meantime the kernel got upgraded therefore correct module could not be found.