Skip to main content
Topic: XFCE4 won't start with nomodeset (Read 196 times) previous topic - next topic
0 Members and 1 Guest are viewing this topic.

XFCE4 won't start with nomodeset

I just tried nomodeset and nomodeset nouveau.modeset=0 added to the kernel command line and the desktop wouldn't start. Obviously the solution to this as a problem is don't do that, but I thought it was interesting.  :D

Re: XFCE4 won't start with nomodeset

Reply #1
That's not XFCE's fault, at least Intel GPUs require modesetting to start X.

Re: XFCE4 won't start with nomodeset

Reply #2
I just tried nomodeset on my backup & testing partition with Devuan  Beowulf and a 5.2.0-18.1-liquorix kernel (which could do with updating but I haven't used it recently) and XFCE 4.12 and it booted and the desktop started there. There were a few odd flashes of strange color at start up and shutdown that are not normally there, but otherwise it worked as I expected it should, with no hardware graphics acceleration in the web browser. I think it's another of the XFCE 4.14 odd graphics issues, and it doesn't work at all without hardware graphics, at least here, as this is on the same laptop.
Usually  nomodeset fixes problems like that, not causes them.