Skip to main content
Topic solved
This topic has been marked as solved and requires no further attention.
Topic: display manager for openrc (Read 179 times) previous topic - next topic
0 Members and 1 Guest are viewing this topic.

display manager for openrc

Are there any display managers for openrc?  When I search I can find lightdm, sddm, lxdm, xdm, all available for s6 or runit only. I personally don't use them but I decided to set up a friend who doesn't like typing thinks like startx, reboot, etc!  Thanks.

Re: display manager for openrc

Reply #1
OpenRC is a bit of an exception in this case.
OpenRC has a service called xdm.
Package: world/displaymanager-openrc

You can configure which DM should start at
Code: [Select]
/etc/conf.d/xdm
by editing  DISPLAYMANAGER variable.
Man is as good as his tools.

Re: display manager for openrc

Reply #2
Whoops I should have seen that. I was searching for things that had dm in them.  Will give it a try. Thanks!

Re: display manager for openrc

Reply #3
I installed displaymanager-openrc, enabled it (into default), and checked /etc/conf.d/xdm.

xdm is set as the DISPLAYMANAGER yet xdm is still not starting on boot. Is there another step or two I need to apply?

Re: display manager for openrc

Reply #4
Is xdm starting as a service under openrc?  It should show up under default runlevel:

Code: [Select]
rc-update show

If not, it can be enabled by:

Code: [Select]
rc-update add xdm default

Make sure there is no /etc/.noxdm file.

DISPLAYMANAGER= in /etc/conf.d/xdm tells xdm what display manager to start.  for example, I use sddm.  My /etc/conf.d/xdm contains:

Code: [Select]
DISPLAYMANAGER="sddm"



Re: display manager for openrc

Reply #5
Code: [Select]
# rc-update show | tail
                 swap | boot                                  
               sysctl | boot                                  
                sysfs |                                 sysinit
            syslog-ng |      default                          
         termencoding | boot                                  
                 udev |                                 sysinit
         udev-trigger |                                 sysinit
                  ufw |      default                          
              urandom | boot                                  
                  xdm |      default

Code: [Select]
# ls -lt /etc/.noxdm                                                                                                                                                   :(
ls: cannot access '/etc/.noxdm': No such file or directory

Code: [Select]
# grep DISP /etc/conf.d/xdm
DISPLAYMANAGER="xdm"

I wonder if it related to my hardware?

Code: [Select]
# lspci -knn | grep -iA4 vga
00:02.0 VGA compatible controller [0300]: Intel Corporation UHD Graphics 630 (Desktop 9 Series) [8086:3e98]
DeviceName: Onboard - Video
Subsystem: Micro-Star International Co., Ltd. [MSI] Device [1462:7b17]
Kernel driver in use: i915
Kernel modules: i915

Thanks for your suggestions! It looks like at least the stuff you pointed out is in order.

Re: display manager for openrc

Reply #6
I am not familiar with using xdm as the display manager, maybe there is something else to install.  xdm is used here to start "SOME" display manager, in which I am using sddm.  Maybe try installing sddm or lightdm or whatever and ensure DISPLAYMANAGER= is set to use it.

You can check /var/log/rc.log to see if there are errors reported.  Make sure /etc/rc.conf is set to log:

Code: [Select]
rc_logger="YES"
.
.
.
rc_verbose=YES

 

 

Re: display manager for openrc

Reply #7
I think there is some kind of a permissions problem somewhere. I can now get xdm to start. I have also tried lightdm, sddm, and lxdm.

If I set DISPLAYMANAGER to xdm in /etc/conf.d/xdm, then xdm starts. If I enter the username and the actual password, then xdm just blinks and remains on the screen. If I enter a fake password, it informs me the password is wrong, but no such message is given if I enter the real password. That must mean the actual passwd is recognized.

If I enter root and roots pw, then X actually starts (twm since of course I don't have X set up to run as root). This is what makes me think it might be a permissions problem. This is a new clean install, not a migration.

Further, if I set DISPLAYMANAGER to lightdm, sddm, or lxdm (and they are all installed), I just get xdm anyway along with the above behavior.

To recover I just touch /etc/.noxdm  and reboot. Thx dxrobertson for letting me know about that one.

I hope this is important information and yields some kind of clue!

Code: [Select]
% pacman -Ss xdm | grep installed
world/libxdmcp 1.1.3-2 [installed]
extra/libxdmcp 1.1.3-2 [installed]
extra/xorg-xdm 1.1.12-1 [installed]
community/lxdm 0.5.3-6 (lxde) [installed]

% pacman -Ss sddm | grep installed
world/sddm 0.18.1-1 [installed]
extra/sddm 0.18.1-1 [installed]

% pacman -Ss lightdm | grep installed
extra/lightdm 1:1.30.0-2 [installed]
extra/lightdm-gtk-greeter 1:2.0.7-1 [installed]

Re: display manager for openrc

Reply #8
I dont know, I am running out of suggestions.  With DISPLAYMANAGER="sddm", this is telling xdm to start sddm. 

Is there anything of use in  /var/log/rc.log?  With verbose logging I have this:

Code: [Select]
* Executing: /usr/lib/openrc/sh/openrc-run.sh /usr/lib/openrc/sh/openrc-run.sh /etc/init.d/xdm-setup start
 * Executing: /usr/lib/openrc/sh/openrc-run.sh /usr/lib/openrc/sh/openrc-run.sh /etc/init.d/xdm start
 * Setting up sddm ...
setting java env from profile
 * start-stop-daemon: fopen `/run/sddm.pid': No such file or directory
 * Detaching to start `/usr/bin/sddm' ...


With DISPLAYMANAGER="sddm", whats in  /run/openrc/options/xdm/service?


Please note you do NOT want the file /etc/.noxdm to exist; this tells xdm to NOT start.


Re: display manager for openrc

Reply #9
Yes I understood that about /etc/.noxdm. I was just saying that I created it to get me out of the endless loop of looking at the xdm login box. I could've just disabled xdm for the same effect.

I will check the logs and and  /run/openrc/options/xdm/service tonight.

Re: display manager for openrc

Reply #10
I will mark this as solved, since I reinstalled using the the artix-cinnamon-runit-20200110-x86_64.iso and the default display manager for that installation, lightdm, is working fine. Thank you both for all your patience and help.