Skip to main content
Topic solved
This topic has been marked as solved and requires no further attention.
Topic: [SOLVED] How to disable system beep? (Read 148 times) previous topic - next topic
0 Members and 1 Guest are viewing this topic.

[SOLVED] How to disable system beep?

Hi all,
I searched for this answer (i really did), but without success. I find the system beep on all "errors" annoying. How can i disable this sound please? Thx much!

Re: How to disable system beep?

Reply #1
I don't know if you have pulseaudio and there were any additional steps, but you could try typing "alsamixer" in the terminal. Use the left and right arrows to go to the Beep fader. Either use the up and down arrows to set it to zero and / or press m on the keyboard to toggle the mute button at the bottom, it says MM when muted, OO when not. Pressing F6 switches sound cards as per the on screen instructions, if you had more than one, say it was a desktop with a dedicated plugin sound card plus one built in the mobo, then you would need to adjust the right one. Press escape to exit.


Re: How to disable system beep?

Reply #3
I was able to change the settings using the first method, but they revert to the previous settings on reboot. I do seem to have some PulseAudio going on as well. The second suggestion worked immediately, and also after reboot. Thanks for the help guys! Ah the beepless silence! Artix rocks!

Re: How to disable system beep?

Reply #4
The alsa-utils-openrc (or the equivalent for other inits) needs to be installed and the alsasound service enabled for the state to be saved at shutdown and restored at boot with straight alsa btw, if you had any problems with volume settings not being saved later.