Skip to main content
Topic solved
This topic has been marked as solved and requires no further attention.
Topic: [SOLVED] Problems running certain programs under wine-staging (Read 76 times) previous topic - next topic
0 Members and 1 Guest are viewing this topic.

[SOLVED] Problems running certain programs under wine-staging

Coming from Arch I noticed that some programs weren't working as expected under wine staging in Artix. I also noticed that after changing to the normal wine package these started to work again, but some other stopped working without wine staging.

Initially, I was somewhat confused, and was about to toss it up to just "staging is needed for that one, but it introduces a regression that prevents the others from running" until I noticed that they didn't have the same dependencies. I tried to first install wine, and then install wine-staging while keeping all of the dependencies brought by the original wine and now all programs are working as expected.

This is an issue that is solved for me from the get-go, but I thought I should let you know as some people might not use wine-staging at all as it doesn't work with some programs with it's current dependencies.

For reference the programs that were working with wine but not wine staging were osu! and Demoncrawl, the one that wasn't working under normal wine but was with staging was the twitch desktop app.

Re: [SOLVED] Problems running certain programs under wine-staging

Reply #1
hi, we provide no wine - staging package, that's is still archlinux's package.