Skip to main content
Topic solved
This topic has been marked as solved and requires no further attention.
Topic: [SOLVED] X won't start with proprietary Nvidia driver (Read 416 times) previous topic - next topic
0 Members and 1 Guest are viewing this topic.

[SOLVED] X won't start with proprietary Nvidia driver

Hello,

I have trouble getting the nvidia driver to work after a clean installation
I installed the following ISO
Code: [Select]
artix-lxde-openrc-20200210-x86_64.iso
PC works otherwise, but if I install the nvidia proprietary driver
Code: [Select]
$ sudo pacman -Syu
$ sudo pacman -S nvidia
and reboot the system, all it shows is a black screen with a blinking cursor. The only thing I can do is log in into tty, pacman -R nvidia and reboot, and everything is back to normal.
I don't understand what's the problem, as far as I've read no special configuration is needed, it should work out of the box.

My card:
Code: [Select]
$ lspci | grep -e VGA -e 3D
01:00.0 VGA compatible controller: NVIDIA Corporation GP107 [GeForce GTX 1050] (rev a1)

Re: X won't start with proprietary Nvidia driver

Reply #1
what say "cat /var/log/Xorg.0.log" ?

Re: X won't start with proprietary Nvidia driver

Reply #2
What version is nvidia package at ?
Can you post the output of
Code: [Select]
pacman -Qi nvidia
Man is as good as his tools.

Re: X won't start with proprietary Nvidia driver

Reply #3
Code: [Select]
$ cat /var/log/Xorg.0.log
[    11.445]
X.Org X Server 1.20.7
X Protocol Version 11, Revision 0
[    11.445] Build Operating System: Linux Artix Linux
[    11.445] Current Operating System: Linux Reimu 5.5.3-artix1-1 #1 SMP PREEMPT Wed, 12 Feb 2020 14:04:08 +0000 x86_64
[    11.446] Kernel command line: BOOT_IMAGE=/boot/vmlinuz-linux root=/dev/sda1 rw net.ifnames=0 quiet resume=UUID=0469a1c7-519c-43f3-9dd0-482dd027f6c7
[    11.446] Build Date: 14 January 2020  03:45:16PM
[    11.446] 
[    11.446] Current version of pixman: 0.38.4
[    11.446] Before reporting problems, check http://wiki.x.org
to make sure that you have the latest version.
[    11.446] Markers: (--) probed, (**) from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[    11.446] (==) Log file: "/var/log/Xorg.0.log", Time: Fri Feb 21 12:55:09 2020
[    11.468] (==) Using config directory: "/etc/X11/xorg.conf.d"
[    11.468] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
[    11.488] (==) No Layout section.  Using the first Screen section.
[    11.488] (==) No screen section available. Using defaults.
[    11.488] (**) |-->Screen "Default Screen Section" (0)
[    11.488] (**) |   |-->Monitor "<default monitor>"
[    11.488] (==) No monitor specified for screen "Default Screen Section".
Using a default monitor configuration.
[    11.488] (==) Automatically adding devices
[    11.488] (==) Automatically enabling devices
[    11.488] (==) Automatically adding GPU devices
[    11.488] (==) Automatically binding GPU devices
[    11.488] (==) Max clients allowed: 256, resource mask: 0x1fffff
[    11.513] (WW) The directory "/usr/share/fonts/OTF" does not exist.
[    11.513] Entry deleted from font path.
[    11.513] (WW) The directory "/usr/share/fonts/Type1" does not exist.
[    11.513] Entry deleted from font path.
[    11.513] (WW) The directory "/usr/share/fonts/100dpi" does not exist.
[    11.513] Entry deleted from font path.
[    11.513] (WW) The directory "/usr/share/fonts/75dpi" does not exist.
[    11.513] Entry deleted from font path.
[    11.513] (==) FontPath set to:
/usr/share/fonts/misc,
/usr/share/fonts/TTF
[    11.513] (==) ModulePath set to "/usr/lib/xorg/modules"
[    11.513] (II) The server relies on udev to provide the list of input devices.
If no devices become available, reconfigure udev or disable AutoAddDevices.
[    11.513] (II) Module ABI versions:
[    11.513] X.Org ANSI C Emulation: 0.4
[    11.513] X.Org Video Driver: 24.1
[    11.513] X.Org XInput driver : 24.1
[    11.513] X.Org Server Extension : 10.0
[    11.514] (++) using VT number 7

[    11.514] (II) systemd-logind: logind integration requires -keeptty and -keeptty was not provided, disabling logind integration
[    11.522] (--) PCI:*([email protected]:0:0) 10de:1c81:1458:3765 rev 161, Mem @ 0xfd000000/16777216, 0xc0000000/268435456, 0xd0000000/33554432, I/O @ 0x0000e000/128, BIOS @ 0x????????/131072
[    11.522] (WW) Open ACPI failed (/var/run/acpid.socket) (No such file or directory)
[    11.522] (II) LoadModule: "glx"
[    11.537] (II) Loading /usr/lib/xorg/modules/extensions/libglx.so
[    11.604] (II) Module glx: vendor="X.Org Foundation"
[    11.604] compiled for 1.20.7, module version = 1.0.0
[    11.604] ABI class: X.Org Server Extension, version 10.0
[    11.604] (==) Matched nouveau as autoconfigured driver 0
[    11.604] (==) Matched nv as autoconfigured driver 1
[    11.604] (==) Matched modesetting as autoconfigured driver 2
[    11.604] (==) Matched fbdev as autoconfigured driver 3
[    11.604] (==) Matched vesa as autoconfigured driver 4
[    11.604] (==) Assigned the driver to the xf86ConfigLayout
[    11.604] (II) LoadModule: "nouveau"
[    11.604] (II) Loading /usr/lib/xorg/modules/drivers/nouveau_drv.so
[    11.612] (II) Module nouveau: vendor="X.Org Foundation"
[    11.612] compiled for 1.20.3, module version = 1.0.16
[    11.612] Module class: X.Org Video Driver
[    11.612] ABI class: X.Org Video Driver, version 24.0
[    11.612] (II) LoadModule: "nv"
[    11.613] (WW) Warning, couldn't open module nv
[    11.613] (EE) Failed to load module "nv" (module does not exist, 0)
[    11.613] (II) LoadModule: "modesetting"
[    11.613] (II) Loading /usr/lib/xorg/modules/drivers/modesetting_drv.so
[    11.648] (II) Module modesetting: vendor="X.Org Foundation"
[    11.648] compiled for 1.20.7, module version = 1.20.7
[    11.648] Module class: X.Org Video Driver
[    11.648] ABI class: X.Org Video Driver, version 24.1
[    11.648] (II) LoadModule: "fbdev"
[    11.648] (II) Loading /usr/lib/xorg/modules/drivers/fbdev_drv.so
[    11.659] (II) Module fbdev: vendor="X.Org Foundation"
[    11.659] compiled for 1.20.0, module version = 0.5.0
[    11.659] Module class: X.Org Video Driver
[    11.659] ABI class: X.Org Video Driver, version 24.0
[    11.659] (II) LoadModule: "vesa"
[    11.659] (II) Loading /usr/lib/xorg/modules/drivers/vesa_drv.so
[    11.668] (II) Module vesa: vendor="X.Org Foundation"
[    11.668] compiled for 1.20.0, module version = 2.4.0
[    11.668] Module class: X.Org Video Driver
[    11.668] ABI class: X.Org Video Driver, version 24.0
[    11.668] (II) NOUVEAU driver
[    11.668] (II) NOUVEAU driver for NVIDIA chipset families :
[    11.668] RIVA TNT            (NV04)
[    11.668] RIVA TNT2           (NV05)
[    11.668] GeForce 256         (NV10)
[    11.668] GeForce 2           (NV11, NV15)
[    11.668] GeForce 4MX         (NV17, NV18)
[    11.668] GeForce 3           (NV20)
[    11.668] GeForce 4Ti         (NV25, NV28)
[    11.668] GeForce FX          (NV3x)
[    11.668] GeForce 6           (NV4x)
[    11.668] GeForce 7           (G7x)
[    11.669] GeForce 8           (G8x)
[    11.669] GeForce 9           (G9x)
[    11.669] GeForce GTX 2xx/3xx (GT2xx)
[    11.669] GeForce GTX 4xx/5xx (GFxxx)
[    11.669] GeForce GTX 6xx/7xx (GKxxx)
[    11.669] GeForce GTX 9xx     (GMxxx)
[    11.669] GeForce GTX 10xx    (GPxxx)
[    11.669] (II) modesetting: Driver for Modesetting Kernel Drivers: kms
[    11.669] (II) FBDEV: driver for framebuffer: fbdev
[    11.669] (II) VESA: driver for VESA chipsets: vesa
[    11.930] (EE) [drm] Failed to open DRM device for pci:0000:01:00.0: -19
[    11.930] (EE) open /dev/dri/card0: No such file or directory
[    11.930] (WW) Falling back to old probe method for modesetting
[    11.930] (EE) open /dev/dri/card0: No such file or directory
[    11.930] (II) Loading sub module "fbdevhw"
[    11.930] (II) LoadModule: "fbdevhw"
[    11.931] (II) Loading /usr/lib/xorg/modules/libfbdevhw.so
[    11.964] (II) Module fbdevhw: vendor="X.Org Foundation"
[    11.964] compiled for 1.20.7, module version = 0.0.2
[    11.964] ABI class: X.Org Video Driver, version 24.1
[    11.964] (EE) Unable to find a valid framebuffer device
[    11.964] (WW) Falling back to old probe method for fbdev
[    11.964] (II) Loading sub module "fbdevhw"
[    11.964] (II) LoadModule: "fbdevhw"
[    11.964] (II) Loading /usr/lib/xorg/modules/libfbdevhw.so
[    11.964] (II) Module fbdevhw: vendor="X.Org Foundation"
[    11.964] compiled for 1.20.7, module version = 0.0.2
[    11.964] ABI class: X.Org Video Driver, version 24.1
[    11.964] (II) FBDEV(2): using default device
[    11.964] (EE) Screen 0 deleted because of no matching config section.
[    11.964] (II) UnloadModule: "modesetting"
[    11.965] (EE) Screen 0 deleted because of no matching config section.
[    11.965] (II) UnloadModule: "fbdev"
[    11.965] (II) UnloadSubModule: "fbdevhw"
[    11.965] (EE)
Fatal server error:
[    11.965] (EE) Cannot run in framebuffer mode. Please specify busIDs        for all framebuffer devices
[    11.965] (EE)
[    11.965] (EE)
Please consult the The X.Org Foundation support
at http://wiki.x.org
 for help.
[    11.965] (EE) Please also check the log file at "/var/log/Xorg.0.log" for additional information.
[    11.965] (EE)
[    11.975] (EE) Server terminated with error (1). Closing log file.

Code: [Select]
$ sudo pacman -Qi nvidia
Name            : nvidia
Version         : 440.59-3
Description     : NVIDIA drivers for linux
Architecture    : x86_64
URL             : https://www.nvidia.com/
Licenses        : custom
Groups          : None
Provides        : None
Depends On      : linux  nvidia-utils=440.59  libglvnd
Optional Deps   : None
Required By     : None
Optional For    : None
Conflicts With  : None
Replaces        : None
Installed Size  : 14,07 MiB
Packager        : Artix Build Bot <[email protected]>
Build Date      : mar 4 feb 2020, 23:43:59
Install Date    : ven 21 feb 2020, 12:50:21
Install Reason  : Explicitly installed
Install Script  : No
Validated By    : Signature


Re: X won't start with proprietary Nvidia driver

Reply #4
Probably not it but are you running elogind and does running X as root work?

Re: X won't start with proprietary Nvidia driver

Reply #5
Probably not it but are you running elogind and does running X as root work?
It shows "Starting elogind... [ok]" on boot.
"ps -aux | grep elogind" shows
Code: [Select]
root      1944  0.0  0.0   4172  3228 ?        S    14:11   0:00 elogind-daemon

This is the /var/log/Xorg.0.log if I run startx as root
Code: [Select]
[    99.015] (WW) Failed to open protocol names file lib/xorg/protocol.txt
[    99.017]
X.Org X Server 1.20.7
X Protocol Version 11, Revision 0
[    99.023] Build Operating System: Linux Artix Linux
[    99.026] Current Operating System: Linux Reimu 5.5.3-artix1-1 #1 SMP PREEMPT Wed, 12 Feb 2020 14:04:08 +0000 x86_64
[    99.026] Kernel command line: BOOT_IMAGE=/boot/vmlinuz-linux root=/dev/sda1 rw net.ifnames=0 quiet resume=UUID=0469a1c7-519c-43f3-9dd0-482dd027f6c7
[    99.033] Build Date: 14 January 2020  03:45:16PM
[    99.035] 
[    99.038] Current version of pixman: 0.38.4
[    99.042] Before reporting problems, check http://wiki.x.org
to make sure that you have the latest version.
[    99.042] Markers: (--) probed, (**) from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[    99.053] (==) Log file: "/var/log/Xorg.0.log", Time: Fri Feb 21 14:28:33 2020
[    99.055] (==) Using config directory: "/etc/X11/xorg.conf.d"
[    99.058] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
[    99.058] (==) No Layout section.  Using the first Screen section.
[    99.058] (==) No screen section available. Using defaults.
[    99.058] (**) |-->Screen "Default Screen Section" (0)
[    99.058] (**) |   |-->Monitor "<default monitor>"
[    99.058] (==) No monitor specified for screen "Default Screen Section".
Using a default monitor configuration.
[    99.059] (==) Automatically adding devices
[    99.059] (==) Automatically enabling devices
[    99.059] (==) Automatically adding GPU devices
[    99.059] (==) Automatically binding GPU devices
[    99.059] (==) Max clients allowed: 256, resource mask: 0x1fffff
[    99.059] (WW) The directory "/usr/share/fonts/OTF" does not exist.
[    99.059] Entry deleted from font path.
[    99.059] (WW) The directory "/usr/share/fonts/Type1" does not exist.
[    99.059] Entry deleted from font path.
[    99.059] (WW) The directory "/usr/share/fonts/100dpi" does not exist.
[    99.059] Entry deleted from font path.
[    99.059] (WW) The directory "/usr/share/fonts/75dpi" does not exist.
[    99.059] Entry deleted from font path.
[    99.059] (==) FontPath set to:
/usr/share/fonts/misc,
/usr/share/fonts/TTF
[    99.059] (==) ModulePath set to "/usr/lib/xorg/modules"
[    99.059] (II) The server relies on udev to provide the list of input devices.
If no devices become available, reconfigure udev or disable AutoAddDevices.
[    99.059] (II) Module ABI versions:
[    99.059] X.Org ANSI C Emulation: 0.4
[    99.059] X.Org Video Driver: 24.1
[    99.059] X.Org XInput driver : 24.1
[    99.059] X.Org Server Extension : 10.0
[    99.060] (++) using VT number 1

[    99.061] (II) systemd-logind: took control of session /org/freedesktop/login1/session/_31
[    99.064] (--) PCI:*([email protected]:0:0) 10de:1c81:1458:3765 rev 161, Mem @ 0xfd000000/16777216, 0xc0000000/268435456, 0xd0000000/33554432, I/O @ 0x0000e000/128, BIOS @ 0x????????/131072
[    99.064] (II) Open ACPI successful (/var/run/acpid.socket)
[    99.064] (II) LoadModule: "glx"
[    99.064] (II) Loading /usr/lib/xorg/modules/extensions/libglx.so
[    99.065] (II) Module glx: vendor="X.Org Foundation"
[    99.065] compiled for 1.20.7, module version = 1.0.0
[    99.065] ABI class: X.Org Server Extension, version 10.0
[    99.065] (==) Matched nouveau as autoconfigured driver 0
[    99.065] (==) Matched nv as autoconfigured driver 1
[    99.065] (==) Matched modesetting as autoconfigured driver 2
[    99.065] (==) Matched fbdev as autoconfigured driver 3
[    99.065] (==) Matched vesa as autoconfigured driver 4
[    99.065] (==) Assigned the driver to the xf86ConfigLayout
[    99.065] (II) LoadModule: "nouveau"
[    99.065] (II) Loading /usr/lib/xorg/modules/drivers/nouveau_drv.so
[    99.065] (II) Module nouveau: vendor="X.Org Foundation"
[    99.065] compiled for 1.20.3, module version = 1.0.16
[    99.065] Module class: X.Org Video Driver
[    99.065] ABI class: X.Org Video Driver, version 24.0
[    99.065] (II) LoadModule: "nv"
[    99.066] (WW) Warning, couldn't open module nv
[    99.066] (EE) Failed to load module "nv" (module does not exist, 0)
[    99.066] (II) LoadModule: "modesetting"
[    99.066] (II) Loading /usr/lib/xorg/modules/drivers/modesetting_drv.so
[    99.066] (II) Module modesetting: vendor="X.Org Foundation"
[    99.066] compiled for 1.20.7, module version = 1.20.7
[    99.066] Module class: X.Org Video Driver
[    99.066] ABI class: X.Org Video Driver, version 24.1
[    99.066] (II) LoadModule: "fbdev"
[    99.066] (II) Loading /usr/lib/xorg/modules/drivers/fbdev_drv.so
[    99.066] (II) Module fbdev: vendor="X.Org Foundation"
[    99.066] compiled for 1.20.0, module version = 0.5.0
[    99.066] Module class: X.Org Video Driver
[    99.066] ABI class: X.Org Video Driver, version 24.0
[    99.066] (II) LoadModule: "vesa"
[    99.066] (II) Loading /usr/lib/xorg/modules/drivers/vesa_drv.so
[    99.066] (II) Module vesa: vendor="X.Org Foundation"
[    99.066] compiled for 1.20.0, module version = 2.4.0
[    99.066] Module class: X.Org Video Driver
[    99.066] ABI class: X.Org Video Driver, version 24.0
[    99.066] (II) NOUVEAU driver
[    99.066] (II) NOUVEAU driver for NVIDIA chipset families :
[    99.066] RIVA TNT            (NV04)
[    99.066] RIVA TNT2           (NV05)
[    99.066] GeForce 256         (NV10)
[    99.066] GeForce 2           (NV11, NV15)
[    99.066] GeForce 4MX         (NV17, NV18)
[    99.066] GeForce 3           (NV20)
[    99.066] GeForce 4Ti         (NV25, NV28)
[    99.066] GeForce FX          (NV3x)
[    99.066] GeForce 6           (NV4x)
[    99.066] GeForce 7           (G7x)
[    99.066] GeForce 8           (G8x)
[    99.066] GeForce 9           (G9x)
[    99.067] GeForce GTX 2xx/3xx (GT2xx)
[    99.067] GeForce GTX 4xx/5xx (GFxxx)
[    99.067] GeForce GTX 6xx/7xx (GKxxx)
[    99.067] GeForce GTX 9xx     (GMxxx)
[    99.067] GeForce GTX 10xx    (GPxxx)
[    99.067] (II) modesetting: Driver for Modesetting Kernel Drivers: kms
[    99.067] (II) FBDEV: driver for framebuffer: fbdev
[    99.067] (II) VESA: driver for VESA chipsets: vesa
[    99.345] (EE) [drm] Failed to open DRM device for pci:0000:01:00.0: -19
[    99.345] (EE) open /dev/dri/card0: No such file or directory
[    99.345] (WW) Falling back to old probe method for modesetting
[    99.345] (EE) open /dev/dri/card0: No such file or directory
[    99.345] (II) Loading sub module "fbdevhw"
[    99.345] (II) LoadModule: "fbdevhw"
[    99.345] (II) Loading /usr/lib/xorg/modules/libfbdevhw.so
[    99.346] (II) Module fbdevhw: vendor="X.Org Foundation"
[    99.346] compiled for 1.20.7, module version = 0.0.2
[    99.346] ABI class: X.Org Video Driver, version 24.1
[    99.346] (EE) Unable to find a valid framebuffer device
[    99.346] (WW) Falling back to old probe method for fbdev
[    99.346] (II) Loading sub module "fbdevhw"
[    99.346] (II) LoadModule: "fbdevhw"
[    99.346] (II) Loading /usr/lib/xorg/modules/libfbdevhw.so
[    99.346] (II) Module fbdevhw: vendor="X.Org Foundation"
[    99.346] compiled for 1.20.7, module version = 0.0.2
[    99.346] ABI class: X.Org Video Driver, version 24.1
[    99.346] (II) FBDEV(2): using default device
[    99.346] (EE) Screen 0 deleted because of no matching config section.
[    99.346] (II) UnloadModule: "modesetting"
[    99.346] (EE) Screen 0 deleted because of no matching config section.
[    99.346] (II) UnloadModule: "fbdev"
[    99.346] (II) UnloadSubModule: "fbdevhw"
[    99.346] (EE)
Fatal server error:
[    99.346] (EE) Cannot run in framebuffer mode. Please specify busIDs        for all framebuffer devices
[    99.346] (EE)
[    99.347] (EE)
Please consult the The X.Org Foundation support
at http://wiki.x.org
 for help.
[    99.347] (EE) Please also check the log file at "/var/log/Xorg.0.log" for additional information.
[    99.347] (EE)
[    99.358] (EE) Server terminated with error (1). Closing log file.

Re: X won't start with proprietary Nvidia driver

Reply #6
Iirc from the time I still had nvidia, if you have nouveau installed, you need to blacklist the nouveau module.

Re: X won't start with proprietary Nvidia driver

Reply #7
Iirc from the time I still had nvidia, if you have nouveau installed, you need to blacklist the nouveau module.
According to the Arch wiki "The nvidia package contains a file which blacklists the nouveau module", but I tried anyway, no luck.
Code: [Select]
$ cat /etc/modprobe.d/blacklist.conf
blacklist nouveau

Re: X won't start with proprietary Nvidia driver

Reply #8
all it shows is a black screen with a blinking cursor.

Oh I know what this one is. You need to disable modesetting. The reason is basically because Nvidia sucks and still doesn't reliably support KMS on all cards. Put "nomodeset" as a kernel parameter.

Re: X won't start with proprietary Nvidia driver

Reply #9
Oh I know what this one is. You need to disable modesetting. The reason is basically because Nvidia sucks and still doesn't reliably support KMS on all cards. Put "nomodeset" as a kernel parameter.
I tried with both "nomodeset" and "nomodeset nouveau.modeset=0", nothing. The /var/log/Xorg.0.log file shows the same errors as the one I posted above.

Re: X won't start with proprietary Nvidia driver

Reply #10
Bummer, I've had the blinking cursor + black screen thing on nvidia machines before and it was because modesetting needed to be disabled. Looking at the xorg log again, I'm not sure if it even attempted to load the nvidia module. I'm out of ideas.

Re: X won't start with proprietary Nvidia driver

Reply #11
Code: [Select]
$ cat /var/log/Xorg.0.log
(II) LoadModule: "nouveau"
[    11.604] (II) Loading /usr/lib/xorg/modules/drivers/nouveau_drv.so
[    11.612] (II) Module nouveau: vendor="X.Org Foundation"
[    11.612] compiled for 1.20.3, module version = 1.0.16
[    11.612] Module class: X.Org Video Driver
[    11.612] ABI class: X.Org Video Driver, version 24.0
[    11.612] (II) LoadModule: "nv"
[    11.613] (WW) Warning, couldn't open module nv
[    11.613] (EE) Failed to load module "nv" (module does not exist, 0)
[    11.613] (II) LoadModule: "modesetting"
[    11.613] (II) Loading /usr/lib/xorg/modules/drivers/modesetting_drv.so
[    11.648] (II) Module modesetting: vendor="X.Org Foundation"


a small chaos in your system :-) your system loaded nouveau driver and after try load nv driver. Nouveau requires kernel mode-setting, nvidia requires NO kernel mode-setting.

Try:
Code: [Select]
pacman -R xf86-video-nouveau
(for now), disable kernel mode-setting in kernel parameters,  install  the right nvida driver  -> so use
Code: [Select]
pacman -S world/nvidia
  - right version is 440.59-7 (I assume you have an up-to-date system) and reboot. what say xorg.log now?

Re: X won't start with proprietary Nvidia driver

Reply #12
check: /etc/X11/xorg.conf.d/20-nvidia.conf. should be:
Code: [Select]
Section "Device"
        Identifier "Nvidia Card"
        Driver "nvidia"
        VendorName "NVIDIA Corporation"
        BoardName "GeForce GTX 1050 Ti"
EndSection

Re: X won't start with proprietary Nvidia driver

Reply #13
i read now, nvidia still support modesetting now
Code: [Select]
 nvidia-drm.modeset=1

please try this .
and instead  nvidia you can use and install
Code: [Select]
pacman -S world/nvidia-dkms 
.i prefer dkms version of drivers, which with new kernel rebuild your drivers.