Skip to main content
Topic solved
This topic has been marked as solved and requires no further attention.
Topic: [SOLVED] brcmfmac: cannot use 2.4GHz band (Read 145 times) previous topic - next topic
0 Members and 1 Guest are viewing this topic.

[SOLVED] brcmfmac: cannot use 2.4GHz band

Hi all!
Yesterday i encountered problems with BCM4356 wireless chip (it is built-in on Firefly RK3399, so SDIO bus is used to access it): i cannot connect to my wireless AP in 2.4GHz band. At the same time all is OK if i am connecting to 5GHz AP. When connecting manually i get following output from wpa_supplicant:
Code: [Select]
wlan0: Trying to associate with SSID '1473'
wlan0: CTRL-EVENT-ASSOC-REJECT bssid=00:00:00:00:00:00 status_code=16
So, AP is detected but it can't connect to it. iw list shows 2.4GHz channels from 1 to 13 working (AP works on 3). Also i have following lines in dmesg:
Code: [Select]
[   16.315372] brcmfmac: brcmf_fw_alloc_request: using brcm/brcmfmac4356-sdio for chip BCM4356/2
[   16.315715] usbcore: registered new interface driver brcmfmac
[   16.456234] brcmfmac: brcmf_fw_alloc_request: using brcm/brcmfmac4356-sdio for chip BCM4356/2
[   16.456321] brcmfmac: brcmf_c_process_clm_blob: no clm_blob available (err=-2), device may have limited channels available
[   16.456707] brcmfmac: brcmf_c_preinit_dcmds: Firmware: BCM4356/2 wl0: May 14 2014 19:51:52 version 7.35.17 (r477908) FWID 01-2ed3ee81
If i try to create an AP from it, i get messages like
Code: [Select]
failed to set tx queue parameters
and other devices don't see this AP
So, what could be the problem and how could it be solved?

Re: brcmfmac: cannot use 2.4GHz band

Reply #1
The issue was resolved after reinstalling bootloader. I don't know how