Skip to main content
Topic solved
This topic has been marked as solved and requires no further attention.
Topic: [SOLVED] multilib/lib32-alsa-plugins 1.2.2-1 error: failed to commit transaction (Read 133 times) previous topic - next topic
0 Members and 1 Guest are viewing this topic.

[SOLVED] multilib/lib32-alsa-plugins 1.2.2-1 error: failed to commit transaction

Hello,

something is wrong with the multilib/lib32-alsa-plugins 1.2.2-1 package.

Any recommendation how to deal with it ?

Code: [Select]
:: Starting full system upgrade...
warning: opensysusers: local (0.6-1) is newer than system (0.5.1-3)
warning: xorgproto: ignoring package upgrade (2019.2-1 => 2019.2-2)
resolving dependencies...
looking for conflicting packages...

Package (6)                  Old Version  New Version  Net Change  Download Size

world/alsa-ucm-conf          1.2.1.2-1    1.2.2-1        0.00 MiB       0.03 MiB
world/alsa-utils             1.2.1-2      1.2.2-1        0.01 MiB       0.97 MiB
multilib/lib32-alsa-lib      1.2.1.2-2    1.2.2-1        0.05 MiB              
multilib/lib32-alsa-plugins  1.2.1-2      1.2.2-1        0.29 MiB              
multilib/lib32-glib2         2.62.4-2     2.62.5-1       0.00 MiB              
world/openexr                2.4.0-7      2.4.1-1       -0.01 MiB       6.39 MiB

Total Download Size:    7.39 MiB
Total Installed Size:  43.31 MiB
Net Upgrade Size:       0.35 MiB
                                                                                                                                   
:: Proceed with installation? [Y/n]                                                                                                
:: Retrieving packages...                                                                                                          
 alsa-ucm-conf-1.2.2-1-any                           28.1 KiB   780 KiB/s 00:00 [#############################################] 100%
 alsa-utils-1.2.2-1-x86_64                          997.3 KiB  7.32 MiB/s 00:00 [#############################################] 100%
 openexr-2.4.1-1-x86_64                               6.4 MiB  8.96 MiB/s 00:01 [#############################################] 100%
(6/6) checking keys in keyring                                                  [#############################################] 100%
(6/6) checking package integrity                                                [#############################################] 100%
(6/6) loading package files                                                     [#############################################] 100%
(6/6) checking for file conflicts                                               [#############################################] 100%
error: failed to commit transaction (conflicting files)
lib32-alsa-plugins: /usr/lib32/alsa-lib/libasound_module_conf_pulse.so exists in filesystem
lib32-alsa-plugins: /usr/lib32/alsa-lib/libasound_module_ctl_arcam_av.so exists in filesystem
lib32-alsa-plugins: /usr/lib32/alsa-lib/libasound_module_ctl_dsp_ctl.so exists in filesystem
lib32-alsa-plugins: /usr/lib32/alsa-lib/libasound_module_ctl_oss.so exists in filesystem
lib32-alsa-plugins: /usr/lib32/alsa-lib/libasound_module_ctl_pulse.so exists in filesystem
lib32-alsa-plugins: /usr/lib32/alsa-lib/libasound_module_pcm_alsa_dsp.so exists in filesystem
lib32-alsa-plugins: /usr/lib32/alsa-lib/libasound_module_pcm_jack.so exists in filesystem
lib32-alsa-plugins: /usr/lib32/alsa-lib/libasound_module_pcm_oss.so exists in filesystem
lib32-alsa-plugins: /usr/lib32/alsa-lib/libasound_module_pcm_pulse.so exists in filesystem
lib32-alsa-plugins: /usr/lib32/alsa-lib/libasound_module_pcm_speex.so exists in filesystem
lib32-alsa-plugins: /usr/lib32/alsa-lib/libasound_module_pcm_upmix.so exists in filesystem
lib32-alsa-plugins: /usr/lib32/alsa-lib/libasound_module_pcm_usb_stream.so exists in filesystem
lib32-alsa-plugins: /usr/lib32/alsa-lib/libasound_module_pcm_vdownmix.so exists in filesystem
lib32-alsa-plugins: /usr/lib32/alsa-lib/libasound_module_rate_samplerate.so exists in filesystem
lib32-alsa-plugins: /usr/lib32/alsa-lib/libasound_module_rate_samplerate_best.so exists in filesystem
lib32-alsa-plugins: /usr/lib32/alsa-lib/libasound_module_rate_samplerate_linear.so exists in filesystem
lib32-alsa-plugins: /usr/lib32/alsa-lib/libasound_module_rate_samplerate_medium.so exists in filesystem
lib32-alsa-plugins: /usr/lib32/alsa-lib/libasound_module_rate_samplerate_order.so exists in filesystem
lib32-alsa-plugins: /usr/lib32/alsa-lib/libasound_module_rate_speexrate.so exists in filesystem
lib32-alsa-plugins: /usr/lib32/alsa-lib/libasound_module_rate_speexrate_best.so exists in filesystem
lib32-alsa-plugins: /usr/lib32/alsa-lib/libasound_module_rate_speexrate_medium.so exists in filesystem
Errors occurred, no packages were upgraded.

Re: multilib/lib32-alsa-lib 1.2.2-1 error: failed to commit transaction (conflicting

Reply #1
It looks like some error during installation/ISO creation.

Be it my machine I would force my way.
Code: [Select]
pacman -Syu --overwrite=/usr/lib32/alsa-lib/
I believe this should do the job.
Man is as good as his tools.

Re: multilib/lib32-alsa-plugins 1.2.2-1 error: failed to commit transaction

Reply #2
Hi,

I tried "pacman -Syu --overwrite=/usr/lib32/alsa-lib/"
Code: [Select]
error: failed to commit transaction (conflicting files)

Same error :(

Re: multilib/lib32-alsa-plugins 1.2.2-1 error: failed to commit transaction

Reply #3
try to add wildcard * at the end
or list all the files, or delete them before update, or try if --force still works
Man is as good as his tools.

Re: multilib/lib32-alsa-plugins 1.2.2-1 error: failed to commit transaction

Reply #4
we updates some alsa packages before 20 minutes. with next sync (up to 1 hour) you can try update your alsa packages again. maybe that will fix your problem..