Skip to main content
Topic solved
This topic has been marked as solved and requires no further attention.
Topic: Possible wifi problem (Read 351 times) previous topic - next topic
0 Members and 1 Guest are viewing this topic.

Possible wifi problem

My 2.4GHz N connection was running slower than usual the past few days, and was only working at normal speeds when moving closer to the router.
           Device-2: Intel Ultimate N WiFi Link 5300 driver: iwlwifi v: kernel port: df00 bus ID: 0c:00.0
           chip ID: 8086:4235
Downgrading seems to have resolved it, Ookla suggests:
$ sudo pacman -U linux-5.5.2.artix1-1-x86_64.pkg.tar.xz linux-headers-5.5.2.artix1-1-x86_64.pkg.tar.xz linux-firmware-20200122.1eb2408-1-any.pkg.tar.xz
More testing here would be helpful, but something could be amiss it seems, as a preliminary suspicion.

Re: Possible wifi problem

Reply #1
Hi,
I changed to 5 GHz -> a lot faster and more robust.
And from  NetworkManager to connman -> better management less Red Hat / Lennart Poettering bullshit.
(You need to occasionally restart (sudo /etc/init.d/connmand restart) connmand after wake-up from suspend)
Recommended /etc/connman/main.conf
Code: [Select]
[General]
AllowHostnameUpdates=false
AllowDomainnameUpdates=false
PreferredTechnologies=ethernet,wifi,cellular
EnableOnlineCheck=false
FallbackTimeservers=pool.ntp.org
UseGatewaysAsTimeservers=false
FallbackNameservers=2606:4700:4700::1111,1.1.1.1
https://wiki.debian.org/iwlwifi recommends:
"If your WiFi is slow when using Bluetooth, try adding the following to /etc/modprobe.d/iwlwifi.conf and reboot:
options iwlwifi bt_coex_active=0 swcrypto=1 11n_disable=8
"
I would play a little with the bt_coex_active option and the other ones.

Re: Possible wifi problem

Reply #2
After upgrading the firmware then the 2 kernel versions to get back to where I started, everything is still working normally, but for several days before there were problems. So it was either a coincidence and an external line issue or perhaps something got misdetected by mkinitcpio, the firmware got bitflipped by a cosmic ray, I don't know.
I wasn't using bluetooth or a networking app. I used to use ifupdown in Debian but then moved to simply issuing commands to wpa_supplicant and dhcpcd and more recently dhclient in scripts which is more transparent, but sometimes I install a gui for testing or if I might need to connect to someone else's network to save time.
5GHz doesn't work for me, 1/10th of the speed and it keeps disconnecting. Apparently it's faster only if you are close to the wireless AP. I hadn't read that until recently, and thought it was slow in general. Also my wifi card predates dual band wireless so a newer adapter might work better on 5GHz. It's a built in wifi card, already updated from the original  and I'm not sure I can do better in this hardware, unless I got an external one. But the current connection was just testing on Ookla at 10MB download speed and usually updates arrive about 0.5 to 1.5MB here (and thats amazing compared to the 100 - 300Kb it was for many years before) so there may be little to gain when things are working properly. While I was having problems recently it was 50 - 200Kb and often dropping to nothing, connection was being lost for a few minutes at a time, it was noticeable on web pages too. Moving closer to the router improved it. There are power settings in wifi cards, if the firmware is not working right it can stay stuck in low power mode so won't work at distance.

Bluetooth used to require pulseaudio, but now according to the Gentoo bluetooth wiki it can work with just alsa using this package available in the AUR:
aur/bluez-alsa-git 2.0.0.r42.gb7eda3a-1 [15 / 0.291324]
    Bluetooth Audio ALSA Backend
Have you ever tried that?

Re: Possible wifi problem

Reply #3
OK, still often getting poor performance from the built in Intel 5300 card. So I tried a (fairly old) PCMCIA wireless N adapter. I started an update, then disconnected the Intel and fired up the Belkin Ralink, and the downloads proceeded at double the previous speed. So there is something suboptimal with the Intel link somewhere I think.

Code: [Select]
04:00.0 Network controller: Ralink corp. RT2760 Wireless 802.11n 1T/2R
Subsystem: Belkin Device 811c
Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV+ VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=slow >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
Latency: 64 (500ns min, 1000ns max), Cache Line Size: 64 bytes
Interrupt: pin A routed to IRQ 19
Region 0: Memory at f0c00000 (32-bit, non-prefetchable) [size=64K]
Capabilities: [40] Power Management version 3
Flags: PMEClk- DSI- D1- D2- AuxCurrent=0mA PME(D0-,D1-,D2-,D3hot-,D3cold-)
Status: D0 NoSoftRst- PME-Enable- DSel=0 DScale=0 PME-
Kernel driver in use: rt2800pci
Kernel modules: rt2800pci

0c:00.0 Network controller: Intel Corporation Ultimate N WiFi Link 5300
Subsystem: Intel Corporation Device 1121
Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR+ FastB2B- DisINTx+
Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
Latency: 0, Cache Line Size: 64 bytes
Interrupt: pin A routed to IRQ 32
Region 0: Memory at f1ffe000 (64-bit, non-prefetchable) [size=8K]
Capabilities: [c8] Power Management version 3
Flags: PMEClk- DSI+ D1- D2- AuxCurrent=0mA PME(D0+,D1-,D2-,D3hot+,D3cold+)
Status: D0 NoSoftRst- PME-Enable- DSel=0 DScale=0 PME-
Capabilities: [d0] MSI: Enable+ Count=1/1 Maskable- 64bit+
Address: 00000000fee01004  Data: 4029
Capabilities: [e0] Express (v1) Endpoint, MSI 00
DevCap: MaxPayload 128 bytes, PhantFunc 0, Latency L0s <512ns, L1 unlimited
ExtTag- AttnBtn- AttnInd- PwrInd- RBE+ FLReset+ SlotPowerLimit 0.000W
DevCtl: CorrErr- NonFatalErr- FatalErr- UnsupReq-
RlxdOrd+ ExtTag- PhantFunc- AuxPwr- NoSnoop+ FLReset-
MaxPayload 128 bytes, MaxReadReq 128 bytes
DevSta: CorrErr+ NonFatalErr- FatalErr- UnsupReq+ AuxPwr+ TransPend-
LnkCap: Port #0, Speed 2.5GT/s, Width x1, ASPM L0s L1, Exit Latency L0s <128ns, L1 <32us
ClockPM+ Surprise- LLActRep- BwNot- ASPMOptComp-
LnkCtl: ASPM L0s L1 Enabled; RCB 64 bytes Disabled- CommClk+
ExtSynch- ClockPM+ AutWidDis- BWInt- AutBWInt-
LnkSta: Speed 2.5GT/s (ok), Width x1 (ok)
TrErr- Train- SlotClk+ DLActive- BWMgmt- ABWMgmt-
Capabilities: [100 v1] Advanced Error Reporting
UESta: DLP- SDES- TLP- FCP- CmpltTO- CmpltAbrt- UnxCmplt- RxOF- MalfTLP- ECRC- UnsupReq- ACSViol-
UEMsk: DLP- SDES- TLP- FCP- CmpltTO- CmpltAbrt- UnxCmplt- RxOF- MalfTLP- ECRC- UnsupReq- ACSViol-
UESvrt: DLP+ SDES- TLP- FCP+ CmpltTO- CmpltAbrt- UnxCmplt- RxOF+ MalfTLP+ ECRC- UnsupReq- ACSViol-
CESta: RxErr- BadTLP- BadDLLP- Rollover- Timeout- AdvNonFatalErr-
CEMsk: RxErr- BadTLP- BadDLLP- Rollover- Timeout- AdvNonFatalErr+
AERCap: First Error Pointer: 00, ECRCGenCap- ECRCGenEn- ECRCChkCap- ECRCChkEn-
MultHdrRecCap- MultHdrRecEn- TLPPfxPres- HdrLogCap-
HeaderLog: 00000000 00000000 00000000 00000000
Capabilities: [140 v1] Device Serial Number 00-16-ea-ff-ff-5f-52-a0
Kernel driver in use: iwlwifi
Kernel modules: iwlwifi
There are some current issues with the iwlwifi driver:
https://bbs.archlinux.org/viewtopic.php?id=252603

Re: Possible wifi problem

Reply #4
No, sorry, this is just my hardware problem, a failing wifi card I guess. Trying the previous Artix Mate live iso on a USB, which offers a complete old set of software:
artix:[artix]:/opt/pale_moon/palemoon% uname -r
5.1.4-artix1-1-ARTIX
Intel : Download Mbps 0.78
Ralink : Download Mbps 11.37
Before I could ip link set thing up on that iso I had to rfkill unblock them, as the cards were blocked, rfkill list showed the numbers to use.

Re: Possible wifi problem

Reply #5
In the recent-ish kernels (5.0+), I noticed my wifi card would randomly get softblocked so I had to use rfkill. I don't know why this happens now. A little annoying honestly but oh well.