Skip to main content
Topic: GDM wont start when service is enabled (runit) (Read 137 times) previous topic - next topic
0 Members and 1 Guest are viewing this topic.

GDM wont start when service is enabled (runit)

Hi, I was trying to move from void linux to artix and when setting up GNOME + GDM I faced this issue where GDM would refuse to run when the service is enabled, leaving me at the shell, no black screen or anything.

The log folder in
Code: [Select]
/var/logs/gdm
is empty each time I run it.

The steps I did are as such:
Code: [Select]
pacman -S gnome gdm gdm-runit
ln -s /etc/runit/sv/gdm /var/run/runit/service/
uncomment WaylandEnable=false in /etc/gdm/custom.conf

How could I fix this issue? Thanks in advance!

Re: GDM wont start when service is enabled (runit)

Reply #1
Ouch, I can reproduce this (s6 not runit, but it shouldn't matter). To make matters worse, simply running "gdm" in a virtual console appears to do nothing.

It may be related to this issue. I can see if some of the workarounds listed in there work later.