Skip to main content
Topic solved
This topic has been marked as solved and requires no further attention.
Topic: KDE Kate and missing libgit2.so.28 (Read 188 times) previous topic - next topic
0 Members and 2 Guests are viewing this topic.

KDE Kate and missing libgit2.so.28

Hello !

After installing artix-plasma-openrc-20200210-x86_64.iso Kate works. After updating the installation using
Code: [Select]
sudo pacman -Syu
Kate did not work anymore. If I try to launch using the terminal I get the error.

Code: [Select]
kate: error while loading shared libraries: libgit2.so.28: cannot open shared object file: No such file or directory

How can I fix that ?

Thanks for help.

Re: KDE Kate and missing libgit2.so.28

Reply #1
libgit2 and ktexteditor was updated, check your mirrors (arch+artix) and make upgrade your system. i has same problem before 2-3 days ago, all updated and works again.

Re: KDE Kate and missing libgit2.so.28

Reply #2
Had no luck at the moment.

How I know which mirrors are up to date ?

Re: KDE Kate and missing libgit2.so.28

Reply #3
libgit2 is provided by artix linux,
ktexteditor is provided by archlinux. Both package i installed 4.3.2020, said pacman.

# Artix mirrors
Server = https://mirrors.dotsrc.org/artix-linux/repos/$repo/os/$arch

#Archlinux
https://arch.jensgutermuth.de/$repo/os/$arch

this mirrors used by me, both are up-to-date

Quote
How I know which mirrors are up to date ?
just try with 'pacman -Syyu' (-Syu not enough ) and if you become new update, your old mirror is out-of-date.

one of newest packages for update: p11-kit-0.23.20-3 libelf-0.178-2 modemmanager-1.12.8-1 libwpe-1.6.0-1 ghostscript-9.51-1
(for example)

Re: KDE Kate and missing libgit2.so.28

Reply #4
Thanks for your fast answer.
That worked. My first Artix mirror in the list is the same as yours. The problem was, the Arch mirror. The first 2 uncommented are the one in the section world. Using the one you mention and update again, solved the problem.