Skip to main content
Topic solved
This topic has been marked as solved and requires no further attention.
Topic: [SOLVED] Ç on terminal (Read 369 times) previous topic - next topic
0 Members and 1 Guest are viewing this topic.

[SOLVED] Ç on terminal

Hello guys,

I've just installed Artix with s6-rc, but something is bugging me. I have a br-abnt2 laptop. On my application the accented letter works just fine. But in my terminal just shows a question mark. Anyone knows how to fix that?




 

Re: Ç on terminal

Reply #1
Possibly your terminal doesn't support it either. Could try a terminal that supports UTF-8 and see if that helps. One that I know of that supports UTF-8 out of the box is "st".

Re: Ç on terminal

Reply #2
I gonna try nerd fonts, I already use ST.

Re: Ç on terminal

Reply #3
I gonna try nerd fonts, I already use ST.

I've tried several different terminals that support UTF-8, but still the same problem. The thing is bugging it's only on terminal.


Re: Ç on terminal

Reply #4
maybe you are missing some font or something on that line...
if it is st I would suggest checking if the support for utf8 is included
Man is as good as his tools.

Re: Ç on terminal

Reply #5
maybe you are missing some font or something on that line...
if it is st I would suggest checking if the support for utf8 is included
AFAIK utf-8 is native to st, as I use it as my terminal as well.

Re: Ç on terminal

Reply #6
I'd 1) verify the locale is an utf-8 one by running 'locale', and b) check the font fallback list for the terminal font in use, 'fc-match -s <name>', or 'fc-list -s <name>' I think.

Re: Ç on terminal

Reply #7
Someone marked this solved.
Can I ask how was this solved for future generations?
Man is as good as his tools.

Re: Ç on terminal

Reply #8
I had set my LC_ALL  manually, that was (unset). I don't know if I screwd something during the setup of my system.