Skip to main content
Topic solved
This topic has been marked as solved and requires no further attention.
Topic: [SOLVED] video distortions with mesa-20.0.2-1 (Read 506 times) previous topic - next topic
0 Members and 2 Guests are viewing this topic.

Re: [SOLVED] video distortions with mesa-20.0.2-1

Reply #15
I am having this problem as well.  Seeing it in various KDE applications and its very noticeable when using mc in a terminal.

I tried exporting the variable, it made no difference:
Code: [Select]
export MESA_LOADER_DRIVER_OVERRIDE=i965
I set it in /etc/profile, tried it in /etc/local.d/mesa.start, and set it directly in a terminal before start mc (in that terminal); nothing worked.

I also tried the file settings in /usr/share/X11/xorg.conf.d/20-intel.conf, as suggested in the bug report at
https://gitlab.freedesktop.org/mesa/mesa/-/issues/2721
This made no difference.

Next is to downgrade back to mesa 19.



 

Re: [SOLVED] video distortions with mesa-20.0.2-1

Reply #16
What window manager are you using? Are you using a compositor?

Re: [SOLVED] video distortions with mesa-20.0.2-1

Reply #17
Using SDDM with Plasma.

Plasma compositor is disabled in monitor config.

I even tried setting the env variable from a console, then manually starting SDDM (to ensure the env variable is set), and still made no difference.

Re: [SOLVED] video distortions with mesa-20.0.2-1

Reply #18
Any particular reason to not use the compositor? If you enable it, it should fix it.

Re: [SOLVED] video distortions with mesa-20.0.2-1

Reply #19
I have always disabled the compositor, I dont use any effects and have no need for it.  I guess now I have a need for it!  I enabled it and you are correct- it fixed the tearing problem.  Thanks!