Skip to main content
Topic solved
This topic has been marked as solved and requires no further attention.
Topic: [SOLVED] Enabling runit -> No such file or directory (Read 318 times) previous topic - next topic
0 Members and 1 Guest are viewing this topic.

[SOLVED] Enabling runit -> No such file or directory

I am trying to install Artix (with runit) for the first time.

I could follow the installation instructions in the Artix Wiki up to the point of the Network configuration (before the first reboot). I am just past the grub installation and bootloader config, in chroot /mnt mode. I have installed connman (with cmst for later LXQt):
Code: [Select]
pacman -S connman-runit cmst

and then I tried to enable runit by
Code: [Select]
ln -s /etc/runit/sv/connmand /run/runit/service

However, this fails. The response is:
Code: [Select]
In: failed to create symbolic link '/run/runit/service': No such file or directory

my /run directory has only blkid as subdirectory. There is no /run/runit . (I can see that /etc/runit/sv/connmand exits)

How should I proceed from here?

Re: Enabling runit -> No such file or directory

Reply #1
Link service to /etc/runit/runsvdir/default/

Re: Enabling runit -> No such file or directory

Reply #2
Thanks, that executed without error.


Re: [SOLVED] Enabling runit -> No such file or directory

Reply #4
I think the wiki should clarify it a bit. I had no /run/runit/service during the installation procedure, but once I booted the installed system, I see that /run/runit/service indeed exists. So maybe creating links in /run/runit/service is the way to enable services, but only after the system can boot on its own.

Re: [SOLVED] Enabling runit -> No such file or directory

Reply #5
Yeah the /run directory is only going to exist at runtime (hence the name). When you're in chroot and installing stuff, that directory won't exist. Normally, /run/runit/service is the symlink you're going to want to make.

Re: [SOLVED] Enabling runit -> No such file or directory

Reply #6
I had the same problem and i did not know this thing about "/etc/runit/runsvdir/default/" which should obviously be explained in the wiki since this is literally the only information that is lacking for a proper Artix install as long as you don't go for an encrypted install.

Still succeeded to "bypass" the issue by enabling it but post-install.

Re: [SOLVED] Enabling runit -> No such file or directory

Reply #7
Linking it to that directory does work, but I'm unsure if it's exactly the same as linking it to the /run/runit/service directory. I'm a bit hesitant to recommend that. It might be better for the wiki to suggest to users to enable their services after an install and boot into the machine.