Skip to main content
Topic: Laptop doesn't suspend when lid is closed (Read 202 times) previous topic - next topic
0 Members and 1 Guest are viewing this topic.

Laptop doesn't suspend when lid is closed

Hello everyone, I have been using artix for a few days now and I love it, except that I can't get my laptop to suspend when I close the lid. I have an 8gb swap, I am using runit, and the issue exists on xfce and on cinnamon. I can get it to suspend if I click suspend in the shutdown dialog, but I can't get it to do it manually. Is there a runit service I need to enable?

Re: Laptop doesn't suspend when lid is closed

Reply #1
hi,  you can set it in xfce-power-manager. have you set it?  or you can edit use /etc/elogind/logind.conf , here are some stuff about LID like this:
Quote
#HandleLidSwitch=suspend
#HandleLidSwitchExternalPower=suspend
#HandleLidSwitchDocked=ignore
#PowerKeyIgnoreInhibited=no
#SuspendKeyIgnoreInhibited=no
#HibernateKeyIgnoreInhibited=no
#LidSwitchIgnoreInhibited=yes

some relevant stuff you can finde here: https://wiki.archlinux.org/index.php/Xfce (here is some info about Laptop lid settings ignored)


Re: Laptop doesn't suspend when lid is closed

Reply #2
Hi I had *edited: a similar* problem for a few days, I solved it following these steps (I'm using OpenRC so hope it works for you):

  • Install zen-kernel
  • Edit /etc/UPower/UPower.conf, change IgnoreLid to true (I'm a bit puzzled between this conf file and the other provided by elogind, as seems like the functionality is overlapping)

I did a lot of trial and error to find those two steps, after that suspension works properly, but there are no buttons to configurate the lid suspension in XFCE. I'm also having a small issue with the keyboard after leaving my laptop alone for a while, it becomes unresponsive for a few seconds... still looking for that one.