Skip to main content
Topic solved
This topic has been marked as solved and requires no further attention.
Topic: [SOLVED] rendering problem (Read 193 times) previous topic - next topic
0 Members and 1 Guest are viewing this topic.

[SOLVED] rendering problem

Hello, everyone,

I installed Artixlinux from the following ISO: artix-plasma-openrc-
Unfortunately, I have the problem that many applications have a black background in the menu bar (File, Edit, ...), so that nothing can be seen. This is for example the case with the application KDE konsole or also with KeePassXC. Also in the Dolphin file browser. If you move the mouse pointer over a file, the file name is highlighted by a black block. Not with Firefox. This phenomenon does not always occur. However, I have noticed that there is a correlation with the following error message:
(console:4308): Gtk-WARNING **: 14:52:29.217: No theme engine could be found in module path "adwaita",
(console:4308): Gtk-WARNING **: 14:52:29.217: No theme engine could be found in module path "adwaita",
(console:4308): Gtk-WARNING **: 14:52:29.221: No theme engine could be found in module path "adwaita",

Everything I found in the net doesn't solve the problem because it mostly refers to gnome.

I hope you can help.


Re: rendering problem

Reply #2
Same.

Re: rendering problem

Reply #3
Can you add some screenshot of qt5ct? Just to see, how is it set.

Re: rendering problem

Reply #4
I have the same issue in KDE. Light Themes from KDE as well as Kate and Dolphin are broken and I do have balck text on black background or white on white or/and black artifacts and white interior (nothing usable).

This is what helped me:
You must uninstall all Artix Themes from terminal and remove all configs from all software, because Artix has hardcoded themes that break all other themes. You can't just go to "settings" and change theme to anything else (e.g. a light thme) - you must remove all hardcoded Artix themes (themes plus hardoded stuff, e.g. in dotfiles of specific hardcoded app -e.g. Kate). There are also other Arch specific changes if the above isn't enough.

Re: rendering problem

Reply #5
I fixed the problem with the following command:

pacman -Rns artix-dark-theme artix-icons artix-sddm-theme artix-desktop-presets artix-gtk-presets artix-qt-presets

Thank you for the help!