Skip to main content
Topic: apulse (Read 66 times) previous topic - next topic
0 Members and 1 Guest are viewing this topic.

apulse

Got no sound from Firefox after installing apulse.
aplay sees following
Code: [Select]
**** List of PLAYBACK Hardware Devices ****
card 0: HDMI [HDA Intel HDMI], device 3: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: HDMI [HDA Intel HDMI], device 7: HDMI 1 [HDMI 1]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: HDMI [HDA Intel HDMI], device 8: HDMI 2 [HDMI 2]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: HDMI [HDA Intel HDMI], device 9: HDMI 3 [HDMI 3]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: HDMI [HDA Intel HDMI], device 10: HDMI 4 [HDMI 4]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: PCH [HDA Intel PCH], device 0: ALC255 Analog [ALC255 Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
**** List of PLAYBACK Hardware Devices ****
card 0: HDMI [HDA Intel HDMI], device 3: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: HDMI [HDA Intel HDMI], device 7: HDMI 1 [HDMI 1]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: HDMI [HDA Intel HDMI], device 8: HDMI 2 [HDMI 2]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: HDMI [HDA Intel HDMI], device 9: HDMI 3 [HDMI 3]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: HDMI [HDA Intel HDMI], device 10: HDMI 4 [HDMI 4]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: PCH [HDA Intel PCH], device 0: ALC255 Analog [ALC255 Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0


Upon modification of defaults Firefox plays sound
/etc/asound.conf
Code: [Select]
defaults.pcm.card 1
defaults.ctl.card 1

Re: apulse

Reply #1
Firefox requires PulseAudio to play any audio.
Man is as good as his tools.

Re: apulse

Reply #2
Firefox does NOT require pulseaudio to play audio.
You can substitute  pulseaudio with apulse from AUR.
Depending on your hardware you may have to redirect the output of apulse.


Re: apulse

Reply #3
apulse is minimal (and was buggy for me) pulseaudio implementation.
Man is as good as his tools.

 

Re: apulse

Reply #4
Sound works for me in Pale Moon, Firefox and Chromium without pulseaudio or apulse. I have these installed and the alsasound service is enabled in the default runlevel. I thought the Artix Firefox package is compiled without a requirement for pulseaudio, unlike the Firefox binary direct from Mozilla?
Code: [Select]
$ pakku -Qs pulse
local/libpulse 13.0-3
    A featureful, general-purpose sound server (client library)
$ pakku -Qs alsa
local/alsa-lib 1.2.2-1
    An alternative implementation of Linux sound support
local/alsa-topology-conf 1.2.2-2
    ALSA topology configuration files
local/alsa-ucm-conf 1.2.2-1
    ALSA Use Case Manager configuration (and topologies)
local/alsa-utils 1.2.2-1
    Advanced Linux Sound Architecture - Utilities
local/alsa-utils-openrc 20180221-1 (openrc-world)
    OpenRC alsa-utils init script
local/zita-alsa-pcmi 0.3.2-3
    The successor of clalsadrv, provides easy access to ALSA PCM devices.