Skip to main content
Topic: [SOLVED] Keyboard not enabled at power on (Read 104 times) previous topic - next topic
0 Members and 1 Guest are viewing this topic.

[SOLVED] Keyboard not enabled at power on

Hi everyone,

I recently installed artix-mate-openrc-20200504-x86_64.iso.
It happens quite often (say about 50% of the time) that when the PC is turned on, the keyboard is not enabled and it is therefore impossible to type the login credentials. So I have to turn off the PC with the power button, and on the second attempt the keyboard usually works.

The same thing happens after the suspension of the system: it is no longer possible to type the password and you have to turn off the whole PC.

Any idea how to fix it?

My pc is a TOSHIBA SATELLITE C670D-109, a slightly outdated machine ... The keyboard, for the rest, is configured correctly.

Thanks in advance.

Giorgio

Re: Keyboard not enabled at power on

Reply #1
Very weird, you can try adding atkbd in /etc/mkinitcpio.conf MODULES array, rebuild initrd (mkinitcpio -P) and reboot.

Re: Keyboard not enabled at power on

Reply #2
Very weird, you can try adding atkbd in /etc/mkinitcpio.conf MODULES array, rebuild initrd (mkinitcpio -P) and reboot.

I tried, but the problem remains. Attached the file /etc/mkinitcpio.conf as it has been modified and the result of "mkinitcpio -P".
Thanks for any further help.

Giorgio

Re: Keyboard not enabled at power on

Reply #3
hi, it seems that earlier toshiba models had frequent problems in this regard
so we ask the google :D

https://forums.linuxmint.com/viewtopic.php?t=152185
https://askubuntu.com/questions/1135591/keyboard-and-touchpad-freeze-after-suspend

add
Code: [Select]
GRUB_CMDLINE_LINUX_DEFAULT="atkdb.reset i8042.nomux "

anther solution speak about
Code: [Select]
GRUB_CMDLINE_LINUX="atkbd.reset=1 i8042.nomux=1 i8042.reset=1 i8042.nopnp=1 i8042.dumbkbd=1"

don't forget update-grub, but that you know...


Re: Keyboard not enabled at power on

Reply #4
hi, it seems that earlier toshiba models had frequent problems in this regard
so we ask the google :D

https://forums.linuxmint.com/viewtopic.php?t=152185
https://askubuntu.com/questions/1135591/keyboard-and-touchpad-freeze-after-suspend

add
Code: [Select]
GRUB_CMDLINE_LINUX_DEFAULT="atkdb.reset i8042.nomux "

anther solution speak about
Code: [Select]
GRUB_CMDLINE_LINUX="atkbd.reset=1 i8042.nomux=1 i8042.reset=1 i8042.nopnp=1 i8042.dumbkbd=1"

don't forget update-grub, but that you know...


OK!
with GRUB_CMDLINE_LINUX_DEFAULT = "atkdb.reset i8042.nomux" added to etc / default / grub the problem has been solved, the keyboard is always recognized, both when the pc is turned on and when it is restored from a suspension. Tested the pc many times during the day.
I had done some research on my own, but without being able to find the posts indicated by you. I'm also learning to search! And it is not so immediate and easy to find adequate answers, if there are ...

For example, after modifying the etc / default / grub file as seen above, launching update-grub I got the WARNING which is shown in the attachment. By doing a search, I found the solution proposed in the second attachment. Further research, however, led me to a place where it was suggested to ignore the WARNING.
Of course I haven't changed anything, I don't have the skills to understand what is best to do!
But everything works for the moment ...
What do you say?

TKS!

George

Re: [SOLVED] Keyboard not enabled at power on

Reply #5
Lvm... Hmm. You use it on 99, 99% not, so just ignore this warning... 😏