Skip to main content
Topic: Suspending / Hibernation Issue with Enlightenment 0.23.1 (Read 170 times) previous topic - next topic
0 Members and 1 Guest are viewing this topic.

Suspending / Hibernation Issue with Enlightenment 0.23.1

Hello All,

I have been configuring my new laptop Artix install for the past several days and have managed to iron out most of the initial setup bugs by searching the forums here and elsewhere. My current problem is quite stubborn, but I hope someone here has the knowledge to help. Hibernation is enabled through my kernel / boot configuration and both loginctl suspend and loginctl hibernate seem to work  perfectly from runlevel 3. However, when Enlightenment is running and I try to suspend or hibernate using its interface, at first it seems to go down normally, but when I try to wake it up I am greeted with a black (backlit) screen displaying only the following two lines of text. I have tried stopping the acpid service before suspending / rebooting. Resuming then produces a backlit screen with no text. I haven't discovered a way to navigate out of this screen so I have to hard reboot to get my system back.

Quote
acpid: client 2710[0:1000] has disconnected
acpid: client 2710[0:1000] has disconnected

When I open a terminal in Enlightenment and run loginctl suspend or loginctl hibernate, the system seems to go down properly and comes back to the desktop environment, but it is frozen with no mouse cursor. The terminal cursor doesn't even blink.

acpid version: 2.0.32
enlightenment version: 0.23.1
elogind 243.7 (243.7)
+PAM +AUDIT -SELINUX +SMACK +UTMP +ACL default-hierarchy=hybrid

Update -- Here's what I've tried. None of this has worked:
Uninstalled all proprietary Nvidia drivers and software, reverting to Nouveau. No effect.
Resinstalled Enlightenment.
Reinstalled acpid.
Tried with acpid not running. Only difference is there is no client disconnection text. Leads me to believe this is either an Nvidia or Xorg  issue.
Added pre and post suspend/hibernate commands to a script in /lib64/elogind/system-sleep/. Verified that the script ran properly and configured it to force a switch to a different virtual terminal before suspend/hibernate, switching back to tty1 after resume. This did not work.
Changed /etc/enlightenment/sysactions.conf to use loginctl instead of systemctl. No effect. I think Enlightenment simply calls loginctl as it should and something goes wrong with Xorg or Nvidia.

Re: Suspending / Hibernation Issue with Enlightenment 0.23.1

Reply #1
Are you sure your X runs on tty1? (you probably are, but had to ask anyway) ACPI and acpid are rarely responsible for resume fails - after the GPU driver, the second most common culprit for failed hibernation cycles is the kernel itself. Would you try with our linux-lts or a third-party kernel like linux-ck/pf/zen?

Additional reading:
https://wiki.gentoo.org/wiki/Suspend_and_hibernate#Can_not_resume_after_suspend
https://01.org/node/3721

Re: Suspending / Hibernation Issue with Enlightenment 0.23.1

Reply #2
Thanks for the response. I'm familiar with the Gentoo article. The Gentoo and Arch wikis are generally my first stop when debugging. That 01.org article looks really useful, especially the tips on how to get some actual debug output pertinent to this problem. I'll try switching to the lts kernel as you suggest.