Skip to main content
Topic solved
This topic has been marked as solved and requires no further attention.
Topic: [SOLVED] outdated imagemagick package? (Read 234 times) previous topic - next topic
0 Members and 1 Guest are viewing this topic.

[SOLVED] outdated imagemagick package?

pacman -Ss imagemagick gives me (only subset of output)
Code: [Select]
world/imagemagick 7.0.10.19-1 [installed]
extra/imagemagick 7.0.10.21-1 [installed: 7.0.10.19-1]
The problem is that 7.0.10.19-1 installs files under usr/lib/perl5/5.30/ but current perl is 5.32.  (I have 27 packages with files under perl 5.30 so the problem probably exists for some of the others also.

Sorry if I've just missed it, but what's the proper way to report this?

Thanks.

Jack

Re: outdated imagemagick package?

Reply #1
It was recently updated, so you should get the newest one once mirrors sync and no perl issue

Re: outdated imagemagick package?

Reply #2
Thanks.  Yes, just a matter of waiting.  Now only two packages in question:  needrestart and perl-dbi.  Neither is critical, so I'll just continue to keep an eye on them.

Re: outdated imagemagick package?

Reply #3
I had a perl warning on updating. Searching suggested this could happen from AUR packages or orphans but they aren't either, although 3 might be orphans, but the rest can't be removed as other packages depend on them. No obvious actual issues from this have been observed yet from my usage though. And the update included imagemagick 7.0.10.20-1.
Code: [Select]
(1/1) Warn about old perl modules
WARNING: '/usr/lib/perl5/5.30' contains data from at least 10 packages which will NOT be used by the installed perl interpreter.
 -> Run the following command to get a list of affected packages: pacman -Qqo '/usr/lib/perl5/5.30'
$ pacman -Qqo '/usr/lib/perl5/5.30'
perl-encode-locale
perl-error
perl-extutils-pkgconfig
perl-file-listing
perl-html-parser
perl-io-html
perl-parse-yapp
perl-uri
perl-www-robotrules
perl-yaml

Re: outdated imagemagick package?

Reply #4
The update today that included imagemagick-7.0.10.21-1 fixed this, apart from perl-yaml. As it's a potential orphan package, at least nothing else depends on that on my system, I removed it.

Re: outdated imagemagick package?

Reply #5
no, imagemagic is up-to-date, perl-yaml and perl-dbi was fixed



Re: outdated imagemagick package?

Reply #6
I'm fully updated and re-installed perl-yaml (which seems redundant on my system anyway, probably an old dependency left by something else) and got that warning about it when I did, so perl-yaml still needs a rebuild (if it's used by anyone else.)
(1/1) Warn about old perl modules
WARNING: '/usr/lib/perl5/5.30' contains data from at least 1 packages which will NOT be used by the installed perl interpreter.
 -> Run the following command to get a list of affected packages: pacman -Qqo '/usr/lib/perl5/5.30'
$ pacman -Qqo '/usr/lib/perl5/5.30'
perl-yaml
imagemagick is up to date now but it wasn't this morning, and last night it was an even older version. But that's just typical updates for you... ;D
perl-yaml is not used by any repo package, whether it is used by any AUR ones who knows.
$ pactree -rsd1 perl-yaml
perl-yaml

Re: outdated imagemagick package?

Reply #7
Perl-yaml is in [extra] and is necessary makedepends for networkmanager, if I see right

Re: outdated imagemagick package?

Reply #8
Hi, all mirrors return error 404, when i atempt to install Imagemagick. A fix would be very appreciated.

Re: outdated imagemagick package?

Reply #9
Hi, all mirrors return error 404, when i atempt to install Imagemagick. A fix would be very appreciated.

not really, check your internet connection or mirrors.. i downloaded it now

Code: [Select]
pacman -S imagemagick
varování: imagemagick-7.0.10.24-2 je aktuální -- přeinstalovat
řeší se závislosti..
kontrola konfliktních balíčků...

Balíčky  (1) imagemagick-7.0.10.24-2

Celková velikost ke stažení:    2,52 MiB
Celková velikost po instalaci:    9,77 MiB
Odhadovaná velikost aktualizace:   0,00 MiB

:: Pokračovat v instalaci? [A/n]
:: Stahují se balíčky...
 imagemagick-7.0.10.24-2-x86_64                2,5 MiB   922 KiB/s 00:03 [########################################] 100%
(1/1) kontrola klíčů v klíčence                                          [########################################] 100%
(1/1) kontrola integrity balíčků                                         [########################################] 100%
(1/1) načítání balíčku                                                   [########################################] 100%
(1/1) kontrola konfliktů souborů                                         [########################################] 100%
(1/1) kontrola volného místa na disku                                    [########################################] 100%
:: Zpracovávání změn balíčku...
(1/1) přeinstalovávám imagemagick                                        [########################################] 100%
:: Probíhá potransakční hook...
(1/1) Warn about old perl modules



 

Re: outdated imagemagick package?

Reply #12
Are your package databases up to date?
Oh dear. It was that easy.. It worked after addind "y" to the -S. So i have to ocasionally refresh the database. Im still learning the ropes in a rolling release.
Thank you both.