Skip to main content
Topic solved
This topic has been marked as solved and requires no further attention.
Topic: [RESOLU] Pamac "Aucun paquet trouvé" (Read 204 times) previous topic - next topic
0 Members and 1 Guest are viewing this topic.

[RESOLU] Pamac "Aucun paquet trouvé"

Bonjour,
Première petite question, j'ai ajouté le gestionnaire graphique Pamac, mais dans "Naviguer", à droite des catégories j'ai "Aucun paquet trouvé". Est-il possible de retrouver cet affichage?
Une installation a été faite sur un autre ordinateur qui elle ne rencontre pas ce défaut.
Seule différence, j'avais installé le paquet  "pamac-gtk" alors que sur l'autre "pamac".
L'autre ordi est ensuite passé sur "pamac-gtk" sans rencontrer le défaut.
Merci pour l'aide

Re: Pamac "Aucun paquet trouvé"

Reply #1
Bonjour,
Première petite question, j'ai ajouté le gestionnaire graphique Pamac, mais dans "Naviguer", à droite des catégories j'ai "Aucun paquet trouvé". Est-il possible de retrouver cet affichage?
Une installation a été faite sur un autre ordinateur qui elle ne rencontre pas ce défaut.
Seule différence, j'avais installé le paquet  "pamac-gtk" alors que sur l'autre "pamac".
L'autre ordi est ensuite passé sur "pamac-gtk" sans rencontrer le défaut.
Merci pour l'aide

Hello,

J'ai déjà eu ce désagrément, mais les informations ont réapparues par la suite sans que je fasse quelque chose de spécial (sauf peut-être une mise à jour).

As-tu vérifié et fait les mises à jour dans pamac ?
Si oui, essaye aussi sudo pacman -Syyu

Chez moi, j'ai pamac-gtk 9.5.6-1 et j'ai le détail des rubriques.

Code: [Select]
jp-artix:[jp]:~$ neofetch
                   '                      [email protected]
                  'o'                     -----------
                 'ooo'                    OS: Artix Linux x86_64
                'ooxoo'                   Kernel: 5.7.8-artix1-1
               'ooxxxoo'                  Uptime: 3 hours, 17 mins
              'oookkxxoo'                 Packages: 1141 (pacman)
             'oiioxkkxxoo'                Shell: bash 5.0.17
            ':;:iiiioxxxoo'               DE: Xfce
               `'.;::ioxxoo'              WM: Xfwm4
          '-.      `':;jiooo'             WM Theme: Daloa
         'oooio-..     `'i:io'            Theme: Adwaita [GTK2/3]
        'ooooxxxxoio:,.   `'-;'           Icons: oxygen [GTK2], matefaenzadark 
       'ooooxxxxxkkxoooIi:-.  `'          Terminal: xfce4-terminal
      'ooooxxxxxkkkkxoiiiiiji'            Terminal Font: Roboto Mono 14
     'ooooxxxxxkxxoiiii:'`     .i'        CPU: AMD Ryzen 5 3600 (12) @ 3.600GHz
    'ooooxxxxxoi:::'`       .;ioxo'       GPU: NVIDIA GeForce GT 710
   'ooooxooi::'`         .:iiixkxxo'      Memory: 1832MiB / 16006MiB

Re: Pamac "Aucun paquet trouvé"

Reply #2
Salut,
Les mise à jour sont ok.
Avec "sudo pacman -Syyu", j'ai un avertissement:
-------
dbus-openrc : la version locale (20202602-1) est plus récente que le system (20200711-1)
il n'y a rien à faire
-------
J'ai la même version que toi de pamac
Code: [Select]
artix:[gebull]:~$ neofetch
                   '                      [email protected]
                  'o'                     ------------
                 'ooo'                    OS: Artix Linux x86_64
                'ooxoo'                   Host: SATELLITE PRO C870-15H PSC8FE-0
               'ooxxxoo'                  Kernel: 5.7.8-artix1-1
              'oookkxxoo'                 Uptime: 12 mins
             'oiioxkkxxoo'                Packages: 670 (pacman)
            ':;:iiiioxxxoo'               Shell: bash 5.0.17
               `'.;::ioxxoo'              Resolution: 1600x900
          '-.      `':;jiooo'             DE: Xfce
         'oooio-..     `'i:io'            WM: Xfwm4
        'ooooxxxxoio:,.   `'-;'           WM Theme: Default
       'ooooxxxxxkkxoooIi:-.  `'          Theme: Artix-dark [GTK2/3]
      'ooooxxxxxkkkkxoiiiiiji'            Icons: matefaenzadark [GTK2/3]
     'ooooxxxxxkxxoiiii:'`     .i'        Terminal: xfce4-terminal
    'ooooxxxxxoi:::'`       .;ioxo'       Terminal Font: Roboto Mono 11
   'ooooxooi::'`         .:iiixkxxo'      CPU: Intel i3-2310M (4) @ 2.100GHz
  'ooooi:'`                `'';ioxxo'     GPU: AMD ATI Radeon HD 6610M/7610M
 'i:'`                          '':io'    Memory: 417MiB / 1944MiB

Avec un "pacman -S pamac" je me rends compte qu'il y a un conflit de paquets entre pamac et pamac-gtk.
Je vais faire en sorte de n'avoir que pamac-gtk d'installé.

Re: Pamac "Aucun paquet trouvé"

Reply #3
Salut,
Les mise à jour sont ok.
Avec "sudo pacman -Syyu", j'ai un avertissement:
-------
dbus-openrc : la version locale (20202602-1) est plus récente que le system (20200711-1)
il n'y a rien à faire

Tu as installé des paquets Aur ?

Mais ce n'est pas grave.

-------
J'ai la même version que toi de pamac

Ok, c'est normal.
 
    
Avec un "pacman -S pamac" je me rends compte qu'il y a un conflit de paquets entre pamac et pamac-gtk.
Je vais faire en sorte de n'avoir que pamac-gtk d'installé.

Alors il vaut mieux désinstaller pamac.

J'ai pamac-cli, pamac-common et pamac-gtk

Si le problème persiste, tu peux éventuellement essayer de réinstaller tous les paquets déjà présents sur ton système :
sudo pacman -S $(pacman -Qnq)
Je sais, ça fait un peu Windoze, mais j'ai déjà eu des petits problèmes de dépendance que je n'ai pas réussi à régler autrement... ::)

Re: Pamac "Aucun paquet trouvé"

Reply #4
Petite correction, je disais avoir un conflit mais c'était normal.
Avec la commande "pacman -S pamac", je tentais d'installer pamac alors que pamac-gtk était déjà installé...
J'ai donc réinstallé pamac-gtk, ça ne marche toujours pas.
J'ai réinstallé tous les paquets, ça ne marche pas non plus.
Tu dis avoir "pamac-cli, pamac-common et pamac-gtk", si je comprends bien, c'est le paquet de pamac plus ses dépendances.
C'est quoi la commande pour avoir ces informations?
Je me repenche sur le sujet jeudi prochain pour notre prochaine réu GEBULL.
Merci pour l'aide!

Re: Pamac "Aucun paquet trouvé"

Reply #5
Bonjour,

Petite correction, je disais avoir un conflit mais c'était normal.
Avec la commande "pacman -S pamac", je tentais d'installer pamac alors que pamac-gtk était déjà installé...
J'ai donc réinstallé pamac-gtk, ça ne marche toujours pas.
J'ai réinstallé tous les paquets, ça ne marche pas non plus.

Bon, je vais chercher un peu, car j'ai déjà ce bug uniquement sur mon PC portable mais pas sur mon PC de bureau.
C'est bizarre, car les deux PC ont exactement les mêmes distributions...
Ce n'est pas un bug propre à Artix car il est présent dans d'autres distributions.

Il y a un moyen de contourner ce bug :
https://forum.endeavouros.com/t/how-to-fix-pamac-aur-pamac-aur-git-empty-list-on-start/3938

Dans le détail :
sudo pacman -S binutils make
ou carrément sudo pacman -Syu base-devel linux-headers
Dans les préférences de pamac il faut activer la prise en charge d'Aur (sans rien cocher d'autre).
Cliquer sur "Mise à jour" ou sudo pacman -Syyu
Ensuite à l'aide le la loupe il faut chercher le paquet downgrade (Aur) et l'installer.

Et pour finir :
sudo downgrade archlinux-appstream-data
choisir la version archlinux-appstream-data    20200103
Répondre par o (oui) à la question : Ajouter archlinux-appstream-data dans la liste des paquets à ne pas mettre à jour automatiquement ? [o/n]

Ensuite pour plus de sécurité il vaut mieux désactiver la prise en charge d'Aur dans les préférences de pamac.

Si au bout d'un certain temps on désire supprimer archlinux-appstream-data de la liste des paquets à ne pas mettre à jour automatiquement :
sudo mousepad /etc/pacman.conf
Supprimer la ligne IgnorePkg = archlinux-appstream-data

Je n'utilise pas souvent les "Catégories",  mais c'est mieux de les avoir.  :)

Tu dis avoir "pamac-cli, pamac-common et pamac-gtk", si je comprends bien, c'est le paquet de pamac plus ses dépendances.
C'est quoi la commande pour avoir ces informations?

Tu peux faire une recherche avec la loupe dans pamac puis tu cliques sur le paquet qui t'intéresse ; tu auras un onglet "Dépendances".

Mais la commande pacman est :
jp-artix:[jp]:~$ pacman -Qi pamac-gtk
Nom                      : pamac-gtk
Version                  : 9.5.6-1
Description              : A Package Manager based on libalpm with AUR and
                           Appstream support
Architecture             : x86_64
URL                      : https://gitlab.manjaro.org/applications/pamac
Licences                 : GPL3
Groupes                  : --
Fournit                  : pamac=9.5.6-1  pamac-gtk=9.5.6-1
Dépend de                : pamac-cli  gtk3>=3.22
Dépendances opt.         : --
Requis par               : --
Optionnel pour           : --
Est en conflit avec      : pamac  pamac-aur  pamac-gtk-dev
Remplace                 : pamac
Taille installée         : 577,93 KiB
Paqueteur                : Artix Build Bot <[email protected]>
Compilé le               : mer. 24 juin 2020 04:01:53
Installé le              : lun. 13 juil. 2020 11:42:08
Motif d’installation     : Explicitement installé
Script d’installation    : Oui
Validé par               : Signature


Je me repenche sur le sujet jeudi prochain pour notre prochaine réu GEBULL.
Merci pour l'aide!

De rien.
Le premier qui aura trouvé a gagné  :D

Re: Pamac "Aucun paquet trouvé"

Reply #6
C'est bon, ça marche!
J'ai fait la manip avec un ami différemment de ton post il me semble.
J'ai gardé quelques impression écran pour pouvoir m'en souvenir et en reparler ici un peu plus tard.
En gros, nous avons téléchargé "archlinux-appstream-data    20200103" qui n'était pas sur l'ordi pour pouvoir downgrader.
Et j'ai ajouté manuellement "IgnorePkg = archlinux-appstream-data" au fichier /etc/pacman.conf
Par contre cette solution ne me semble pas parfaite...
Faut il remonter le bug pour avoir une mise à jour de archlinux-appstream-data ou de pamac?
En suivant le lien que tu avais donné, je pense que la demande est déjà faite: https://gitlab.manjaro.org/applications/pamac/-/issues/772
Merci pour l'aide



Re: Pamac "Aucun paquet trouvé"

Reply #7
C'est bon, ça marche!
Super  8)

J'ai fait la manip avec un ami différemment de ton post il me semble.
Cela revient au même, car vous avez installé "manuellement" le paquet en question.
J'en avais profité pour te montrer comment activer les dépôts Aur depuis pamac pour avoir le paquet downgrade.

J'ai gardé quelques impression écran pour pouvoir m'en souvenir et en reparler ici un peu plus tard.
Oui, ça pourra toujours intéresser quelqu'un.

Par contre cette solution ne me semble pas parfaite...
Faut il remonter le bug pour avoir une mise à jour de archlinux-appstream-data ou de pamac?
Oui, le  bug a déjà été signalé.
Le bug ne provient pas forcément de archlinux-appstream-data, car chez nous la version 20200720-1 de ce paquet  fonctionne sur deux postes et pas sur un troisième, alors qu'ils utilisent la même version Artix XFCE avec les mêmes applications...

Merci pour l'aide

Avec plaisir  8)


Re: Pamac "Aucun paquet trouvé"

Reply #8
Donc, pour expliquer ce que j'avais fait:
En console dans /var/cache/pacman/pkg/
Code: [Select]
ls -al | grep appstream-data
J'ai 2 fichiers archlinux-appstream-data-20200612 et ...-20200720
Je télécharge le fichier ...-20200103 sur https://archive.archlinux.org/packages/a/archlinux-appstream-data/
En console dans le répertoire du fichier téléchargé
Code: [Select]
sudo pacman -U archlinux-appstream-data-20200103-1-any.pkg.tar.zst
Puis j'ai modifié le fichier pacman.conf
En console dans le répertoire /etc
Code: [Select]
sudo nano pacman.conf
Sur la ligne IgnorePkg j'ai supprimé le # en début de ligne et ajouté archlinux-appstream-data après le =
A+

Re: Pamac "Aucun paquet trouvé"

Reply #9
Bonjour,

Merci pour le détail de votre intervention.

Vous avez donc fait "manuellement" ce qu'aurait fait sudo downgrade archlinux-appstream-data

C'est une bonne méthode qui évite d'installer downgrade depuis les paquets Aur.

Il serait bien de renommer le titre en [Resolu] Pamac  "Aucun paquet trouvé".

@+

Re: [RESOLU] Pamac "Aucun paquet trouvé"

Reply #10
En suivant le lien que tu m'avais envoyé, il semble que le bug soit plutôt dans: appstream-glib
Plus qu'à attendre une mise à jour de ce fichier...

Re: [RESOLU] Pamac "Aucun paquet trouvé"

Reply #11
En suivant le lien que tu m'avais envoyé, il semble que le bug soit plutôt dans: appstream-glib
Plus qu'à attendre une mise à jour de ce fichier...
Oui, j'ai vu, mais j'ai un petit doute, car ça fonctionne bien sur deux machines sur trois (installations identiques).
Mais bon, ce n'est que de la supputation de ma part  :)