Skip to main content
Topic: Timezone Error (Read 148 times) previous topic - next topic
0 Members and 1 Guest are viewing this topic.

Timezone Error

i do ...
Code: [Select]
ln -sf /usr/share/zoneinfo/Europe/Skopje /etc/localtime
hwclock -w
... and the output of ...
Code: [Select]
ls -l /etc/localtime
... is +2 hours of what it actually is... I've been trying to find a solution for over a week now, but nothing seems to help. Anyone knows a simple solution to this? Thanks in advance


Re: Timezone Error

Reply #2
yes. i got it working after changing windows' time to use UTC. thanks for offering help anyways.

Re: Timezone Error

Reply #3
you find here a lot information here, as usually: https://wiki.archlinux.org/index.php/System_time

inclusive:

Quote
UTC in Windows
To dual boot with Windows it is recommended to configure Windows to use UTC, rather than Linux to use localtime. (Windows by default uses localtime [1].)

It can be done by a simple registry fix: Open regedit and add a DWORD value for 32-bit Windows, or QWORD for 64-bit one, with hexadecimal value 1 to the registry:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\TimeZoneInformation\RealTimeIsUniversal
You can do this from an Administrator Command Prompt running:

reg add "HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\TimeZoneInformation" /v RealTimeIsUniversal /d 1 /t REG_QWORD /f
(Replace QWORD with DWORD for 32-bit Windows.)

Alternatively, create a *.reg file (on the desktop) with the following content and double-click it to import it into registry:

Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\TimeZoneInformation]
     "RealTimeIsUniversal"=qword:00000001
(Replace qword with dword for 32-bit Windows.)

Should Windows ask to update the clock due to DST changes, let it. It will leave the clock in UTC as expected, only correcting the displayed time.

The #Hardware clock and #System clock time may need to be updated after setting this value.