Skip to main content
Topic solved
This topic has been marked as solved and requires no further attention.
Topic: [SOLVED]I installed gamemode and gamemode-32bit from aur. Did I mess something?  (Read 82 times) previous topic - next topic
0 Members and 1 Guest are viewing this topic.

[SOLVED]I installed gamemode and gamemode-32bit from aur. Did I mess something?

Well, gamemode-32bit depends on lib32-systemd, which is now installed on my system. I installed from pamac, so I didn't see if this removed any important package. I am on a runit installation. Thanks!

Re: I installed gamemode and gamemode-32bit from aur. Did I mess something?

Reply #1
just edit manually PKGBUILD and replace lib32-systemd -> lib32-eudev (and systemd -> eudev in gamemode)

EDIT: tested, i can build it after this editation.

Re: I installed gamemode and gamemode-32bit from aur. Did I mess something?

Reply #2
just edit manually PKGBUILD and replace lib32-systemd -> lib32-eudev (and systemd -> eudev in gamemode)

EDIT: tested, i can build it after this editation.

Thanks, but for me I receive some errors in lib32-gamemode:

Could not the dependency ib32-eudev and could not find the dependency eudev-systemdcompat

Re: I installed gamemode and gamemode-32bit from aur. Did I mess something?

Reply #3
Thanks, but for me I receive some errors in lib32-gamemode:

Could not the dependency ib32-eudev and could not find the dependency eudev-systemdcompat

Ok, I changed eudev-systemdcompat for libsystemd-eudev-standalone,

but I receive a invalid gpg key error when I try to build lib32-kmod :|

Re: I installed gamemode and gamemode-32bit from aur. Did I mess something?

Reply #4
Ok, I changed eudev-systemdcompat for libsystemd-eudev-standalone,

but I receive a invalid gpg key error when I try to build lib32-kmod :|
why are you complicating it? You did compile lib32-gamemode well with lib32-eudev ;-) just use command "pacman -S lib32-eudev"

lib32-gamemode have systemd even disabled! https://aur.archlinux.org/cgit/aur.git/tree/PKGBUILD?h=lib32-gamemode

my build log https://paste.artixlinux.org/view/234e3ac6

Re: I installed gamemode and gamemode-32bit from aur. Did I mess something?

Reply #5
why are you complicating it? You did compile lib32-gamemode well with lib32-eudev ;-) just use command "pacman -S lib32-eudev"

lib32-gamemode have systemd even disabled! https://aur.archlinux.org/cgit/aur.git/tree/PKGBUILD?h=lib32-gamemode

my build log https://paste.artixlinux.org/view/234e3ac6

Thanks, but I could not find this package, so I thought it doesn't exist.

I got this error:
error: target not found: lib32-eudev


is any thing missing?