Skip to main content
Topic: No Desktop environment (Read 364 times) previous topic - next topic
0 Members and 1 Guest are viewing this topic.

No Desktop environment

After installing the Artix xface4 openrc and subsequent post installation , I have rebooted Artix. However, it goes to straight forward to terminal instead of desktop environment.  How to get desktop environment.

Re: No Desktop environment

Reply #1
pacman -S displaymanager-openrc. Install a login manager example: sddm. Set which login manager in /etc/conf.d/xdm

rc-update add xdm default
rc-service xdm start

Re: No Desktop environment

Reply #2
xdm already installed in run level default, skipping and xdm has already started. What to do

Re: No Desktop environment

Reply #3
pacman -S displaymanager-openrc. Install a login manager example: sddm. Set which login manager in /etc/conf.d/xdm

rc-update add xdm default
rc-service xdm start

"Install a login manager example: sddm."

https://wiki.artixlinux.org/Main/Installation#Desktop_Environment

I think in this case xdm is a service script, although there is an actual dm called xdm, but that's probably the xorg-xdm package. There doesn't seem to be any openrc-xdm package at all in the repos, but it is in the AUR, perhaps it's under a different name. I'm using startx and have no xdm service at all, so it's not part of openrc.

Re: No Desktop environment

Reply #4
How to install login manager. I feel i have already installed and followed above link.

Re: No Desktop environment

Reply #5
Because openrc “xdm” script is displaymanager-openrc and allows choosing which login manager you want including xdm


"Install a login manager example: sddm."

https://wiki.artixlinux.org/Main/Installation#Desktop_Environment

I think in this case xdm is a service script, although there is an actual dm called xdm, but that's probably the xorg-xdm package. There doesn't seem to be any openrc-xdm package at all in the repos, but it is in the AUR, perhaps it's under a different name. I'm using startx and have no xdm service at all, so it's not part of openrc.

Re: No Desktop environment

Reply #6
I have installed sddm and edit to nano /etc/xdm added sddm in the file. However, still going straight to terminal after rebooting. What to do. ?. Is it not suitable layman>

 

Re: No Desktop environment

Reply #7
I have installed sddm and edit to nano /etc/xdm added sddm in the file. However, still going straight to terminal after rebooting. What to do. ?. Is it not suitable layman>
without providing any logs we only could use a crystal ball to help you…
Code: [Select]
lspci 
Code: [Select]
dmesg
Code: [Select]
cat  /var/log/Xorg.0.log

Re: No Desktop environment

Reply #8
Actually I got perplexed when I seen your request for log file because i dont know how to save the log file in my situation. Because no desktop with browser. After googling I got some idea and saved the command line and attaching the saved log text file through another distributions.

Re: No Desktop environment

Reply #9
Quote
I have installed sddm and edit to nano /etc/xdm added sddm in the file.
The file is "/etc/conf.d/xdm" and the is variable "DISPLAYMANAGER" which you need to set to xdm

The whole file might look like this:

Code: [Select]
# We always try and start X on a static VT. The various DMs normally default
# to using VT7. If you wish to use the xdm init script, then you should ensure
# that the VT checked is the same VT your DM wants to use. We do this check to
# ensure that you haven't accidentally configured something to run on the VT
# in your /etc/inittab file so that you don't get a dead keyboard.
CHECKVT=7

# What display manager do you use ?  [ xdm | gdm | kdm | gpe | entrance ]
# NOTE: If this is set in /etc/rc.conf, that setting will override this one.
DISPLAYMANAGER="sddm"

This file will be present only if you have package "displaymanager-openrc" installed.
To start it when you start your machine add it into default runleve.
Code: [Select]
rc-update add xdm default

after that either reboot or you can start service manually like this:
Code: [Select]
rc-service xdm start

PS: If i missed your point I hope this will at worst feed search engines with answers.
Man is as good as his tools.

Re: No Desktop environment

Reply #10
I have changed  xdm  ("/etc/conf.d/xdm" and the is variable "DISPLAYMANAGER" which you need to set to xdm).
while running rc-update add xdm default , it  says that already installed. Then rebooted still goes to terminal and login prompt. (same as before)
I have also applied  rc-service xdm start,  it says xdm already started.

Re: No Desktop environment

Reply #11
than try restart with verbose option.
Code: [Select]
rc-service --verbose xdm restart

This should print some messages / logs, I hope you can post the output here.
Man is as good as his tools.

Re: No Desktop environment

Reply #12
I'd just like to say that I'm having the same problem. I'm in VirtualBox using lightdm.

Re: No Desktop environment

Reply #13
[   12.853576] b43 ssb0:0: Direct firmware load for b43/ucode15.fw failed with error -2
[   12.853636] b43 ssb0:0: Direct firmware load for b43-open/ucode15.fw failed with error -2
A dmesg error suggests you can install the b43-firmware package from the AUR for wireless to work. This won't affect the desktop starting though.
It works here - I installed displaymanager-openrc and sddm. Then edited /etc/conf.d/xdm:
Code: [Select]
#DISPLAYMANAGER="xdm"
DISPLAYMANAGER="sddm"
Enabled service:
Code: [Select]
$ sudo rc-update add xdm default
I commented out my  pre-existing  startx content in .xinitrc and .bashrc, it worked and the sddm login page appeared, and I could get to the desktop.
I could get to a terminal prompt at boot by removing the xdm service again:
Code: [Select]
$ sudo rc-update delete xdm default
Then after logging in at the terminal prompt I tried
Code: [Select]
$ sudo /etc/init.d/xdm start
which worked, and then after rebooting:
Code: [Select]
$ sudo sddm
which also worked - not sure if that would start a root x but it also got the login page and desktop.
If you have this issue, then try to restart xdm as previously suggested by SGOrava to hopefully get some messages in the terminal login, you could also try starting the dm itself like I did above. Another thing could be to check you are on the right tty for X - (CTRL) ALT F(1-7) should switch through tty's, CTRL is only needed when X has started. I think I've seen cases when X starts on tty7 yet you stay on tty1, usually when I got my personal config wrong.

Re: No Desktop environment

Reply #14
Upon running the command rc-service --verbose xdm restart , the output as follows:-

Code: [Select]
xdm.Executing: /usr/lib/openrc/sh/openrc-run-sh /usr/lib/ openrc-run.sh /etc/initd/xdm.stop
stopping xdm....
Will stop usr/bin/xdm
start-stop-demeon : no matching process found
xdm.xdm.Executing: /usr/lib/openrc/sh/openrc-run-sh /usr/lib/ openrc-run.sh /etc/initd/xdm.start
your XDM value is invalid
No. xdm executable could be found on system
Error : Please set lyour DISPLAYMANAGER variable in etc/conf.d/xdm
or instal x11-apps/xdm package
gettign up xdm
shart-stop deamon: /usr/bin/xdm
could not start the display manager